Post by Calis1978 » Fri Nov 18, 2016 7:12 pm

Hello,

I would like to upgrade my current opencart store (version 1.5.4) to a 2.x version.
Since i know i will have incompatibilities with extentions i will have to search for and try newer ones, therefore i don't know which 2.x version to choose yet.

My first thought was getting my current store running on a safe test environment (on a raspberry Pi2).

A fresh install of opencart 1.5.4 works perfectly. No erro messages or warnings.
A ll 2.x fresh installs also workwithout errors or warnings. The raspberry can handle it perfectly.

The problem comes with my current store.
I made a backup of the database on the live store. Took care to uncheck all the tavles created by extentions.
Copied the files of my current store to the root of the freshly installed one and restored the database from the live store on the test store.

No error messages or warnings.
I see categories in the backend, orders, customers. No products.
In the frontend there have been no changes to the text. Only the images have disappeared.

What am i doing wrong?

Newbie

Posts

Joined
Tue Jul 30, 2013 8:35 pm

Post by IP_CAM » Sat Nov 19, 2016 12:51 am

What am i doing wrong?
...by basically talking about an UPGRADE, because one cannot UPGRADE an existing v.1.5.x Software, strictly technically, one can only install a NEW v.2.x Software, and then, piece by piece, find out, if the same Extensions exist, as one used before, matching exactly the Version Number and the THEME used, and then download/install those extensions again.

Like one cannot UPGRADE a WIN XP into a WIN 10 either...., by just overwriting an existing XP-Code with the Souce Code of a WIN10... :laugh:

And when it comes to the DB, it's basically the SAME, one need's to get the DB-Content into it's new DB, onto the right place, but since certain changes exist, some TABLES and Sections do not longer use the same NAMES and Settings, and do not store the same Content, therefore, one is required, to adapt this, to make it work again, as well.

This would be a clean way, not leaving any old CRAB in the new Shop Software, like it would be the case, if one foolishly tries to just overwrite an existing software. And some DEV's offer paid assistance, to achieve such. Some links are below.
It just depends on, how important your Shop is for you, income-wise at least. Either play around, like many do, usually just ending up in frustration, or then,

https://www.opencart.com/index.php?rout ... ember=peku

https://github.com/pekka2/OpenCart-Migr ... grade-Tool

https://www.opencart.com/index.php?rout ... n_id=16493

https://www.opencart.com/index.php?rout ... ch=upgrade

And NEVER overwrite an existing Shop Site, or it's DB, one does not unload / park the new Car on top of the old One either.

And to your images, they are placed in a differently named /image/... Subdirectory now.
Good Luck ;)
Ernie

Ernie's OpenCart v.1.5.6.5 LIGHT + OpenShop Admin v.1.75 Test Sites
http://www.ebikes.li - http://www.evelo.li - http://www.openshop.li
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by Calis1978 » Sun Nov 20, 2016 11:28 pm

Thank you for your answer.

But.....

Opencart 2.x installations now have an "upgrade.txt" telling that it is now possible to upgrade an existing 1.5.x installation to this 2.x version.

However, my problem is not with that.

My problem is way before we get there....

I do have a clean install of the same version as my live shop. (1.5.4)
Importing the database (backup from my live store without extentions) works.
In the test encironment i can see categories, customers, sales, but not products.

So i am not even trying to upgrade yet. Just moving the database from my live store to the test environment.

In your car analogy. There is no new car yet. Just parking it in a different parking spot makes half the car disappear.

Newbie

Posts

Joined
Tue Jul 30, 2013 8:35 pm

Post by IP_CAM » Mon Nov 21, 2016 6:28 am

I don't know, but when I download the OC v.2.3.0.2-compiled.zip from the official Source,
I only find this, clearly mentioning nothing about OC-2 anywhere, in Contrary:

Code: Select all

///////////////////////////////////////
///    OpenCart V1.5.x TO 1.5.x     ///
///      Upgrade Instructions       ///
///     http://www.opencart.com     ///
///////////////////////////////////////
NOTE: THIS IS FOR UPGRADE ON EXISTING INSTALLS ONLY!
But read this forum a little, it's full of infos and failures of those, trying such on running Sites, and (formerly) working Databases. :D

Good Luck! ;)
Ernie

Ernie's OpenCart v.1.5.6.5 LIGHT + OpenShop Admin v.1.75 Test Sites
http://www.ebikes.li - http://www.evelo.li - http://www.openshop.li
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by Calis1978 » Fri Nov 25, 2016 6:07 am

Ok, i don't get it.

I just downloaded opencart 2.3.0.2-compiled.zip again. From the official source and it has an upgrade.txt in the root directory saying

##########################################
THIS IS FOR UPGRADING EXISTING OPENCART 1.5.x STORES ONLY
THIS IS FOR UPGRADING EXISTING OPENCART 1.5.x STORES ONLY
THIS IS FOR UPGRADING EXISTING OPENCART 1.5.x STORES ONLY
##########################################

At the bottom that file has a link http://docs.opencart.com/upgrading/
Where it states:
"
Updating from 1.5.x to the latest version

Updating from a 1.5.x version to the newest version is a simpler process than updating from 1.4.x. To access the latest version of OpenCart, visit the Download page:
Image

Newbie

Posts

Joined
Tue Jul 30, 2013 8:35 pm

Post by IP_CAM » Fri Nov 25, 2016 8:39 am

///////////////////////////////////////
/// OpenCart V1.5.x TO 1.5.x ///
/// Upgrade Instructions ///
/// http://www.opencart.com ///
///////////////////////////////////////
Read, what's written, when it clearly says 1.5.0 to 1.5.x (later Subversions, up to v.1.5.6.4)
---
But if you want to find out, what this crab-file is still doing in OC-2, you'll have to get in Contact with our Master of the OC Universe, he would be the only one to know. I'm complaining about this around here for months already, but he don't wanna hear me, and those from the inner circle seem to have no influence, when it comes to such (highly important!) details... :-\
---
Still, it's a foolish attempt, trying to 'upgrade' something like OC, from a Version 1 to a brandnew Version 2, especially under the aspect, neither the DB, nor most EXTENSIONS would/could still function. If it still would be the same, there would be no need, to even change a Version Number. And OC is an OPEN System, everybody could add/change/modify most everything, Not even a simple MS WINDOWS Security Update would longer function, in such a Case, if external DEV's could change so much Code, as it is possible in a System like OC.

Again, compare it with a Car, even the Tire-Size could be diffferent, in a later Version, and no-one would expect, to be able to use a simple Oil Filter or a Muffler from the former Version, just like that.
---
So, better take it, as it comes, you did not have to pay for, so, Mr. OC has no obligation, to make it as easy as possible, on you, me, or anyone else... :D
Good Luck ;)
Ernie
---
PS: As one can easy find out, when fully reading the OC Upgrade Doc's, as linked above !
---
Image

Ernie's OpenCart v.1.5.6.5 LIGHT + OpenShop Admin v.1.75 Test Sites
http://www.ebikes.li - http://www.evelo.li - http://www.openshop.li
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by deepakrajput » Mon Feb 13, 2017 10:19 am

It really works to upgrade your theme into a new version.

Opencart - Main Site


New member

Posts

Joined
Sat Apr 09, 2016 3:35 am
Location - CA
Who is online

Users browsing this forum: No registered users and 20 guests