Post by platypuspuzzles » Thu Jun 05, 2014 11:38 pm

I have used shared sessions selected, in order to be able for my shopping cart to be used accross domains, however this isn't working.

No errors in error log.

Another issue occuring, that 'may' be related - I can't get https:// to load onto secondary multi site domains

domain3.com
domain4.com etc

Active Member

Posts

Joined
Sun Jan 23, 2011 8:11 pm

Post by cwswebdesign » Fri Jun 06, 2014 2:42 am

platypuspuzzles wrote:I have used shared sessions selected, in order to be able for my shopping cart to be used accross domains, however this isn't working.

No errors in error log.

Another issue occuring, that 'may' be related - I can't get https:// to load onto secondary multi site domains

domain3.com
domain4.com etc
It's an incomplete solution and won't work. Unfortunately, I haven't found a solution for it elsewhere but it would be nice to have.

DL

This account is inactive. Look for us under the name 'EvolveWebHosting' and contact us under that username.

Thanks!


User avatar
Active Member

Posts

Joined
Sun Dec 11, 2011 12:26 am
Location - USA

Post by platypuspuzzles » Fri Jun 06, 2014 7:26 am

thank you!

Is the incomplete solution to both the shared session not working, and mutli SSL URL, or just the shared session

Active Member

Posts

Joined
Sun Jan 23, 2011 8:11 pm

Post by cwswebdesign » Fri Jun 06, 2014 8:22 am

platypuspuzzles wrote:thank you!

Is the incomplete solution to both the shared session not working, and mutli SSL URL, or just the shared session
Just the shared session. If you're using a UCC certificate, http://sitename.com and http://www.sitename.com are always considered to be 2 separate domains.

DL

This account is inactive. Look for us under the name 'EvolveWebHosting' and contact us under that username.

Thanks!


User avatar
Active Member

Posts

Joined
Sun Dec 11, 2011 12:26 am
Location - USA

Post by platypuspuzzles » Fri Jun 06, 2014 9:14 am

yes, i know.

My ssl is working well - it's the config of mutli domains causing issue - it looks like i need a folder for each domain to keep site specific data in, to trigger the https, google analytics code etc.

that's how my previous host had it set up, and my secondary domains worked with their own SSL URL...but when I changed to 1.5.x and reconfigered my file set up, according to the instructions given by opencart (all folders to link to public_html), they no longer apply https:// when going to checkout

Active Member

Posts

Joined
Sun Jan 23, 2011 8:11 pm

Post by ocaddons » Fri Jun 06, 2014 9:45 am

@platypuspuzzles,

From my pointer of view, it just need to use the database driven session to achieve the shared session. It means you have to create a database table to store the session data and adjust a few of code about the session section.

Image
Image

EMail: support@ocaddons.com


User avatar
New member

Posts

Joined
Fri Dec 27, 2013 10:21 am


Post by nikksan » Fri Mar 23, 2018 9:32 pm

ocaddons wrote:
Fri Jun 06, 2014 9:45 am
@platypuspuzzles,

From my pointer of view, it just need to use the database driven session to achieve the shared session. It means you have to create a database table to store the session data and adjust a few of code about the session section.
Regardless of whether you store the session - whether in the db or the native server file system, you cant share the session_id if you are using different domains. (not subdomains)

Newbie

Posts

Joined
Tue Apr 26, 2016 7:05 pm

Post by straightlight » Fri Mar 23, 2018 9:37 pm

nikksan is correct here. The generated session ID is only per domain purposes whether it's for local or backward compatibility purposes.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 11 guests