Post by Alexg1227 » Tue Jun 06, 2017 1:06 pm

My website loads in english even though I have spanish set as default, cleared all cookies, restarted PC but no luck. Any help would be greatly appreciated
www.havanasupermarket.com

Newbie

Posts

Joined
Tue Jun 06, 2017 1:04 pm

Post by IP_CAM » Wed Jun 07, 2017 1:26 am

Your languages work in:
http:// havanasupermarket. com/
but NOT in:
http:// www.havanasupermarket. com/
(also, by use of WWW. your ICONS do not display!)
so, you have to make sure, by adding a routine into your .htaccess file
like this code shown below, right AFTER:

Code: Select all

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder,
# make sure you folder it does run in ie. / becomes /shop/
RewriteBase /
HERE:

Code: Select all

#Force (http host) non www to www (optional)
RewriteCond %{HTTP_HOST} !^www\.
RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

#Force (https host) non www to www (optional)
RewriteCond %{HTTPS} on
RewriteCond %{HTTP_HOST} !^www\.
RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]
and rewrite the LINKS in BOTH config.php Files,
to have the WWW. included in the href-links, to make it work, like:
ROOT:

Code: Select all

// HTTP
define('HTTP_SERVER', 'http://www.havanasupermarket.com/');
// HTTPS
define('HTTPS_SERVER', 'http://www.havanasupermarket.com/');
Admin:

Code: Select all

// HTTP
define('HTTP_SERVER', 'http://www.havanasupermarket.com/admin/');
define('HTTP_CATALOG', 'http://www.havanasupermarket.com/');
define('HTTP_IMAGE', 'http://www.havanasupermarket.com/image/');
// HTTPS
define('HTTPS_SERVER', 'http://www.havanasupermarket.com/admin/');
define('HTTPS_CATALOG', 'http://www.havanasupermarket.com/');
define('HTTPS_IMAGE', 'http://www.havanasupermarket.com/image/');
Good Luck! ;)
Ernie

Ernie's OpenCart v.1.5.6.5 LIGHT + OpenShop Admin v.1.75 Test Sites
http://www.ebikes.li - http://www.evelo.li - http://www.openshop.li
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by Alexg1227 » Fri Jun 09, 2017 10:28 pm

it worked!!!! thank you so much!

Newbie

Posts

Joined
Tue Jun 06, 2017 1:04 pm

Post by lliliqliliq » Thu Aug 17, 2017 10:46 pm

Hi I have similar issue. I have got two languages on my opencart Bulgarian and English. I have installed Bulgarian language pack then enabled it. After I went to System -> Languages and set all up and I put Bulgarian language sort order 1 and English Language sort order 2. After that I went to System -> Settings -> and in 'Local' tab I made Bulgarian Language set as default.

I have cleared all cookies. My websites still fist loads as default English language.
This is the website http://oarke.com/

Any help will be much appreciated indeed.

Thank you very much in advance.

Newbie

Posts

Joined
Thu Aug 17, 2017 10:00 pm

Post by IP_CAM » Fri Aug 18, 2017 1:33 am

Must be a Cookie-Problem in your Browser, your Shop loads
perfect, and in your Language, if I click the Link you've added.
Ernie

Ernie's OpenCart v.1.5.6.5 LIGHT + OpenShop Admin v.1.75 Test Sites
http://www.ebikes.li - http://www.evelo.li - http://www.openshop.li
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by lliliqliliq » Fri Aug 18, 2017 3:58 am

Hello thanks for the quick answer.
Well I have my all browser data cleared all history cookie everything. Then I load the web site and still open it in English Language instead of Bulgarian.
Do you think, that might be a issue with that my hosting provider is not based in Bulgaria? I am just confused?

Newbie

Posts

Joined
Thu Aug 17, 2017 10:00 pm

Post by mohamed.megahed » Sat Oct 14, 2017 8:43 pm

IP_CAM wrote:
Wed Jun 07, 2017 1:26 am
Your languages work in:
http:// havanasupermarket. com/
but NOT in:
http:// www.havanasupermarket. com/
(also, by use of WWW. your ICONS do not display!)
so, you have to make sure, by adding a routine into your .htaccess file
like this code shown below, right AFTER:

Code: Select all

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder,
# make sure you folder it does run in ie. / becomes /shop/
RewriteBase /
HERE:

Code: Select all

#Force (http host) non www to www (optional)
RewriteCond %{HTTP_HOST} !^www\.
RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

#Force (https host) non www to www (optional)
RewriteCond %{HTTPS} on
RewriteCond %{HTTP_HOST} !^www\.
RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]
and rewrite the LINKS in BOTH config.php Files,
to have the WWW. included in the href-links, to make it work, like:
ROOT:

Code: Select all

// HTTP
define('HTTP_SERVER', 'http://www.havanasupermarket.com/');
// HTTPS
define('HTTPS_SERVER', 'http://www.havanasupermarket.com/');
Admin:

Code: Select all

// HTTP
define('HTTP_SERVER', 'http://www.havanasupermarket.com/admin/');
define('HTTP_CATALOG', 'http://www.havanasupermarket.com/');
define('HTTP_IMAGE', 'http://www.havanasupermarket.com/image/');
// HTTPS
define('HTTPS_SERVER', 'http://www.havanasupermarket.com/admin/');
define('HTTPS_CATALOG', 'http://www.havanasupermarket.com/');
define('HTTPS_IMAGE', 'http://www.havanasupermarket.com/image/');
Good Luck! ;)
Ernie
Sir i did everything in htaccess but still the English language is the default but some pcs Arabic is default

New member

Posts

Joined
Wed May 17, 2017 10:39 pm
Who is online

Users browsing this forum: No registered users and 2 guests