Post by robbie269 » Tue Aug 16, 2016 2:34 pm

Opencart ver 2.2. My Google Sitemap Feed is not woking properly. I am getting the following error in Webmaster Tools:
An invalid date was found. Please fix the date or formatting before resubmitting.
The example is:
Parent tag: url
Tag: lastmod
Value: -0001-11-30T00:00:00+10:00

And the date in the actual feed is: <lastmod>-0001-11-30T00:00:00+10:00</lastmod>

How can I fix this?

Newbie

Posts

Joined
Thu May 26, 2016 5:46 am

Post by robbie269 » Wed Aug 17, 2016 7:27 am

Anyone?

Newbie

Posts

Joined
Thu May 26, 2016 5:46 am

Post by netbuster » Wed Aug 17, 2016 3:02 pm

I have the same problem. The workaround I used is to open the product and just save it. But this is very annoying problem.

Newbie

Posts

Joined
Wed Aug 17, 2016 2:58 pm

Post by sculptex » Wed Aug 17, 2016 4:34 pm

How did you create your products? using an import tool?

Asuming the date is set correctly on your server then you could use phpmyadmin to correct last modified dates on your products to the current date using

Code: Select all

UPDATE `oc_product` SET date_modified = now()

ImageImage


User avatar
Active Member

Posts

Joined
Tue Sep 13, 2011 3:07 am
Location - UK

Post by robbie269 » Thu Aug 18, 2016 6:07 am

Thankyou sculptex! That's what the problem was. All fixed now.

Newbie

Posts

Joined
Thu May 26, 2016 5:46 am

Post by X-TLC » Mon Aug 22, 2016 5:55 pm

sculptex wrote:How did you create your products? using an import tool?

Asuming the date is set correctly on your server then you could use phpmyadmin to correct last modified dates on your products to the current date using

Code: Select all

UPDATE `oc_product` SET date_modified = now()

Hi sculptex. I have same issue and could you tell me how should I go for edit the above you mentioned? Thank you

New member

Posts

Joined
Sat Mar 21, 2015 7:46 pm

Post by sculptex » Thu Sep 01, 2016 6:06 am

Hi, you need to execute that sql command in your database.
The easiest way to do this us using phpmyadmin or similar, usually accessed through cpanel or similar provided by your hosting company.
However, by the very nature of your asking, it might be better to seek someone out who can help you as you can do a lot of damage if you are not familiar with such things. Whichever way you go, make sure you backup your database first!!

ImageImage


User avatar
Active Member

Posts

Joined
Tue Sep 13, 2011 3:07 am
Location - UK

Post by uksitebuilder » Thu Sep 01, 2016 6:16 pm

Or you could upload the attached to your store root folder and run it in a browser.
Alternatively, try our Sitemap Extension - (See link in my signature)

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by mRC » Sun Nov 13, 2016 12:00 am

I also have the same issue, can someone explain how to fix this issue. The server time is correct.

many thanks

mRC
Active Member

Posts

Joined
Wed Nov 12, 2014 12:43 am

Post by thekrotek » Sun Nov 13, 2016 7:06 pm

mRC wrote:I also have the same issue, can someone explain how to fix this issue. The server time is correct.
It's not a server time, it's a wrong date_modified value for some products. There's a simple query given above - just run it and it should fix the issue.

I'd also suggest you to replace default sitemap extension with Smart Sitemap. It will give you full control over your sitemap and XML is generated way much better.
Last edited by thekrotek on Thu Dec 15, 2016 2:14 pm, edited 1 time in total.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Active Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by phamxuanvinh2110 » Mon Dec 05, 2016 12:07 am

the same one. I did above support, but error no fix. :(

New member

Posts

Joined
Mon Nov 28, 2016 11:41 am

Post by Poplarman » Thu Dec 15, 2016 1:11 pm

Here's an extension which validates 100%

Click here

Our Extension Demonstration Website
Poplarweb


User avatar
Newbie

Posts

Joined
Tue Nov 29, 2016 9:09 pm


Post by phamxuanvinh2110 » Sat Dec 17, 2016 12:34 pm

fix done. fix google sitemap.php, rewrite date.

New member

Posts

Joined
Mon Nov 28, 2016 11:41 am

Post by Jansuh » Sun Jun 17, 2018 6:32 pm

sculptex wrote:
Wed Aug 17, 2016 4:34 pm
How did you create your products? using an import tool?

Asuming the date is set correctly on your server then you could use phpmyadmin to correct last modified dates on your products to the current date using

Code: Select all

UPDATE `oc_product` SET date_modified = now()
Thanks that solved my problem!

New member

Posts

Joined
Fri Apr 20, 2018 8:13 pm

Who is online

Users browsing this forum: No registered users and 4 guests