Post by otix » Tue Feb 13, 2018 10:12 pm

Hi,
I am running OC v.2.3.02 and I am unable to open Order Totals modules in Extension List in admin.
But I can open all other sections (except Order Totals).
I get following error - error undefined (see below).
Any solution?
Thanks in advance.

Image

Newbie

Posts

Joined
Tue Feb 13, 2018 10:04 pm

Post by straightlight » Wed Feb 14, 2018 6:59 am

Check your error logs in your admin - > systems - > maintenance - > error logs page regarding this event. If none are appearing, check your access logs from your root FTP domain path in access_logs or logs folder or from your host console in the error logs icon.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by otix » Wed Feb 14, 2018 11:18 pm

straightlight wrote:
Wed Feb 14, 2018 6:59 am
Check your error logs in your admin - > systems - > maintenance - > error logs page regarding this event. If none are appearing, check your access logs from your root FTP domain path in access_logs or logs folder or from your host console in the error logs icon.
Hi, thanks for ideas.
There is one error in error logs, just not sure if is related to the stated problem.
"2018-02-14 16:10:12 - PHP Warning: Invalid argument supplied for foreach() in /home/carmirro/public_html/system/storage/modification/system/library/cart/cart.php on line 97"

Thanks

Newbie

Posts

Joined
Tue Feb 13, 2018 10:04 pm

Post by straightlight » Thu Feb 15, 2018 5:56 am

What is on line 97 of that file? More information is needed.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by otix » Thu Feb 15, 2018 8:58 pm

straightlight wrote:
Thu Feb 15, 2018 5:56 am
What is on line 97 of that file? More information is needed.
line 97 foreach (json_decode($cart['option']) as $product_option_id => $value) {
line 98 $option_query = $this->db->query("SELECT po.product_option_id, po.option_id, od.name, o.type FROM " . DB_PREFIX . "product_option po LEFT JOIN `" . DB_PREFIX . "option` o ON (po.option_id = o.option_id) LEFT JOIN " . DB_PREFIX . "option_description od ON (o.option_id = od.option_id) WHERE po.product_option_id = '" . (int)$product_option_id . "' AND po.product_id = '" . (int)$cart['product_id'] . "' AND od.language_id = '" . (int)$this->config->get('config_language_id') . "'");

Newbie

Posts

Joined
Tue Feb 13, 2018 10:04 pm

Post by straightlight » Fri Feb 16, 2018 5:54 am

So far, this issue seem to be caused by an installed OCMod extension. See from your admin - > extensions - > modifications or from your vqmod/xml folder.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by otix » Mon Feb 19, 2018 1:11 am

straightlight wrote:
Fri Feb 16, 2018 5:54 am
So far, this issue seem to be caused by an installed OCMod extension. See from your admin - > extensions - > modifications or from your vqmod/xml folder.
Ok, will try to switch off extensions one by one and hopefully find the problem. Thanks!

Newbie

Posts

Joined
Tue Feb 13, 2018 10:04 pm
Who is online

Users browsing this forum: No registered users and 4 guests