Post by ash_sp99 » Sat Jun 17, 2017 4:25 am

Hello,
I am using a following vqmod for showing a Indian rupee symbol, which is working fine...

Code: Select all

<file path="system/library/currency.php">
      <operation>
         <search position="replace"><![CDATA[$symbol_left   = $this->currencies[$currency]['symbol_left'];]]></search>
         <add><![CDATA[$symbol_left   = (($currency == 'INR') ? '<span class="fa fa-rupee" style="padding-right: 2px;"></span>' : $this->currencies[$currency]['symbol_left']);]]></add>
      </operation>

      <operation>
         <search position="replace"><![CDATA[$symbol_left   = $this->currencies[$this->code]['symbol_left'];]]></search>
         <add><![CDATA[$symbol_left   = (($this->code == 'INR') ? '<span class="fa fa-rupee" style="padding-right: 2px;"></span>' : $this->currencies[$this->code]['symbol_left']);]]></add>
      </operation>
   </file>

   <file path="catalog/view/theme/xxx/template/common/currency.tpl">
      <operation>
         <search position="after" offset="0"><![CDATA[<?php foreach ($currencies as $currency) { ?>]]></search>
         <add><![CDATA[<?php if ($currency['code'] == 'INR') {
         $currency['symbol_left'] = '<span class="fa fa-rupee" style="padding-right: 2px;"></span>';} ?>]]></add>
      </operation>
   </file>
</modification>
But when we send a Store credit mail then that mail shows

Code: Select all

<span class="fa fa-rupee" style="padding-right: 2px;"></span>
544 credit

Pls. suggest what change u suggest in the above vqmod which stops this coding showing in emails . I am using opencart 2.1.0.2

Newbie

Posts

Joined
Thu Feb 09, 2017 2:56 am

Post by thekrotek » Sat Jun 17, 2017 5:13 am

You can't use Font Awesome in mails the same way you do it in your store ("fa-rupee" class). You need to insert it directly.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Active Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by ash_sp99 » Sat Jun 17, 2017 5:37 pm

In emails, I don't want to use any special font, so pls. tell me what i need to do in above mod to fix in emails but untouched on website.

Newbie

Posts

Joined
Thu Feb 09, 2017 2:56 am

Post by ash_sp99 » Sat Jun 24, 2017 1:41 am

Any suggestion guys, what can be done to solve this issue.

Newbie

Posts

Joined
Thu Feb 09, 2017 2:56 am

Post by artcore » Sat Jun 24, 2017 2:00 am

Try this
https://www.w3schools.com/charsets/tryit.asp?deci=8360
You can also try adding it via admin>localization>currency unless the & has to be escaped somewhere.

Attn: I no longer provide OpenCart extensions, nor future support - this includes forum posts.
Reason: I moved on to Laravel ;D

Thanks!


User avatar
Active Member

Posts

Joined
Tue Jul 09, 2013 4:13 am
Location - The Netherlands

Post by ash_sp99 » Sat Jun 24, 2017 2:03 am

this is not the solution. We are talking about the editing in the php code, to avoid html in mails.

Newbie

Posts

Joined
Thu Feb 09, 2017 2:56 am

Post by thekrotek » Sat Jun 24, 2017 2:05 am

Like I said in my previous reply, INSERT IT DIRECTLY. Go to your currency settings and simply copy Rupee symbol from somewhere to Left Symbol field. And disable this stupid mod, because you absolutely don't need it.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Active Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by ash_sp99 » Sat Jun 24, 2017 2:54 am

You are absolutely right, no need of them stupid mod, but font used on the site changed the symbol design because not available in each font.

That's why we have to use this.

Newbie

Posts

Joined
Thu Feb 09, 2017 2:56 am

Post by thekrotek » Sat Jun 24, 2017 4:26 am

Have you tried to use another font or search for your current font updates? I'm pretty sure, it can be fixed without any mod.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Active Member

Posts

Joined
Sun Jul 03, 2016 12:24 am

Who is online

Users browsing this forum: No registered users and 6 guests