Post by zionhealth » Fri Feb 09, 2018 2:49 am

I'm not sure what happened, but a few days ago, we started getting customers complaining of multiple charges for the same order, on their credit card. After doing a little research, we found that what is happening, is that at checkout the order success page is not opening, so the customer just keeps click the "Confirm Order" button, each time, the payment is sent to Paypal, generating a new credit card charge.

We are using OpenCart 2.3.0.2. with a Pavo Theme Template
We also use the AJax Quick Checkout One Page Checkout

Looks like the problem is only occurring with the default Opencart Paypal Pro payment module.
We have tried uninstalling and reinstalling the Paypal Pro payment module in admin.
We have tried deleting the API credentials at Paypal, and genereating new credentials.

Everything was working fine until a few days ago, so we are not sure what is going on. Any assistance would be greatly appreciated.

New member

Posts

Joined
Tue Oct 18, 2016 8:12 am

Post by zionhealth » Fri Feb 09, 2018 2:56 am

One other thing, after pressing the "Confirm Order" button at checkout, we do see a brief "Please Wait" message, but it just disappears. The cart itself is still filled with the items, but a charge has been sent to Paypal for the order.

New member

Posts

Joined
Tue Oct 18, 2016 8:12 am

Post by zionhealth » Fri Feb 09, 2018 9:45 am

FWIW, to anyone experiencing similar. The fix for us was to turn off one of the modules in Extensions>Modules. Apparently, it was interfering with the completion of the payment process.

New member

Posts

Joined
Tue Oct 18, 2016 8:12 am

Post by NickT87 » Thu Apr 12, 2018 1:11 am

experiencing the same problem.

Do you know which extension this was causing this for you?

New member

Posts

Joined
Sun Jul 31, 2016 12:09 am

Post by straightlight » Thu Apr 12, 2018 1:52 am

NickT87 wrote:
Thu Apr 12, 2018 1:11 am
experiencing the same problem.

Do you know which extension this was causing this for you?
The only way to find out is by disabling each modules until identifying the root cause.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by VladZablotskyy » Fri Jul 20, 2018 2:09 pm

I am experiencing the same thing. Any solutions thus far?

New member

Posts

Joined
Wed Oct 07, 2009 3:47 am

Post by straightlight » Fri Jul 20, 2018 6:13 pm

VladZablotskyy wrote:
Fri Jul 20, 2018 2:09 pm
I am experiencing the same thing. Any solutions thus far?
I mean … the solution is posted … right on the above … disable each extensions.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 2 guests