Post by jeremyjustus0916 » Sun Apr 16, 2017 1:36 pm

Has anyone gotten this plugin working on their site? I have followed all instructions on the docs and now the login seems to work fine, when I go to pay I get to the /address portion of the application and thats when I get an error returned from their widget with this:

"We're sorry, but there's a problem processing your payment from this website. Please contact the seller for assistance."

Which I did some research and found this as type of error to be the culprit of seeing that response:
ReleaseEnvironmentMismatch: You have attempted to render a widget in a release environment that does not match the release environment of the Billing Agreement object. The release environment of the widget and the Billing Agreement object must match.

Did anyone else run into all this and find fixes? I even turned on the debug logging and Notice this error repeatedly upon attempts and getting to the address lookup part of the widget:

2017-04-16 4:09:45 - Origin: Proxy::__call
2017-04-16 4:09:45 - SimpleXMLElement Object
(
[Error] => SimpleXMLElement Object
(
[Type] => Sender
[ * Code * ] => InvalidOrderReferenceId
[Message] => The OrderReferenceId validate details is invalid.
)

[RequestId] => 4b778d47-2a6c-4e6e-b441-9cca07cdb7bf
)

Which I then looked up and found this info out:
InvalidOrderReferenceId - The specified order reference identifier is invalid. (Gee thanks for the insight on this one amazon) ....

I have honestly tried looking into the controllers/views/modules and I cannot find anything specifically that stands out wrong to me. I did var_dumps on most values and I see all the common creds are correct. Anyone know how to compare the release environment to that of the Billing Agreement object that amazon refers to as a potential problem? Or if we go by the errors my logs spit out, then it would be a different error entirely I am trying to tackle here...

Any pro coderz that can play with the amazon plugin and get it working for them and then dump me the source files would have my eternal gratitude ;) (I also wanna know wtf was wrong cause 6+ hours into this and I am still no closer now). I will even give away the person who can get amazon working my bitpay fixed sources for newest version + my custom forum codes if they want them. Sharing is caring heh.

I posted on the developer of the addons page too but idk if he will be answering me or not: https://www.opencart.com/index.php?rout ... azon%20pay

-Jeremy

User avatar

Posts

Joined
Thu Mar 23, 2017 9:36 am

Post by labeshops » Fri Apr 21, 2017 10:56 pm

I use it on opencart 2.2 with no issues. Haven't tried on 2.3 but I didn't have to make any changes. Make sure you also enable login with amazon as it is required to make the payment option work.

Running Opencart v2.2 with multi-stores from http://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by jeremyjustus0916 » Mon Apr 24, 2017 12:34 pm

Was any changes made that are significant from 2.2 to 2.3? I would not thinks so. Any chance you could link me to your amazon source files/classes + controllers? Or direct me to where you downloaded them(or did you just already use what opencart 2.2 came with?) . If so then I will DL 2.2 and gut out all the necessary amazon files. My friend may have inadvertently messed up a file when trying to configure/fix amazon awhile back.

Thanks!

User avatar

Posts

Joined
Thu Mar 23, 2017 9:36 am

Post by jeremyjustus0916 » Wed Apr 26, 2017 5:03 am

Update: Wellfordmedia identified the problem should occur with all users of the application right now. They are talking to amazon for a fix since amazon commissioned them to make this app in the first place.

Thanks.

User avatar

Posts

Joined
Thu Mar 23, 2017 9:36 am

Post by labeshops » Wed Apr 26, 2017 9:13 am

I just used it as it came with 2.2. I've been getting sales with it paid by amazon nearly every day so no issues for me.

Running Opencart v2.2 with multi-stores from http://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by jeremyjustus0916 » Wed Apr 26, 2017 12:19 pm

Not sure how that's possible, this was their exact email to me:

"
Thanks for getting an email over!

So I have passed this over to our developer who originally built the module to have a look at, and he has informed me that the error you have flagged up is something which he has already emailed Amazon about and we are just waiting on a response for fixes etc. As Amazon commissioned us to build the module, we aren't allowed to perform any fixes to it without their go ahead. This is why we do charge for support as any changes we make can only be to that individual client.

Once we hear back from Amazon regarding this issue, I will get back you with an update!

In regards to the billing, at the moment we're on hold as we may be able to provide a fix to the module without there being any costs to yourself. But we will not know for definite until we hear back. Would you be okay with waiting?

Kind regards

(Removed first name), Cook
Office Manager
"

Have you tried reaching the the address lookup portion of the java-script application? That is where visually it will fail in the order process. When you have

See what this portion of the URL is for the error and try on your site to reach that call with no error in the sample image, if its returning an address and loading there then maybe Wellfordmedia may be confused too.

Attachments

SampleError.png

The error - SampleError.png (42.22 KiB) Viewed 580 times


User avatar

Posts

Joined
Thu Mar 23, 2017 9:36 am

Post by jeremyjustus0916 » Wed May 24, 2017 9:17 am

Gah amazon for dev's suck. So this whole time the error was simply because I did not have tax profile information filled out on the account. we had everything else fine as it was.... jeesh you think their errors could be more representative of the real culprit issues...

User avatar

Posts

Joined
Thu Mar 23, 2017 9:36 am
Who is online

Users browsing this forum: No registered users and 7 guests