Post by wolfylicious » Fri Sep 22, 2017 5:18 am

Got this error when tying to install any extension. I know its have been done in the past but i was trying to fix it with no clue. Already checked many threads like it. Please help.

Error @ /system/storage/modification/admin/controller/extension/installer.php @ line 116

Version 2.3.0.2

Attachments

Err.png

Err.png (18.27 KiB) Viewed 1545 times


Newbie

Posts

Joined
Tue Sep 19, 2017 7:21 pm

Post by yodapt » Fri Sep 22, 2017 5:32 am

Can you paste the code of that file? /system/storage/modification/admin/controller/extension/installer.php

Opencart Developer - My Extension Showcase
Contact me at aeon.yoda@gmail.com


User avatar
Active Member

Posts

Joined
Fri Jun 17, 2011 6:39 pm


Post by wolfylicious » Fri Sep 22, 2017 5:47 am

Code: Select all

// If zip file copy it to the temp directory
			if (strrchr($this->request->files['file']['name'], '.') == '.zip') {
				$file = DIR_UPLOAD . $path . '/upload.zip';

				move_uploaded_file($this->request->files['file']['tmp_name'], $file);
Last edited by wolfylicious on Fri Sep 22, 2017 5:49 am, edited 1 time in total.

Newbie

Posts

Joined
Tue Sep 19, 2017 7:21 pm

Post by yodapt » Fri Sep 22, 2017 5:59 am

Have you moved the storage folder? Seems like its a permission error.

Opencart Developer - My Extension Showcase
Contact me at aeon.yoda@gmail.com


User avatar
Active Member

Posts

Joined
Fri Jun 17, 2011 6:39 pm


Post by wolfylicious » Fri Sep 22, 2017 6:06 am

Nope.Its in /system/storage/upload. DIR path its the same.
I already gave installer.php & system folder 0777 permision.

Newbie

Posts

Joined
Tue Sep 19, 2017 7:21 pm

Post by yodapt » Fri Sep 22, 2017 6:10 am

What about ownership of those files / folders? The user and group must be allowed by Apache in order for PHP to use them correctly.

Is that an unmanaged VPS?

Opencart Developer - My Extension Showcase
Contact me at aeon.yoda@gmail.com


User avatar
Active Member

Posts

Joined
Fri Jun 17, 2011 6:39 pm


Post by wolfylicious » Fri Sep 22, 2017 4:09 pm

They are. No VPS indeed.

Newbie

Posts

Joined
Tue Sep 19, 2017 7:21 pm

Post by jhebb » Fri Mar 16, 2018 12:26 am

Check the DIR_UPLOAD path in the admin and root config.php files, make sure 'storage' is added.

New member

Posts

Joined
Tue Oct 18, 2011 7:32 am

Post by straightlight » Fri Mar 16, 2018 1:27 am

Simply follow these instructions: viewtopic.php?f=202&t=201745#p713479 . Ensure not to have used the automatic settings from the modal security window in the OC admin.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 7 guests