Post by billhobbs » Fri Apr 13, 2018 3:38 am

I have a problem that I can't seem to fix. I'm using Paypal Advanced with Opencart 2.3.0.2, I have the extension that adds Paypal Advanced to the payment options.

On checkout the Paypal is receiving the details and the credit card is being charged.

What is happening is that when a customer completes the purchase four things (that I know of) are not happening.
1. The status of the order in the database isn't being updated. The order appears to be stored but the order_status_id is set to 0.
2. No confirmation email is sent to the customer or the store owner.
3. The cart isn't emptied. The number of items and the items in the cart aren't cleared.
4. Since the order_status_id is set to 0 the order isn't showing up in the Dashboard

Any help would be greatly appreciated. It looks like some code isn't being triggered. I'm not sure where the code for these actions would be located.

Thank You in advance.

Newbie

Posts

Joined
Fri Feb 24, 2017 3:54 am

Post by OSWorX » Fri Apr 13, 2018 4:10 am

I guess that this is only sometimes, not always?

From my own PP-Extensions I know, that PayPal has currently massive problems.
That may lead to the situation, that PayPal is not sending the whole information (e.g. the Order-ID) back to the shop.
But this ID is required to identify the order, therefore the order is not completed nor the following processes - sending emails, delete session data, etc. - are triggered.

That leads to the situation, that the order cannot be completed.
Frustrating, but as it seems not changeable until PayPal has his own system updated!

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria
Who is online

Users browsing this forum: No registered users and 6 guests