Post by noahfbla » Thu Dec 14, 2017 10:25 pm

Hi all

Using OpenCart 2.1.0.2. New install via Godaddy.

Default seems to work fine, but have tried 4 different themes and once installed they all give some sort of "undefined variable" errors. Usually in the header but sometimes in other places too depending on the theme.

Anyone run into this before? Would it be better for me to delete and try to do a manual install?

Thanks so much in advance. This is for a student project so won't be a fully operational store but want to get it as close as possible.

Newbie

Posts

Joined
Tue Dec 12, 2017 10:07 pm

Post by straightlight » Fri Dec 15, 2017 12:12 am

If it's a new install, rather install the latest version of Opencart which already contains several patches from the Github Opencart master files.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by IP_CAM » Fri Dec 15, 2017 4:25 am

they all give some sort of "undefined variable" errors.

Well, that's not really a Student-like information, in contrary, the NAMES of the
undefined Variables would be upmost important to know, otherwise, it's just hot air... ::)
Ernie

Ernie's OpenCart v.1.5.6.5 LIGHT + OpenShop Admin v.1.75 Test Sites
http://www.bigmax.ch - http://www.evelo.li - http://www.openshop.li
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by noahfbla » Fri Dec 15, 2017 9:40 pm

Yes I'm thinking a clean install of the newest version may be the best. Or is there a particular version that is more stable, as far as accepting specific themes?

Here's some of the code we're seeing.

Notice: Undefined variable: icon in /home/muh5frf8ow6i/public_html/store/catalog/view/theme/spicy/template/common/header.tpl on line 14 Notice: Undefined variable: stores in /home/muh5frf8ow6i/public_html/store/catalog/view/theme/spicy/template/common/header.tpl on line 52Notice: Undefined variable: google_analytics in /home/muh5frf8ow6i/public_html/store/catalog/view/theme/spicy/template/common/header.tpl on line 61

Here's a link:
http://temp.weststanlyfbla.com/store/


Thanks much for the replies!

Newbie

Posts

Joined
Tue Dec 12, 2017 10:07 pm

Post by straightlight » Fri Dec 15, 2017 11:26 pm

Revert to the default theme and see if this issue can be reproduced. If not, the problem is with the custom theme. Contact the extension theme developer from where you originally downloaded the extension to resolve this issue.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by noahfbla » Mon Dec 18, 2017 9:04 pm

That's what I was thinking but we've installed 4 different themes and it's always the same errors. But there are no errors with the default theme.

Newbie

Posts

Joined
Tue Dec 12, 2017 10:07 pm

Post by straightlight » Mon Dec 18, 2017 9:06 pm

If there are no errors with the default theme, then we are looking at an incompatibility with an extension that may not be compatible with the extension themes you have installed. Contact the extension developer of the installed extension affecting your custom theme in order to resolve these issues.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by noahfbla » Mon Dec 18, 2017 9:11 pm

I think I'm using the wrong terminology (trying to do too many things at once!).

We are trying to use new templates. We have downloaded 4 different templates and when activated they show those errors. Using the default template shows no errors.

Apologies for any miscommunication--and thank you so much for your input.

Newbie

Posts

Joined
Tue Dec 12, 2017 10:07 pm

Post by straightlight » Mon Dec 18, 2017 9:26 pm

My above reply still stands. I did perfectly understood what was posted on the above and I did replied accordingly. There's no error message on the default theme but only when using custom themes when an additional extension is installed. In this case, you do need to contact the extension developer to resolve this issue.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by noahfbla » Mon Dec 18, 2017 9:33 pm

Ok thank you. I just thought it odd that every template we try has the same type of error. We will try a few more and see if the error continues to be replicated, as we also try to contact those theme developers.

Thank you again

Newbie

Posts

Joined
Tue Dec 12, 2017 10:07 pm

Post by straightlight » Mon Dec 18, 2017 9:36 pm

noahfbla wrote:
Mon Dec 18, 2017 9:33 pm
Ok thank you. I just thought it odd that every template we try has the same type of error. We will try a few more and see if the error continues to be replicated, as we also try to contact those theme developers.

Thank you again
With the exception of the default theme, yes. Which means, it is not an issue from the OC core.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 22 guests