Post by godly75 » Fri Oct 27, 2017 1:24 am

Hello, I'm trying to upgrade from v2 to v3.
I did a clean reinstall and now try to import the exported database from my previous version.
I keep on getting errors when importing tables, even step by step.
Below you see 1 problem already.
How can I fix these or is there a database migration script?
Image

Newbie

Posts

Joined
Fri Oct 27, 2017 1:21 am

Post by straightlight » Fri Oct 27, 2017 3:04 am

You seem to have tracked down a bug from v3.0.2.0. As per the message indicates, you have missing fields on the database which, in this case, would be in the customer table. The approved field is missing or even perhaps this field should of been removed from the catalog/model/extension/payment/amazon_login_pay.php file in the addCustomer() method.

Let's assume it should of been added. In your PHPMyAdmin, click on your Opencart database. Then, in your SQL tab, execute the following query statement:

Code: Select all

ALTER TABLE `oc_customer` ADD `approval` INT(1) NOT NULL;
Note: change: `oc_ with your actual database table prefix name if using another one. Then, execute the query and refresh the page where the error message posted occurs to see if that rectifies the issue.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Fri Oct 27, 2017 3:07 am

This issue has now been reported regarding the field name: Approval.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 23 guests