Post by Bobbio999 » Mon Oct 23, 2017 7:45 pm

Hi All,

I've recently been awarded the SSL certificate which has been applied by my host. However, I just cannot get my website to function using the https url. Please would somebody confirm / comment on what I'm doing wrong.

So far I have:
1) set the root config.php to https
2) set the admin config.php to https
3) set the radio button in the admin area to home/stores/settings/server to 'use SSL = YES'

......is there anything else I'm missing? I've also pasted my htaccess file below, as I have seen others edit this perhaps?

1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt))">
Order deny,allow
Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/


RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^system/download/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none

<Files 403.shtml>
order allow,deny
allow from all
</Files>

deny from 95.147.2.65

New member

Posts

Joined
Thu Apr 16, 2015 11:19 pm

Post by MrPhil » Mon Oct 23, 2017 11:49 pm

First of all, are you using the domain format specified in your SSL certificate? Most certs are issued to a domain specifically with or without www. If yours is issued for www.mysite.com, it usually won't work if you give just mysite.com, and vice-versa. Make sure they match. Second, you have all http: changed to https: in your configuration files and .htaccess? Make sure you aren't still using http: anywhere (I'm assuming that you want your entire site under SSL, and not just sensitive pages).

In your .htaccess, you should redirect any http: requests coming in to https:, before it gets to the OC part. You can combine forcing http to https with forcing www. (or forcing without):

Code: Select all

RewriteEngine On
RewriteCond  %{HTTPS} !on  [OR]
RewriteCond  %{HTTP_HOST}  !^www\.  
RewriteRule  ^(.*)$   https://www.mysite.com/$1  [R=301,L]
This is assuming you want to force www. on the domain. Season to taste.

Active Member

Posts

Joined
Wed May 10, 2017 11:52 pm
Who is online

Users browsing this forum: No registered users and 20 guests