Post by Bobbio999 » Sat Oct 14, 2017 12:12 am

Hi,

I've upgraded from 1.5 to 2.3.0.2.
Everything works fine in the /admin pages but the website just displays the following fatal errors.
Can anyone please advise before I have to pull the plug and roll back.

The url is http://conquerorpaper.com


Fatal error: Uncaught exception 'Exception' with message 'Error: Could not load model total!' in /home/planklvv/public_html/conquerorpaper.com/system/engine/loader.php:169 Stack trace: #0 [internal function]: Loader->{closure}(Array, Array) #1 /home/planklvv/public_html/conquerorpaper.com/system/engine/proxy.php(25): call_user_func_array(Object(Closure), Array) #2 /home/planklvv/public_html/conquerorpaper.com/catalog/controller/common/cart.php(37): Proxy->__call('getTotal', Array) #3 /home/planklvv/public_html/conquerorpaper.com/catalog/controller/common/cart.php(37): Proxy->getTotal(Array) #4 [internal function]: ControllerCommonCart->index(Array) #5 /home/planklvv/public_html/conquerorpaper.com/system/engine/action.php(51): call_user_func_array(Array, Array) #6 /home/planklvv/public_html/conquerorpaper.com/system/engine/loader.php(24): Action->execute(Object(Registry), Array) #7 /home/planklvv/public_html/conquerorpaper.com/catalog/controller/common/header.php(129): Loader->controller('common/cart') #8 [internal functio in /home/planklvv/public_html/conquerorpaper.com/system/engine/loader.php on line 169

New member

Posts

Joined
Thu Apr 16, 2015 11:19 pm

Post by straightlight » Sat Oct 14, 2017 9:16 pm

Your total modules are either missing or placed into the wrong folder. Between the v1.5x and v2.x releases, the directories are a slight different regarding the extensions that are included with Opencart's original ZIP file. I would suggest to restore backups and to try to upgrade with a script or to ask for professional assistance to upgrade your store.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Bobbio999 » Tue Oct 17, 2017 12:06 am

I think leaping from v 1.5 to the latest version of 2.3.0.2 was too big a step.

I changed and upgraded to Version 2.1.0.1 and all works perfectly. My preferred version anyhow due to the way the Dashboard sits.

New member

Posts

Joined
Thu Apr 16, 2015 11:19 pm

Post by justahippy » Sun Nov 12, 2017 12:12 pm

Wish i would have seen this about 24 hrs ago :( I am having the same issue going from 1.5 to 2.3.0.2

Newbie

Posts

Joined
Sun Nov 12, 2017 10:16 am
Who is online

Users browsing this forum: No registered users and 23 guests