Post by conceptstore » Fri Aug 25, 2017 9:01 pm

Hello,

We upgraded a site from 2.1.0.1 to 2.3.0.2 and we now have the following error message

Fatal error: Uncaught exception 'Exception' with message 'Error: Unknown column 'api_id' in 'where clause'<br />Error No: 1054<br />DELETE FROM oc_cart WHERE (api_id > '0' OR customer_id = '0') AND date_added < DATE_SUB(NOW(), INTERVAL 1 HOUR)' in /home/concepttestingco/public_html/karmafurnishings/system/library/db/mysqli.php:40 Stack trace: #0 /home/concepttestingco/public_html/karmafurnishings/system/library/db.php(16): DB\MySQLi->query('DELETE FROM oc_...', Array) #1 /home/concepttestingco/public_html/karmafurnishings/system/library/cart/cart.php(15): DB->query('DELETE FROM oc_...') #2 /home/concepttestingco/public_html/karmafurnishings/admin/controller/startup/startup.php(56): Cart\Cart->__construct(Object(Registry)) #3 [internal function]: ControllerStartupStartup->index() #4 /home/concepttestingco/public_html/karmafurnishings/system/storage/modification/system/engine/action.php(51): call_user_func_array(Array, Array) #5 /home/concepttestingco/public_html/karmafurnishings/system/engine/front.php(34): Action->execute in /home/concepttestingco/public_html/karmafurnishings/system/library/db/mysqli.php on line 40

We are new to opencart and are really stuck. Any help in resolving the above would be really healpful

Thanks

Newbie

Posts

Joined
Fri May 12, 2017 7:51 pm

Post by rjcalifornia » Mon Aug 28, 2017 4:33 am

First, restore the site from a backup. It is a good practice to make a copy of the site, install it locally (on your computer), and make changes in the local version before modifying the production site

Second, how did you perform the upgrade?

Image


Active Member

Posts

Joined
Fri Sep 02, 2011 1:19 pm
Location - Worldwide

Post by conceptstore » Mon Aug 28, 2017 3:58 pm

rjcalifornia wrote:
Mon Aug 28, 2017 4:33 am
First, restore the site from a backup. It is a good practice to make a copy of the site, install it locally (on your computer), and make changes in the local version before modifying the production site

Second, how did you perform the upgrade?
We put site on a test server to do the upgrade which seemed to be fine. I upgraded via the opencart instructions. We then installed a "plaza theme" and then i went to save the settinhs and this happened. Any further ideas would be appreciated.

Newbie

Posts

Joined
Fri May 12, 2017 7:51 pm

Post by rjcalifornia » Wed Aug 30, 2017 10:20 am

conceptstore wrote:
Mon Aug 28, 2017 3:58 pm
We then installed a "plaza theme" and then i went to save the settinhs and this happened. Any further ideas would be appreciated.
When you performed the upgrade in the test site, did you also install the plaza theme? Did it cause the same issues?

Image


Active Member

Posts

Joined
Fri Sep 02, 2011 1:19 pm
Location - Worldwide

Post by conceptstore » Wed Aug 30, 2017 4:27 pm

Yes, in the test site I installed the upgrade and all seemed to be well. I then installed the plaza theme (with a few small issues) but that also seemed to have worked as well. Only after that when I went to make a change to the system settings (store name) did it then show the error message above for both frontend and admin.

In the end we've had to scrap opencart and go with another system.

Newbie

Posts

Joined
Fri May 12, 2017 7:51 pm
Who is online

Users browsing this forum: No registered users and 10 guests