Post by vinhpk » Mon Oct 24, 2016 11:02 pm

I am using 2.1.0.1, use a theme bought on themeforest, but now I bought another too, but, it for 2.3.0.2 and can not install to 2.1.0.1 cause some error (i tried install a clean 2.3.0.2 and install this theme successfully) so I want upgrade my site from 2.1.0.1 to 2.3.0.2. But when I copy and replace all file with new and run install, I received this error:

Code: Select all

Notice: Error: Could not load template D:/xampp/htdocs/www/install/view/template/common/header! in D:\xampp\htdocs\www\system\storage\modification\system\engine\loader.php on line 86
I tried remove all extensions, mods were used, back to default theme, and run script upgrade again but received this error again. Can anyone help me? Thanks you!

New member

Posts

Joined
Sat Dec 29, 2012 12:13 pm

Post by Hannah00 » Wed Oct 26, 2016 12:52 pm

You can try to remove file system/modification/system/engine/loader.php or try go to admin > extension > modification and press "refresh".

Opencart migration & upgrade tool


User avatar
New member

Posts

Joined
Wed May 04, 2016 5:09 pm

Post by vinhpk » Fri Oct 28, 2016 3:33 am

Hannah00 wrote:You can try to remove file system/modification/system/engine/loader.php or try go to admin > extension > modification and press "refresh".
I tried removed all exts mods and refresh (of course) but still get that errors. Remove that file still nothing change :(

New member

Posts

Joined
Sat Dec 29, 2012 12:13 pm

Post by cyclops12 » Fri Oct 28, 2016 9:33 pm

Have you modified the header.tpl??
Try renaming the header.tpl file to header_old.tpl then upload the header.tpl file from 2.3.0.2 version.
If all is ok then you should be able to edit the new header file

Active Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by vinhpk » Tue Nov 01, 2016 10:05 pm

Hi, I fixed this errors, I am so confuse what exactly of this errors. I tried remove all code, reupload code downloaded from opencart official site but still get this error. So I tried open loader.php go to line 86, this is space line without data, I remove this line and save, oh shit, everything OK. Till now I still dont know what the hell which I got???? ??? ??? ??? ??? ???

New member

Posts

Joined
Sat Dec 29, 2012 12:13 pm

Post by cyclops12 » Tue Nov 01, 2016 10:44 pm

So it was an empty line causing the error....at least you got it sorted and well done for posting the solution.

Active Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by Hannah00 » Wed Nov 02, 2016 4:07 pm

You can choose other way to upgrade 2.1 to 2.3: https://www.opencart.com/index.php?rout ... n_id=27239

Opencart migration & upgrade tool


User avatar
New member

Posts

Joined
Wed May 04, 2016 5:09 pm

Post by JNeuhoff » Wed Nov 02, 2016 5:44 pm

Hannah00 wrote:You can choose other way to upgrade 2.1 to 2.3: https://www.opencart.com/index.php?rout ... n_id=27239
The migration tool shown in your link is highly misleading, it claims to be free in the Opencart extension store, but it isn't! I wouldn't trust anyone with such misleading advertising.

Also, another common issue with many, if not all, migration tools is that they are unable to do a proper remapping of Opencart countries and zones, including updating customer addresses.

Quite often it is easier just to use PHPMyAdmin with which you can export DB tables in e.g. into CSV format, then modify its format with a spreadsheet software to the required new format, and then import to the new DB of a freshly installed new OpenCart.

User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Hannah00 » Thu Nov 10, 2016 12:37 pm

Thanks for your recommendation. Hope people can fnd the easy solution to solve their problem!

Opencart migration & upgrade tool


User avatar
New member

Posts

Joined
Wed May 04, 2016 5:09 pm

Post by n2rtechnologies » Fri Jun 16, 2017 6:30 am

You can easily upgrade from 2.x.x.x to 2.3 by just uploading all 2.3 upload files to server via FTP and without editing config.php file and run http://www.yoursitelink.com/install/. The theme must be compatible with 2.3 and all 3rd party module also need to be compatible with Opencart 2.3.
After finish login to your admin and refresh modification from admin/extension/modification

For any support, please contact http://www.n2rtechnologies.com

User avatar

Posts

Joined
Wed Aug 10, 2016 10:51 pm
Location - India

Post by jonathan777 » Mon Oct 23, 2017 10:25 am

In controller/header.php do this:

//if (file_exists(DIR_TEMPLATE . $this->config->get('config_template') . '/template/common/header.tpl')) {
// return $this->load->view($this->config->get('config_template') . '/template/common/header.tpl', $data);
//} else {
return $this->load->view('default/template/common/header.tpl', $data);
//}

Newbie

Posts

Joined
Mon Oct 23, 2017 10:21 am
Who is online

Users browsing this forum: No registered users and 21 guests