Post by i2Paq » Mon Jun 06, 2016 5:44 pm

There are a lot of issue regarding upgrading to 2.2 from older versions.

Here are some guidelines you should read en practice BEFORE starting on the journey called: Upgrading.
  • NEVER perform an upgrade on a live store. Use a backup or dev-site!
  • NEVER perform an upgrade WITHOUT a complete backup (Files and Database).
  • NEVER perform and upgrade if your additional modules and Theme are not upgradable.
  • DO NOT USE the upgrade script coming with 2.2.x.
  • If you are an upgrading "newbie" or not familiar with OpenCart and building your own site; hire someone.
Here is what to prepare:
  • Backup your files (FTP)
  • Backup your database (phpMyAdmin, contact your hoster)
  • Make a list of all your 3rd party modules and modification and find updated versions, they will NOT work after the upgrade.
  • Custom theme? Contact the creator for an update as it will not work after the upgrade.
  • If there are NO upgrades available for your third party modules, add-ons and theme then de-install them before upgrading.
  • Use proven upgrade-scrips found in the Extensions
Best practice:
  • Hire someone.
  • If doing yourself ALWAYS use a backup/dev-site.
Please share your comments so I can fine-tune this topic.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

UPGRADE to 2.x: Contemplate before thou begins!

Our FREE search: Find your answer FAST!.

BUGs?: Known BUGS for All OC Versions.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by dmsims » Tue Jun 07, 2016 8:01 am

i2Paq wrote: [*] DO NOT USE the upgrade script coming with 2.2.x.
This is wrong Opencart says it works

Active Member

Posts

Joined
Sat Apr 13, 2013 6:05 pm

Post by i2Paq » Tue Jun 07, 2016 2:06 pm

dmsims wrote:
i2Paq wrote: [*] DO NOT USE the upgrade script coming with 2.2.x.
This is wrong Opencart says it works
Where?

Did you used it to upgrade?

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

UPGRADE to 2.x: Contemplate before thou begins!

Our FREE search: Find your answer FAST!.

BUGs?: Known BUGS for All OC Versions.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by dmsims » Wed Jun 08, 2016 6:20 pm

Image

Active Member

Posts

Joined
Sat Apr 13, 2013 6:05 pm

Post by i2Paq » Thu Jun 09, 2016 1:21 am

Well I have my answer and you have yours.

I still say that you should not use the script coming with OC.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

UPGRADE to 2.x: Contemplate before thou begins!

Our FREE search: Find your answer FAST!.

BUGs?: Known BUGS for All OC Versions.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by dmsims » Thu Jun 09, 2016 4:43 am

i2Paq wrote:I still say that you should not use the script coming with OC.
I agree with you

It DOES NOT work

Active Member

Posts

Joined
Sat Apr 13, 2013 6:05 pm

Post by platypuspuzzles » Sun Jul 03, 2016 11:45 pm

I disagree.

I have a fully functional, error free, LIVE optimised 2.2.0.0 with about 10 extensions, full SSL over my whole website, and seller protection activated.

The issues I was having came about from pre 2.2 - post 1.5.6.4 upgrades, but I worked through each one and any fixes, have been added to Qphoria's post.

Active Member

Posts

Joined
Sun Jan 23, 2011 8:11 pm

Post by CelBot » Thu Jul 14, 2016 8:43 am

How is it possible that after all this time since the 2.x.x era that the upgrade.txt file is still included from version 1.5?

Hey OpenCart, just remove the file until upgrading works again. Or, if it does work now, take the 3 minutes and change the top portion that reads: " OpenCart V1.5.x TO 1.5.x Upgrade Instructions". And change it to "V2.x TO 2.x.

How is this old upgrade text file still making into every 2.x version of OpenCart?

I'm an OpenCart user who still can't believe this.

Thanks

;D

Newbie

Posts

Joined
Fri Apr 24, 2015 11:00 pm

Post by leonattpcs » Thu Jul 14, 2016 1:21 pm

platypuspuzzles wrote:I disagree.

I have a fully functional, error free, LIVE optimised 2.2.0.0 with about 10 extensions, full SSL over my whole website, and seller protection activated.

The issues I was having came about from pre 2.2 - post 1.5.6.4 upgrades, but I worked through each one and any fixes, have been added to Qphoria's post.

Hi,
Who do you host your website with? I have had nothing, but problems with trying to move to 2.1.0.2 and I think it is with the differences in the way hosting companies run things. I have tried 1and1, nublue and site ground. I try to do the same thing each time and get different errors on every occasion so who is your hosting company and how did you install opencart?
Thanks

Newbie

Posts

Joined
Tue Mar 26, 2013 5:15 pm

Post by platypuspuzzles » Fri Jul 15, 2016 6:21 pm

leonattpcs wrote:
platypuspuzzles wrote:I disagree.

I have a fully functional, error free, LIVE optimised 2.2.0.0 with about 10 extensions, full SSL over my whole website, and seller protection activated.

The issues I was having came about from pre 2.2 - post 1.5.6.4 upgrades, but I worked through each one and any fixes, have been added to Qphoria's post.

Hi,
Who do you host your website with? I have had nothing, but problems with trying to move to 2.1.0.2 and I think it is with the differences in the way hosting companies run things. I have tried 1and1, nublue and site ground. I try to do the same thing each time and get different errors on every occasion so who is your hosting company and how did you install opencart?
Thanks
I followed this thread to upgrade from 2.0.3.1 and 1.5.4 on my old store - the issues I cam across have been implemented into the install files you need to download from this thread.
http://forum.opencart.com/viewtopic.php?f=181&t=159898

I backed up my cpanel and database, made a copy of it, so I could complete the upgrade on a copy and not my live store. First I updated my vqmod, then I downloaded the latest version of opencart, deleted the install folder, and replaced it with the install folder downloaded from first post in the above link.
I host with wxhosting.com and it also worked on hostgeek.com.au

Active Member

Posts

Joined
Sun Jan 23, 2011 8:11 pm

Post by leonattpcs » Fri Jul 15, 2016 7:25 pm

Thanks for the info.

Newbie

Posts

Joined
Tue Mar 26, 2013 5:15 pm

Post by EvolveWebHosting » Tue Jul 26, 2016 7:15 am

I have used the same upgrade script all the way back to 1.5.2.x and it works. There are weird little issues here and there but the answers are in the forums if you want to look for them and get your site up to date.

Image
https://www.evolvewebhost.com
Unhappy with your current host? We can migrate your account today (usually for no fee)! Visit our website and signup and we'll take care of the rest!
24/7/365 support
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by scottdog129 » Sun Jul 31, 2016 8:50 am

Iim VERY unsure about doing this myself. Are there options out there to upgrade? Im having issues with mail and Ive been informed to upgrade, but I dont want to mess up my site.

New member

Posts

Joined
Thu Aug 01, 2013 10:01 am

Post by EvolveWebHosting » Sun Jul 31, 2016 12:17 pm

scottdog129 wrote:Iim VERY unsure about doing this myself. Are there options out there to upgrade? Im having issues with mail and Ive been informed to upgrade, but I dont want to mess up my site.
It's best to hire a developer to do it for you. We offer the service and so does Qphoria. Which version are you looking to upgrade from?

Image
https://www.evolvewebhost.com
Unhappy with your current host? We can migrate your account today (usually for no fee)! Visit our website and signup and we'll take care of the rest!
24/7/365 support
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by scottdog129 » Mon Aug 01, 2016 10:51 pm

I am on 2.0.3.1. Trying to resolve a mail issue.

New member

Posts

Joined
Thu Aug 01, 2013 10:01 am

Post by straightlight » Mon Aug 01, 2016 11:04 pm

scottdog129 wrote:I am on 2.0.3.1. Trying to resolve a mail issue.
Regarding email issues, if erroneous occurs specifically from Opencart, followed is a FAQ topic including email troubleshooting steps: http://forum.opencart.com/viewtopic.php ... 57#p630707 .

To troubleshoot and provide the source of the error message, I would suggest following the Essentials topic: http://forum.opencart.com/viewtopic.php?f=190&t=165636 (Error logs section).

Tired of paying for service fees to export your database from other databases over Opencart?

Try those extensions for FREE: http://www.opencart.com/index.php?route ... aightlight

Regards,
Straightlight


Expert Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by scottdog129 » Mon Aug 01, 2016 11:48 pm

Im getting this error when updating history.

Image

New member

Posts

Joined
Thu Aug 01, 2013 10:01 am

Post by straightlight » Mon Aug 01, 2016 11:56 pm

This error message is part of my first link solution above. :)

Tired of paying for service fees to export your database from other databases over Opencart?

Try those extensions for FREE: http://www.opencart.com/index.php?route ... aightlight

Regards,
Straightlight


Expert Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by scottdog129 » Mon Aug 01, 2016 11:59 pm

I think I figured it out. It was set to SMTP without anything entered for server or credentials. Is there a way to test the email that customers get when ordering? Can I have the system send that to myself?

New member

Posts

Joined
Thu Aug 01, 2013 10:01 am

Post by straightlight » Tue Aug 02, 2016 12:16 am

scottdog129 wrote:I think I figured it out. It was set to SMTP without anything entered for server or credentials. Is there a way to test the email that customers get when ordering? Can I have the system send that to myself?
There are no test modes for emails. However, the followed FAQ topic demonstrate on how to test a transaction which also leads to email confirmation without affecting your customers: http://forum.opencart.com/viewtopic.php?f=170&t=165829

Tired of paying for service fees to export your database from other databases over Opencart?

Try those extensions for FREE: http://www.opencart.com/index.php?route ... aightlight

Regards,
Straightlight


Expert Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 10 guests