Post by pm-netti » Sun Aug 07, 2016 11:24 pm

Renecek wrote:Hello, first of all thank you very much for this script. I followed first post but didn't successfully upgrade my shop.

WHAT I HAVE?
I have OpenCart 1.5.6.4.

WHAT I WANT?
I want to have clean OpenCart 2.2.0 but I need to keep my customers, products, orders etc..
My idea is upgrade 1.5.6.4. to 2.2.0, then I export products, customers, orders etc.. from phpmyadmin and will import it to new database where is clean opencart 2.2.0.
So I uploaded 2.2.0 EXCEPT install folder and overwrited all files of course. I upload folder install (downloaded in 1st post) to root, then I run http://myshop.com/install

It shows me upgrade was successfully BUT:
1. If I open some order in administration, popup window shows me "error undefinied" (see attachment)
2. in order I can't add rewards points, affiliate etc.. can't click on green buttons
3. Parse error: syntax error, unexpected '&&' (T_BOOLEAN_AND), expecting ')' in /web/sub/v2/admin/controller/customer/customer.php on line 1105

Any solution please? Tried it 2 times.. Thank you
2 and 3: You upload bugs fix 2.2. file to admin > extension > installer:
https://github.com/pekka2/OpenCart-Migr ... .ocmod.xml
1:Can you look javascript console?

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by zendframeworks » Fri Aug 12, 2016 1:51 am

I have followed your script and upgraded the site from 2.0.1.1 to 2.2.0.0 but i am getting this error "error Undefined". I confirmed its not 3rd party extensions as it comes even with app xmls removed and modification refreshed, vqcache removed.
I was wondering If anyone was able to solve it.

Greyed out save button-after making changes
Image

order - order edit(repeated many times) Settings - And - Dashboard_error Repeated twice on Dashboard With No maps/charts
Image


Posts

Joined
Mon Jun 27, 2016 10:59 pm

Post by zendframeworks » Fri Aug 12, 2016 5:17 am

The error I get in chrome dev tools is

Code: Select all

Navigated to https://xxxxxx.com/admin/index.php?route=common/dashboard&token=xxxx
XMLHttpRequest cannot load https://www.xxxxx.com/admin/index.php?route=dashboard/chart/chart&token=xxxxx&range=month. Request header field X-Requested-With is not allowed by Access-Control-Allow-Headers in preflight response.


XMLHttpRequest cannot load https://www.xxxxx.com/admin/index.php?route=dashboard/map/map&token=xxxxx. Request header field X-Requested-With is not allowed by Access-Control-Allow-Headers in preflight response.

I have added The below fix also

Code: Select all

//=======================================================================================================================
// RJ - 20160306 - Force Admin to SSL
// Fix: Force Admin to SSL - 20160306 - daniGo  - v1.0.0
//=======================================================================================================================

	<file name="system/config/catalog.php">
		<operation error="abort"> 
		   <search position="replace"><![CDATA[$_['site_ssl']         = false;]]></search>
			<add><![CDATA[$_['site_ssl']         = true;]]></add>
		</operation>

	</file>

	<file name="system/config/admin.php">
		<operation error="abort"> 
		   <search position="replace"><![CDATA[$_['site_ssl']          = false;]]></search>
			<add><![CDATA[$_['site_ssl']         = true;]]></add>
		</operation>

	</file>

	<file name="system/config/default.php">
		<operation error="abort"> 
		   <search position="replace"><![CDATA[$_['site_ssl']             = false;]]></search>
			<add><![CDATA[$_['site_ssl']         = true;]]></add>
		</operation>

	</file>

	<file name="system/config/install.php">
		<operation error="abort"> 
		   <search position="replace"><![CDATA[$_['site_ssl']          = false;]]></search>
			<add><![CDATA[$_['site_ssl']         = true;]]></add>
		</operation>

	</file>
I have this in .htaccess about cross origin

Code: Select all

Header add Access-Control-Allow-Origin "*" 
But nothing solves the issue


Posts

Joined
Mon Jun 27, 2016 10:59 pm

Post by pm-netti » Thu Sep 01, 2016 10:17 pm

This is yet timely, so to Up. :)

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by fibag21 » Fri Sep 30, 2016 2:53 am

Hi,

tried to upgrade, on my localhost, from 2.0.3.1 to 2.2.0.0.

Error during upgrade process:

[Exception... "" nsresult: "0x805e0006 ()" location: "JS frame :: https://localhost/opencart/install/view ... 1.1.min.js :: .send :: line 4" data: no] [Exception... "" nsresult: "0x805e0006 ()" location: "JS frame :: https://localhost/opencart/install/view ... 1.1.min.js :: .send :: line 4" data: no] undefined

So upgrade not performed and cart is now broken.

Fortunately, I had a VM snapshot. But still, some way to upgrade would be gould.
Thanks

Newbie

Posts

Joined
Sat Mar 26, 2016 3:10 am

Post by boredmind » Thu Oct 27, 2016 4:00 am

Hello,


I want to upgrade from 2.0.1.1 to 2.2.0.0. But the database is messed up, I have made a new installation, cleared and perfect as I want. The only problem I have now is with the database. I want to copy customers and orders to the new installation is it possible to copy every table from phpmyadmin? will it work ?

Thank you.
Tasos

New member

Posts

Joined
Sat Jul 12, 2014 4:26 pm
Location - Metamorfosi,Athens,Greece

Post by OSWorX » Thu Oct 27, 2016 4:49 pm

boredmind wrote:Hello,


I want to upgrade from 2.0.1.1 to 2.2.0.0. But the database is messed up, I have made a new installation, cleared and perfect as I want. The only problem I have now is with the database. I want to copy customers and orders to the new installation is it possible to copy every table from phpmyadmin? will it work ?

Thank you.
Tasos
Yes, but partly!
You have to adopt the tables - compare the old tables with the new and adopt them.

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by borolaweb » Thu Nov 10, 2016 6:30 pm

Hi, how can i update from 2.2.0.0 to the latest version?

Newbie

Posts

Joined
Mon Jun 27, 2016 3:43 pm

Post by evopixel » Mon Jan 09, 2017 5:32 pm

The link is broken, it would be fab if you can fix it for us ;o)

Many thanx
@lex

Newbie

Posts

Joined
Mon Apr 28, 2014 4:20 pm

Post by dxer » Tue Jan 31, 2017 11:09 pm

I want to upgrade from 1.5.6.1 to 2.3. if it is possible. Can I do this from Opencart 2.3.0.2 upgrade script or this is not safe ?
As I am using Pav Decore theme on the 1.5.6.1. should I install new version of this theme on the 2.3.0.2. before upgrade from 1.5.6.1 or after upgrade ?
The same question is for extensions ?

New member

Posts

Joined
Thu Dec 13, 2012 10:32 pm

Post by thekrotek » Wed Feb 01, 2017 12:37 am

dxer wrote:I want to upgrade from 1.5.6.1 to 2.3. if it is possible. Can I do this from Opencart 2.3.0.2 upgrade script or this is not safe ? As I am using Pav Decore theme on the 1.5.6.1. should I install new version of this theme on the 2.3.0.2. before upgrade from 1.5.6.1 or after upgrade ? The same question is for extensions ?
It of course possible, yet require some knowledge. If you can't do it yourself, feel free co contact me via email or Skype by support@thekrotek.com. We'll discuss it further.

Professional OpenCart extensions, support and custom work.
Contact me via email support@thekrotek.com


User avatar
Active Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by esprit1st » Wed Oct 25, 2017 10:00 pm

Hi,

I tried to upgrade from 1.5.6.4. It starts out working, then right after it's finished with 1000.php it shows an undefined error. The progress bar shows the green 1000 and then immediately displays the undefined error.
Any suggestions?
I checked php and mysql log. No error messages found.

Thank you!

Newbie

Posts

Joined
Sun Feb 17, 2013 6:57 am

Post by straightlight » Wed Oct 25, 2017 10:28 pm

See in your server error logs or in your Opencart error.txt file what is the detailed message about the undefined error.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by esprit1st » Thu Oct 26, 2017 1:00 am

I don't get any error messages in the opencart/system/logs/error.log during the upgrade.
I am getting some mysql-errors if I try to load the shop homepage which makes sense, since I have the 2.2 files with the 1.5 partly updated database.

Newbie

Posts

Joined
Sun Feb 17, 2013 6:57 am

Post by straightlight » Thu Oct 26, 2017 3:18 am

What are those mySQL error messages you are receiving?

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by esprit1st » Thu Oct 26, 2017 10:48 pm

Here is the output of the shop frontend as mentioned DB is 1.5 with patch 1000 successfully applied, and 2.2 files.

Code: Select all

Warning: mysqli::query(): Couldn't fetch mysqli in opencart/shop/system/library/db/mysqli.php on line 18
Warning: DB\MySQLi::query(): Couldn't fetch mysqli in opencart/shop/system/library/db/mysqli.php on line 20
Notice: Trying to get property of non-object in opencart/shop/catalog/model/extension/event.php on line 6
Warning: Invalid argument supplied for foreach() in opencart/shop/catalog/controller/startup/event.php on line 9
Warning: mysqli::real_escape_string(): Couldn't fetch mysqli in opencart/shop/system/library/db/mysqli.php on line 45
Warning: mysqli::query(): Couldn't fetch mysqli in opencart/shop/system/library/db/mysqli.php on line 18
Warning: DB\MySQLi::query(): Couldn't fetch mysqli in opencart/shop/system/library/db/mysqli.php on line 20
Notice: Trying to get property of non-object in opencart/shop/catalog/model/design/layout.php on line 6
Warning: mysqli::real_escape_string(): Couldn't fetch mysqli in opencart/shop/system/library/db/mysqli.php on line 45
Warning: mysqli::query(): Couldn't fetch mysqli in opencart/shop/system/library/db/mysqli.php on line 18
Warning: DB\MySQLi::query(): Couldn't fetch mysqli in opencart/shop/system/library/db/mysqli.php on line 20
Notice: Trying to get property of non-object in opencart/shop/catalog/model/design/layout.php on line 16
Warning: Invalid argument supplied for foreach() in opencart/shop/catalog/controller/common/column_left.php on line 48
Error: A theme has not been assigned to this store!
Warning: mysqli::close(): Couldn't fetch mysqli in opencart/shop/system/library/db/mysqli.php on line 61
Thank you for your help. I appreciate it!

Newbie

Posts

Joined
Sun Feb 17, 2013 6:57 am

Post by straightlight » Fri Oct 27, 2017 12:10 am

This error seem to be caused by the fact that the connection is being closed from the __destruct method of the system/library/db/mysqli.php file: https://stackoverflow.com/questions/199 ... tch-mysqli .

In your config.php file and admin/config.php file, switch from mysqli to: mpdo and see if the error message persists once you restored backups.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by esprit1st » Fri Oct 27, 2017 12:41 am

Unfortunately I'm getting this error:

Code: Select all

Error: Could not load database driver type mpdo!

Newbie

Posts

Joined
Sun Feb 17, 2013 6:57 am

Post by straightlight » Fri Oct 27, 2017 12:58 am

Not considering lowercases, got it. Rename mpdo to: mPDO .

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by esprit1st » Fri Oct 27, 2017 3:47 pm

Same thing, no database driver:
Error: Could not load database driver type mPDO!

Newbie

Posts

Joined
Sun Feb 17, 2013 6:57 am
Who is online

Users browsing this forum: No registered users and 13 guests