Post by kirkhall » Fri Jun 24, 2016 2:56 am

labeshops wrote:Version 2.2 does not use the English folder - it uses the en-gb folder. So any language changes you need to make, you need to do in that folder.
Ok, thanks for that.

Active Member

Posts

Joined
Thu May 22, 2014 11:31 am
Location - Missouri, USA

Post by labeshops » Fri Jun 24, 2016 9:23 am

Moved to a new topic as it is not related to the upgrade script and I don't want to confuse others
Last edited by labeshops on Sun Jul 03, 2016 7:50 am, edited 2 times in total.

Running Opencart v2.2 with multi-stores from http://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by platypuspuzzles » Sun Jun 26, 2016 10:52 pm

Hi all

I've updated onto a copy of my store and the upgrade script worked like a charm from 2.0.3.1 to 2.2.0.0

I had this same error for guest.php and shipping_method.php but was able to find the fix on the forum.

I haven't been able to find a fix for this one though:

SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

OK

<b>Notice</b>: Undefined index: comment in <b>/.../catalog/controller/checkout/payment_method.php</b> on line <b>186</b>[]

Any help greatly appreciated

Active Member

Posts

Joined
Sun Jan 23, 2011 8:11 pm

Post by platypuspuzzles » Mon Jun 27, 2016 11:55 pm

FIXED - Checkout JSON errors for all checkout options (guest/register new account/log in/change address etc)
I've attached the fixed files in the below thread
'http://forum.opencart.com/viewtopic.php?f=190&t=162066

Active Member

Posts

Joined
Sun Jan 23, 2011 8:11 pm

Post by Qphoria » Tue Jun 28, 2016 1:28 am

Updated new zip in first post with additional bug fixes and changes.

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Qphoria » Tue Jun 28, 2016 2:29 am

pm-netti wrote:There in catalog.php is bug:

Code: Select all

// Action Events
$_['action_event'] = array(
	'view/*/before' => 'event/theme',
	//'model/*/before' => 'event/debug/before'
	//'model/*/after' => 'event/debug/after'
);
change to:

Code: Select all

// Action Events
$_['action_event'] = array(
	'view/*/before' => 'event/theme'
	//'model/*/before' => 'event/debug/before'
	//'model/*/after' => 'event/debug/after'
);
I don't see a difference.

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by pm-netti » Tue Jun 28, 2016 3:45 pm

Qphoria wrote:
pm-netti wrote:There in catalog.php is bug:

Code: Select all

// Action Events
$_['action_event'] = array(
	'view/*/before' => 'event/theme',
	//'model/*/before' => 'event/debug/before'
	//'model/*/after' => 'event/debug/after'
);
change to:

Code: Select all

// Action Events
$_['action_event'] = array(
	'view/*/before' => 'event/theme'
	//'model/*/before' => 'event/debug/before'
	//'model/*/after' => 'event/debug/after'
);
I don't see a difference.

Code: Select all

$_['action_event'] = array(
	'view/*/before' => 'event/theme',
);
change to:

Code: Select all

$_['action_event'] = array(
	'view/*/before' => 'event/theme'
);
shorted code :)

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by Qphoria » Fri Jul 01, 2016 2:16 am

Ohh the comma. Yea that's not really part of the upgrade here.

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by labeshops » Sat Jul 02, 2016 8:34 pm

Just remembered that I had run the turbo script on my db a while back viewtopic.php?f=20&t=160694 - could this have interfered with the upgrade script?

Thought I'd ask in case someone else is getting ready to upgrade and used it.

Running Opencart v2.2 with multi-stores from http://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by platypuspuzzles » Sun Jul 03, 2016 6:04 pm

Apologies if this isn't the correct place for this... though I'd primarily like to highlight that the core coding be changed to the below, in upload/catalog/view/theme/default/template/payment/pp_standard.tpl as currently, sellers do not have seller protection with PayPal, with the current coding.

Code: Select all

<input type="hidden" name="no_shipping" value="0" />
or

Code: Select all

<input type="hidden" name="no_shipping" value="2" />

From what I've read today, core coding in upload/catalog/view/theme/default/template/payment/pp_standard.tpl was changed to prevent a customer changing their address in PayPal which would mean Opencart wouldn't pick up the change, and sellers would post to an incorrect address.

Code below is from core files - 1 means DO NOT prompt for an address, causing sellers to lose seller protection

Code: Select all

+  <input type="hidden" name="no_shipping" value="1" />

As per the reply provided by supak111 on the below thread, PayPal have three shipping code choices..
viewtopic.php?f=190&t=138451&sid=a6c6e1 ... 7&start=20

0 – prompt for an address, but do not require one
1 – do not prompt for an address
2 – prompt for an address, and require one

SUGGESTION: Provide an option box in admin>payments>paypal payments standard> edit on the general tab to allow OC users to select between the above 3 PayPal address prompt options.

Alternatively, is there another solution to provide seller protection whilst allowing customers to change their address in PayPal post purchase/pre shippment, and have a notification and change of address picked up by Opencart?

Active Member

Posts

Joined
Sun Jan 23, 2011 8:11 pm

Post by platypuspuzzles » Sun Jul 03, 2016 11:51 pm

just wanted to say thanks for all the hard work.

My site is live and error free!

The issues I had were:
checkout (updated php files were added to version 8)
SSL not working (extension force SSL and the creator fixed the errors created)
PayPal lost seller protection (see above posts from me on how I fixed this)

I have a couple of small issues with two payment extensions, but these are both minor coding issues which do not effect the customer's experience.

Active Member

Posts

Joined
Sun Jan 23, 2011 8:11 pm

Post by GiaiPhapHay » Tue Jul 05, 2016 3:01 pm

Thank you so much.

lam bang dai hoc ha noi | lam bang cap 3 uy tin


Newbie

Posts

Joined
Tue Jul 05, 2016 2:47 pm

Post by fireatwire » Thu Jul 07, 2016 9:08 pm

I have a store on 1.4.9.6 which I want to upgrade to 2.2.
So far I have used the upgrade-14x-to-15x Script with success. After that I have uploaded OC 2.2 files und this upgrade script. Unfortunately it didn't work.
Is my workflow correct? Do I first need to install version 1.5.x and make some changes before I continue with this script?
(I have been trying the whole week on my local dev-system before I posted here)

New member

Posts

Joined
Wed Feb 03, 2010 5:21 am

Post by i2Paq » Thu Jul 07, 2016 9:21 pm

fireatwire wrote:Unfortunately it didn't work.
Explain.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

UPGRADE to 2.x: Contemplate before thou begins!

Our FREE search: Find your answer FAST!.

BUGs?: Known BUGS for All OC Versions.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by pm-netti » Fri Jul 08, 2016 4:24 am

fireatwire wrote:I have a store on 1.4.9.6 which I want to upgrade to 2.2.
So far I have used the upgrade-14x-to-15x Script with success. After that I have uploaded OC 2.2 files und this upgrade script. Unfortunately it didn't work.
Is my workflow correct? Do I first need to install version 1.5.x and make some changes before I continue with this script?
(I have been trying the whole week on my local dev-system before I posted here)
http://www.opencart.com/index.php?route ... n_id=24347

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by Qphoria » Fri Jul 08, 2016 9:00 am

fireatwire wrote:I have a store on 1.4.9.6 which I want to upgrade to 2.2.
So far I have used the upgrade-14x-to-15x Script with success. After that I have uploaded OC 2.2 files und this upgrade script. Unfortunately it didn't work.
Is my workflow correct? Do I first need to install version 1.5.x and make some changes before I continue with this script?
(I have been trying the whole week on my local dev-system before I posted here)
You did it correctly. but what "didn't work" ?

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by fireatwire » Fri Jul 08, 2016 5:26 pm

It's working now! I forgot to change permissions for some folders after I uploaded the new files (CHMOD had changed).

New member

Posts

Joined
Wed Feb 03, 2010 5:21 am

Post by Sathish2317 » Thu Jul 21, 2016 3:53 pm

I was trying to upgrade opencart frmo 1.5.6.4 to 2.2.0.0 .I followed the following Steps.

How to use:
This package should replace the existing "install" folder from 2.2.0.0 when you first unzip.
1. Download the OpenCart 2.2.0.0 zip file (do not use this script for any other version. Newer versions may already have updated versions of the upgrade script.)
2. Upload all files and folders from inside the "upload" folder to your server EXCEPT for the "install" folder. Overwrite the existing files on your server. You do not need any file outside of the upload folder.
3. Download my upgrade package from the bottom of this post
4. Upload the "install" folder within to the root of your store. The same place you uploaded admin, catalog, etc
5. Run the upgrade script by going to
CODE: SELECT ALL
http://<yoursite.com>/install

I got an error while upgrading like this:

Fatal error: Call to undefined method Session::start() in D:\wamp\www\openold\system\framework.php on line 31
Call Stack
# Time Memory Function Location
1 0.0007 258608 {main}( ) ..\index.php:0
2 0.0206 1855152 require_once( 'D:\wamp\www\openold\system\framework.php' ) ..\index.php:34

Please help me...

Newbie

Posts

Joined
Thu Jul 21, 2016 3:45 pm

Post by Vady » Wed Jul 27, 2016 7:04 am

Hello, I've tried this tutorial, and when running the upgrade script, I'm getting this:

SyntaxError: Unexpected token < in JSON at position 0 OK

Can anyone help me please?

Newbie

Posts

Joined
Wed Jul 27, 2016 5:58 am

Post by Renecek » Sun Aug 07, 2016 7:00 pm

Hello, first of all thank you very much for this script. I followed first post but didn't successfully upgrade my shop.

WHAT I HAVE?
I have OpenCart 1.5.6.4.

WHAT I WANT?
I want to have clean OpenCart 2.2.0 but I need to keep my customers, products, orders etc..
My idea is upgrade 1.5.6.4. to 2.2.0, then I export products, customers, orders etc.. from phpmyadmin and will import it to new database where is clean opencart 2.2.0.
So I uploaded 2.2.0 EXCEPT install folder and overwrited all files of course. I upload folder install (downloaded in 1st post) to root, then I run http://myshop.com/install

It shows me upgrade was successfully BUT:
1. If I open some order in administration, popup window shows me "error undefinied" (see attachment)
2. in order I can't add rewards points, affiliate etc.. can't click on green buttons
3. Parse error: syntax error, unexpected '&&' (T_BOOLEAN_AND), expecting ')' in /web/sub/v2/admin/controller/customer/customer.php on line 1105

Any solution please? Tried it 2 times.. Thank you

Attachments

Snímka obrazovky 2016-08-07 o 12.55.41.png

Snímka obrazovky 2016-08-07 o 12.55.41.png (156.65 KiB) Viewed 1406 times


New member

Posts

Joined
Thu Dec 10, 2015 7:12 pm
Who is online

Users browsing this forum: No registered users and 13 guests