Post by stusand » Tue Jan 12, 2016 5:38 pm

Did anyone ever find a solution for this?

I tried a clean install of version 2.1.0.1 on a 1and1 managed server and couldn't get past step 3 with the same error message as above.

I plan to use Openbay Pro to link my store to eBay, so I could go back and install version 1.5 as it is still supported. However, if the Openbay Pro plug-in stops supporting 1.5 as it undoubtedly will at some point, then this could end up being a major problem. I'd rather get this sorted now than having to find some answer later on.

Newbie

Posts

Joined
Mon Jun 13, 2011 11:00 pm

Post by cactustactical » Wed Jan 13, 2016 12:37 am

I gave up trying to install v 2.xx on both 1and1 and hostgator and installed 1.5.6 on a 1and1 managed server with no issues.

Have been integrating the OC cart with our Thub environment over the last month or so with mixed results. The 1and1 managed server we have this on is not PCI compliant and they state that one must use a user managed server for PCI compliance if that is needed by you.

But, for your main question, no we were never able to get the install to work on 2 different servers on 2 different companies.


Posts

Joined
Wed Aug 05, 2015 3:38 am

Post by Chops » Tue Jan 26, 2016 9:17 pm

Hi, I'm new to Opencart as of today, but I've been using another solution for over 5 years, which was great up until about two years ago, when the old install corrupted itself and then the new install (latest version) never really worked properly and the TC project team just seemed to die off.

I've let it sit offline for over 18 months and moved a lot of my gear thru a bigcartel store of another online business I run.

But now want to get back in to my own hosted/run store for this specific business and clean up the bigcartel one as it's way too busy with products now, so after some research I found OpenCart which looked to have a lot of support and good reviews, plus seem somewhat familiar to the old one, even down to the support forum..!? Mind you, I can't even get it installed as yet?

Anyway, so far I've lost a day trying to install ver 2.1.0.2 - being unable to get past step 3/4 due to 'access denied for user 'xxxx_xxxx'@'localhost' (using password: YES)

I've tried what knowledge I have of MySQL DB and Account admin.. I've confirmed all the requirements are met, I've deleted and recreated accounts, confirming permissions. I've checked all the folder and file permissions. And it's now 11pm at night.. and after many hours of surfing the support forum.. can see that this issue is 'Very Common' in ver 2.x with no apparent fix out there..?

I'm now deleting all the install files and looking to upload 1.5.6.4 - as from what I can read, is the only possible way of getting it running on my host (HostGator).

I have to say.. not a great start.. if I'm to fall in love with this solution.. it's a rough start.

Anyway, I've not written it off yet, but am feeling a tad uncertain..?

That's my five cents worth...

Regards, JD

User avatar
Newbie

Posts

Joined
Tue Jan 26, 2016 8:16 pm
Location - Australia

Post by deepvision » Mon May 16, 2016 4:38 pm

It's easy to make it work on 1and1.

Just add the following to php.ini :

Code: Select all

mysqli.default_socket=/tmp/mysql5.sock
And in the config.php change the

Code: Select all

define('DB_HOSTNAME', 'localhost:/tmp/mysqli.sock');
to

Code: Select all

define('DB_HOSTNAME', 'localhost');

ImageImageImage


User avatar
Active Member

Posts

Joined
Tue May 19, 2015 1:03 am
Who is online

Users browsing this forum: No registered users and 18 guests