Post by vaclavtichy » Wed Oct 31, 2018 9:12 pm

hello

I would like upgrade our opencart 2.3.0.2 on latest version opencart 3, but after copy files i have this error:


Fatal error: Uncaught exception 'Exception' with message 'Error: Could not load template adaptor !' in /www/doc/www.edokodo.cz/www/system/library/template.php:28 Stack trace: #0 /www/doc/www.edokodo.cz/www/system/storage/modif ... er.php(81): Template->__construct(NULL) #1 /www/doc/www.edokodo.cz/www/install/controller/c ... er.php(14): Loader->view('common/header', Array) #2 [internal function]: ControllerCommonHeader->index(Array) #3 /www/doc/www.edokodo.cz/www/system/storage/modif ... on.php(51): call_user_func_array(Array, Array) #4 /www/doc/www.edokodo.cz/www/system/storage/modif ... er.php(24): Action->execute(Object(Registry), Array) #5 /www/doc/www.edokodo.cz/www/install/controller/u ... de.php(28): Loader->controller('common/header') #6 [internal function]: ControllerUpgradeUpgrade->index() #7 /www/doc/www.edokodo.cz/www/system/storage/modif ... on.php(51): call_user_func_array(Array, Array) #8 /www/doc/www.edokodo.cz/ in /www/doc/www.edokodo.cz/www/system/library/template.php on line 28

Do you have idea, what i can to do? I have it on testing adress http://www.edokodo.cz.uvirt72.active24. ... de/upgrade

Thank you

Vaclav

New member

Posts

Joined
Fri Dec 29, 2017 11:04 pm

Post by Elevate » Wed Oct 31, 2018 10:48 pm

Check to make sure all of the files in the template folder were properly uploaded

Elevate
Custom Website Developers
https://www.elev8your.com


New member

Posts

Joined
Fri Jul 06, 2018 12:40 am
Location - Denver, Colorado, USA

Post by vaclavtichy » Thu Nov 01, 2018 12:03 am

Hi,
yes, everything okay, i tried install newone - https://www.opencart.com/index.php?rout ... n_id=12478 but problem is still same

Thank you
Vaclav

New member

Posts

Joined
Fri Dec 29, 2017 11:04 pm

Post by OSWorX » Thu Nov 01, 2018 12:29 am

vaclavtichy wrote:
Wed Oct 31, 2018 9:12 pm
I would like upgrade our opencart 2.3.0.2 on latest version opencart 3 ..
What is the latest version of OpenCart 3 ??
I hope, you don't mean 3.1.x
Latest useable Version is 3.0.2.0

Forum Rules: viewtopic.php?f=176&t=200480
Commercial Request: viewforum.php?f=88

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by OSWorX » Thu Nov 01, 2018 12:30 am

vaclavtichy wrote:
Thu Nov 01, 2018 12:03 am
Hi,
yes, everything okay, i tried install newone - https://www.opencart.com/index.php?rout ... n_id=12478 but problem is still same

Thank you
Vaclav
This theme will never work on 3.x - it is for 1.5.x !

Forum Rules: viewtopic.php?f=176&t=200480
Commercial Request: viewforum.php?f=88

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by vaclavtichy » Thu Nov 01, 2018 1:43 am

Hi
i mean OpenCart 3.0.2.0. :-)
i dont undertand, why is in error in /www/doc/www.edokodo.cz/www/system/library/templat if i have anyehwere in config in /www/doc/http://www.edokodo.cz.uvirt72.active24. ... ry/templat....

Our stable version is on www.edokodo.cz but test version is on http://www.edokodo.cz.uvirt72.active24.cz

Oh, we template.. ok, i recover correct version :)

Thank you
Vaclav

New member

Posts

Joined
Fri Dec 29, 2017 11:04 pm

Post by vaclavtichy » Thu Nov 08, 2018 5:51 pm

Nobody with idea? :(


Vaclav

New member

Posts

Joined
Fri Dec 29, 2017 11:04 pm

Post by straightlight » Thu Nov 08, 2018 7:02 pm

Hi
i mean OpenCart 3.0.2.0. :-)
i dont undertand, why is in error in /www/doc/www.edokodo.cz/www/system/library/templat if i have anyehwere in config in /www/doc/http://www.edokodo.cz.uvirt72.active24. ... ry/templat....
Create a new service request in the Commercial Support section of the forum to get this done as a custom job.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by OSWorX » Thu Nov 08, 2018 9:16 pm

vaclavtichy wrote:
Thu Nov 08, 2018 5:51 pm
Nobody with idea? :(
Yes.
Basically, what I never will and can understand, is that everybody wants to update with the update scripts.
LET IT!

A bit more work, but no headaches: do that manual.

Simple done by:

1. install new shopversion in a new folder - with a new table prefix or a new database
2. go into your database management tool (e.g. phpMyAdmin) and make an export of old and new database (that why 2 should be used)
3. compare the old tables with the new
4. add those fieldls which are missing to the new tables (can be deleted afterwards)
5. compare tables and fields - if new tables and new fields, check which are the corresponding old tables and fields
6. check new fields if they have a new name (e.g. instead order_id > order_ids)
7. import now the adapted (new) database into the new database

Beside this, check also the requried extensions if they are required (1.) and if they are compatible (2.) with the new shop version
Install only the needed extensions in the new shop: if the are using database tables, copy them into the new database.

Template: very rare that a template will work under 2 different shopversions.
Either get a new, compatible version you can use in the new shop.
Or use another.
Or update it by yourself (of hire someone).

Finally check the result.

Working time for an update from 2.x to 3.x: approx. 4 hours maximum (without template).
And we never will hear from you here, because of a failed update!

Is that so hard to understand?

Forum Rules: viewtopic.php?f=176&t=200480
Commercial Request: viewforum.php?f=88

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by vaclavtichy » Fri Nov 09, 2018 9:52 pm

Hello

thank you so much for help. Step 1 and 2 is okay, but "compare the old tables with the new". You mean compare manualy, or some merge tools?

Thank you so much

Vaclav

New member

Posts

Joined
Fri Dec 29, 2017 11:04 pm

Post by OSWorX » Fri Nov 09, 2018 10:25 pm

vaclavtichy wrote:
Fri Nov 09, 2018 9:52 pm
Hello

thank you so much for help. Step 1 and 2 is okay, but "compare the old tables with the new". You mean compare manualy, or some merge tools?

Thank you so much

Vaclav
As written:
do that manual
Means no tools, handmade.

Forum Rules: viewtopic.php?f=176&t=200480
Commercial Request: viewforum.php?f=88

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria
Who is online

Users browsing this forum: No registered users and 8 guests