Post by danmatthews-SH » Thu Aug 16, 2018 6:56 pm

Hello!

To cut a long story short, I need to update the jQuery on our website in order to pass the 2nd part of PCI Compliance - Network Vulnerability Scan. We have the Fastor theme installed on OC version 2.1.0.1.

Can someone help advise where to, and how to, update jQuery? It has had a knock-on effect on our PayPal account, and unfortunately I am not the most code-proud person around so anything 'dumbed down' would be much appreciated!

Thanks

DM


Posts

Joined
Thu Aug 16, 2018 6:52 pm

Post by ADD Creative » Fri Aug 17, 2018 12:37 am

You will find jQuery in the folder catalog/view/javascript/jquery/, you would need to replace this with the later version (or remove and use a CDN).

Then you need to change the theme template to include the later version. The the default theme it's at the line at the link below. It's likely to be different in your theme and may even be included from a different folder to the one above.
https://github.com/opencart/opencart/bl ... er.tpl#L20

If you also need to update the admin interface it's in admin/view/javascript/jquery/. And on https://github.com/opencart/opencart/bl ... er.tpl#L14.

I would recommend doing this on a test version of you site first and fully test the upgrade doesn't break anything, especially if you are upgrading from jQuery 2 to 3 (https://jquery.com/upgrade-guide/3.0/). If the scan is detecting what I think it is, then version 3 is probably required. Did the scan give any details as to why and what versions?

ADD Creative - Web development and e-commerce development, Milton Keynes or Christchurch, UK
ADD Filtration - HVAC Panel Filters, Bag Filters and HEPA Filters


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Who is online

Users browsing this forum: No registered users and 2 guests