Post by hongyiu » Wed Mar 29, 2017 1:01 pm

I set up the SSL and succes to access with https://www.mystore.com
but i still can access my store without SSL, like:
www.mystore.com
mystore.com
http://www.mystore.com

How can i redirect all url to SSL in all sub page of my store?

MY opencart version is 2.3.0.2
Last edited by hongyiu on Wed Mar 29, 2017 1:03 pm, edited 1 time in total.

Newbie

Posts

Joined
Wed Feb 15, 2017 3:25 pm

Post by rjcalifornia » Wed Mar 29, 2017 1:36 pm

Did you change the settings of the config.php file? (HTTP to HTTPS)


You can also edit .htaccess

Find this:
Options +FollowSymlinks
And change to this:
Options +FollowSymlinks
RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://yoursite.com/$1 [R=301,L]

Image


Newbie

Posts

Joined
Fri Sep 02, 2011 1:19 pm
Location - Worldwide

Post by mtjhost » Thu Apr 06, 2017 5:59 pm

Hi

I have installed the SSL correctly and tested it on SSL checker correctly. I the Opencart image folder is not using the SSL link and causing the website look insecure. So if we enable SSL from settings, https in the config and admin/config files and correctly using the SSL in website then SSL should work out of the box.

But after doing this all stuff I am unable to getting the all link covered under the https:// when going in the ctrl+shift+J it shows me the links which are not covered and look insecure by SSL team. I contacted the SSL issuer and they said that your base coding of the image links have problem. Image folder is not covered and also the webrupee indian currency module I installed not covered under the https://.

So anyone here can please resolve the best way to sort this problem.

Thanks

Newbie

Posts

Joined
Wed Apr 30, 2014 12:37 am

Post by IP_CAM » Fri Apr 07, 2017 3:45 am

imagewise, you could make 'em linked by 'Image Subdomain linking':
https://www.opencart.com/index.php?rout ... age%20link
and when it comes to the extension you mentioned, you better contact the Supplier.
Good Luck
Ernie

Ernie's OpenShop 1.75 with responsive Bootstrap Themes:
http://www.bigmax.ch - http://www.hitline.info - http://www.openshop.li
Image


User avatar
Newbie

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by sicario » Fri Apr 21, 2017 10:38 am

i think you dont need to force, just use https links instead of http only, then it will secure you server

Newbie

Posts

Joined
Mon Oct 17, 2016 2:31 pm
Who is online

Users browsing this forum: No registered users and 4 guests