Post by satyadeo » Mon Mar 07, 2016 10:59 pm

When I try to Save after editing any module in opencart (1.5.5.1) admin it throws internal server error 500. its happening randomly - 90% of the time it throws error and rest 10% of the time it works without issue.

I am windows server with PHP 5.4 and ioncube loader for paladin module.

Not able to upload any new data. Badly stuck. kindly help.

My web.config file looks as following:

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
<system.webServer>

<defaultDocument>
<files>
<clear />
<add value="index.php" />
<add value="Index.html" />
<add value="Index.htm" />
</files>
</defaultDocument>
<directoryBrowse enabled="false" />
<rewrite>
<rules>
<rule name="rule 1U" stopProcessing="true">
<match url="^sitemap.xml$" />
<action type="Rewrite" url="/index.php?route=feed/google_sitemap" />
</rule>
<rule name="rule 2U" stopProcessing="true">
<match url="^googlebase.xml$" />
<action type="Rewrite" url="/index.php?route=feed/google_base" />
</rule>
<rule name="rule 3U" stopProcessing="true">
<match url="^download/(.*)" />
<action type="Rewrite" url="//index.php?route=error/not_found" />
</rule>
<rule name="block favicon" stopProcessing="true">
<match url="favicon\.ico" />
<action type="CustomResponse" statusCode="404" subStatusCode="1" statusReason="The requested file favicon.ico was not found" statusDescription="The requested file favicon.ico was not found" />
</rule>
<rule name="Imported Rule 1" stopProcessing="true">
<match url="^(.*)$" ignoreCase="false" />
<conditions>
<add input="{HTTP_HOST}" pattern="^ananyafashion\.com$" />
</conditions>

<action type="Redirect" redirectType="Permanent" url="http://www.ananyafashion.com/{R:1}" />
</rule>
<rule name="Imported Rule 2" stopProcessing="true">
<match url="^(.*)$" ignoreCase="false" />
<conditions>
<add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" negate="true" />
<add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" negate="true" />
<add input="{URL}" pattern="^/favicon.ico$" ignoreCase="false" negate="true" />
</conditions>
<action type="Rewrite" url="index.php?_route_={R:1}" appendQueryString="true" />
</rule>
</rules>
</rewrite>
<caching>
<profiles>
<add extension=".php" policy="DisableCache" kernelCachePolicy="DisableCache" />
<add extension=".png" policy="CacheForTimePeriod" kernelCachePolicy="CacheForTimePeriod" duration="30:00:00:00" />
<add extension=".jpeg" policy="CacheForTimePeriod" kernelCachePolicy="CacheForTimePeriod" duration="30:00:00:00" />
<add extension=".gif" policy="CacheForTimePeriod" kernelCachePolicy="CacheForTimePeriod" duration="30:00:00:00" />
<add extension="javascript" policy="CacheForTimePeriod" kernelCachePolicy="CacheForTimePeriod" duration="30:00:00:00" />
<add extension="x-javascript" policy="CacheForTimePeriod" kernelCachePolicy="CacheForTimePeriod" duration="30:00:00:00" />
<add extension="x-shockwave-flash" policy="CacheForTimePeriod" kernelCachePolicy="CacheForTimePeriod" duration="30:00:00:00" />
<add extension="x-icon" policy="CacheForTimePeriod" kernelCachePolicy="CacheForTimePeriod" duration="30:00:00:00" />
<add extension=".css" policy="CacheForTimePeriod" kernelCachePolicy="CacheForTimePeriod" duration="07:00:00:00" />
<add extension=".jpg" policy="CacheForTimePeriod" kernelCachePolicy="CacheForTimePeriod" duration="07:00:00:00" />
<add extension=".js" policy="CacheForTimePeriod" kernelCachePolicy="CacheForTimePeriod" duration="07:00:00:00" />
<add extension=".ttf" policy="CacheForTimePeriod" kernelCachePolicy="CacheForTimePeriod" duration="07:00:00:00" />
<add extension=".json" policy="CacheForTimePeriod" kernelCachePolicy="CacheForTimePeriod" duration="07:00:00:00" />
</profiles>
</caching>
<httpCompression directory="%SystemDrive%\inetpub\temp\IIS Temporary Compressed Files">
<scheme name="gzip" dll="%Windir%\system32\inetsrv\gzip.dll" staticCompressionLevel="6" />
<dynamicTypes>
<add mimeType="text/*" enabled="true" />
<add mimeType="message/*" enabled="true" />
<add mimeType="application/x-javascript" enabled="true" />
<add mimeType="application/json" enabled="true" />
<add mimeType="*/*" enabled="false" />
</dynamicTypes>
<staticTypes>
<add mimeType="text/*" enabled="true" />
<add mimeType="message/*" enabled="true" />
<add mimeType="application/x-javascript" enabled="true" />
<add mimeType="application/atom+xml" enabled="true" />
<add mimeType="application/xaml+xml" enabled="true" />
<add mimeType="*/*" enabled="false" />
</staticTypes>
</httpCompression>

<handlers>
<add name="PHP via FastCGI (*.php)" path="*.php" verb="*" modules="FastCgiModule" scriptProcessor="C:\Program Files (x86)\Parallels\Plesk\Additional\PleskPHP54\php-cgi.exe" resourceType="File" />
</handlers>
</system.webServer>
<system.web>
<sessionState timeout="620" />
</system.web>
</configuration>

Newbie

Posts

Joined
Mon Mar 07, 2016 10:33 pm

Post by paulfeakins » Tue Mar 08, 2016 7:54 pm

satyadeo wrote:When I try to Save after editing any module in opencart (1.5.5.1) admin it throws internal server error 500. its happening randomly - 90% of the time it throws error and rest 10% of the time it works without issue.
Is that actually the case or is it only certain modules that always cause the error? It can be that when posting certain keywords, the firewall blocks the request. Usually that would display a 404 though. It sounds like you should probably contact your web host in either case.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Active Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by Brosss » Thu Jun 23, 2016 2:00 am

And how exactly can we uninstall a core module? Using the Add-on uninstall function does not work...

Newbie

Posts

Joined
Mon Jun 13, 2016 8:38 pm
Who is online

Users browsing this forum: No registered users and 7 guests