Post by Werner D. » Mon Feb 04, 2019 2:21 pm

Hello,
what should I pay attention to, if my server provider (Strato), wants to change the PHP version from 5.2 to 7.2. Is Opencart compatible with PHP 7.2 or crashes my homepage from there.
What's the best way to switch to PHP 7.2 without any problems?
Thank you in advance for your reply.
Greetings Werner

Newbie

Posts

Joined
Mon Feb 04, 2019 2:07 pm

Post by OSWorX » Mon Feb 04, 2019 10:39 pm

First you should pay attention that you have not posted which OpenCart Version you are using!
Because, if an older is used, you have to replace the encryption class.
Using OpenCart with php 7.2 works perfectly - can only recommend it!

Forum Rules [en]: viewtopic.php?f=176&t=200480
Forumregeln [de]: viewtopic.php?f=37&t=114208
Commercial Request: viewforum.php?f=88

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by IP_CAM » Mon Feb 11, 2019 7:35 am

Here is a bunch of PHP-7.x capable encryption files, and they
work in most everything above v.1.5.0 ! But not all of them
still function up to PHP v.7.2x, so try 'em out, one after one.
Ernie

Attachments

PHP v.7.x OpenCart encryption.php Files for OC v.1.5 - up


For Sale: Turnkey Top URLs with Opencart installed!
Latest Opencart LIGHT + V-Pro Test Site: http://www.hitline.info
For more Information, please contact me at: jti@jacob.ch
Free OC Extensions from the largest Github OC Archive on Earth,
635 + free Repositories - from OC v.1.5.x up
on my Github Opencart Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: No registered users and 2 guests