Post by SummerEverdeen » Thu Aug 27, 2015 4:44 pm

Здравейте,

При мен се появява следният проблем:

Качвам магазина, но трябва да скролвам много редове надолу, за да стигна до него. Тези редове посочват грешка: Deprecated preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead на ред 636 във vqmod.php. Замествам preg_raplace с preg_replace_callback и излиза друга грешка: Warning: preg_replace_callback(): Requires argument 2, 'preg_quote("$1"", "~")' to be a valid callback във vqmod.php.

Можете ли да ми кажете как да се справя с проблема?

Благодаря!

Ирена


Posts

Joined
Thu Aug 27, 2015 4:37 pm

Post by agatha65 » Sat Aug 29, 2015 8:35 am

Здравей,
коя версия на vqmod ползваш?
Ако не е последната свали я от тука и пробвай с нея:
https://github.com/vqmod/vqmod/tree/opencart
Ако и това не помага компромисният вариант е да си свалиш версията на php под 5.5.
Виж тука се коментира този проблем и има някакво решение за версия 2.4.1
http://forum.opencart.com/viewtopic.php?f=72&t=121277

Print Version for Product Page and Product Compare Page | Rich Snippets | Facebook Open Graph Meta Tags | Information pages in top menu | Multi-Language Banners, Sliders and Carousels
Image


User avatar
Active Member

Posts

Joined
Fri Mar 16, 2012 10:18 am
Location - Canada, QC
Who is online

Users browsing this forum: No registered users and 1 guest