Post by Matp » Tue Jul 17, 2018 10:49 pm

Hi, this is the first time I post sorry if I am not doing properly, in admin when I click on products I get this message, everything seems to work when I open, modify and save a product, I already had the same type of problem in the past and fixed using topic in link bellow, solution came from Masane , but now does not work, thanks for your help.
http://forum.opencart.com/viewtopic.php?t=120459

Warning: mysql_query(): Access denied for user 'root'@'localhost' (using password: NO) in /home2/globespi/public_html/gs-store/vqmod/vqcache/vq2-admin_model_catalog_product.php on line 7Warning: mysql_query(): A link to the server could not be established in /home2/globespi/public_html/gs-store/vqmod/vqcache/vq2-admin_model_catalog_product.php on line 7Warning: mysql_fetch_assoc() expects parameter 1 to be resource, boolean given in /home2/globespi/public_html/gs-store/vqmod/vqcache/vq2-admin_model_catalog_product.php on line 8Warning: mysql_query(): Access denied for user 'root'@'localhost' (using password: NO) in /home2/globespi/public_html/gs-store/vqmod/vqcache/vq2-admin_model_catalog_product.php on line 30Warning: mysql_query(): A link to the server could not be established in /home2/globespi/public_html/gs-store/vqmod/vqcache/vq2-admin_model_catalog_product.php on line 30Warning: mysql_query(): Access denied for user 'root'@'localhost' (using password: NO) in /home2/globespi/public_html/gs-store/vqmod/vqcache/vq2-admin_model_catalog_product.php on line 7Warning: mysql_query(): A link to the server could not be established in /home2/globespi/public_html/gs-store/vqmod/vqcache/vq2-admin_model_catalog_product.php on line 7Warning: mysql_fetch_assoc() expects parameter 1 to be resource, boolean given in /home2/globespi/public_html/gs-store/vqmod/vqcache/vq2-admin_model_catalog_product.php on line 8Warning: mysql_query(): Access denied for user 'root'@'localhost' (using password: NO) in /home2/globespi/public_html/gs-store/vqmod/vqcache/vq2-admin_model_catalog_product.php on line 30Warning: mysql_query(): A link to the server could not be established in /home2/globespi/public_html/gs-store/vqmod/vqcache/vq2-admin_model_catalog_product.php on line 30

Newbie

Posts

Joined
Sun Jun 06, 2010 4:32 pm

Post by shahid21290 » Tue Jul 17, 2018 11:07 pm

HI,

Please update your database access on config file.

Thanks

For quick, professional OpenCart support please email scf8127@gmail.com


User avatar
New member

Posts

Joined
Fri May 03, 2013 8:32 pm

Post by Matp » Wed Jul 18, 2018 7:29 pm

shahid21290 wrote:
Tue Jul 17, 2018 11:07 pm
HI,

Please update your database access on config file.

Thanks
Thanks for your response, I don't see any errors in both config.php files. I only have this problem when I click on products in admin and save modified product, what do you mean my update, thanks if you have more details

Newbie

Posts

Joined
Sun Jun 06, 2010 4:32 pm

Post by Matp » Wed Jul 18, 2018 7:39 pm

I have just figured out, had in config.php in admin

define('DB_DRIVER', 'mysqli'); changed to define('DB_DRIVER', 'mysql');
now works

Newbie

Posts

Joined
Sun Jun 06, 2010 4:32 pm

Post by MrPhil » Fri Jul 20, 2018 4:58 am

I'm not sure which you're reporting: that you had it using 'mysqli' and you changed it to 'mysql', or vice-versa. From the error messages you posted at the top, it sounds like maybe you were trying to use 'mysql' rather than 'mysqli'. I wouldn't be surprised if 'mysql' failed, as many hosts are no longer bothering to install the old MySQL library, preferring to install the newer MySQLi. Anyway, if you are now running MySQL instead of MySQLi, I would consider that only a temporary reprieve; you should be looking at updating your system so that you can use the newer (and supported) MySQLi.

User avatar
Active Member

Posts

Joined
Wed May 10, 2017 11:52 pm

Post by Matp » Sun Aug 05, 2018 2:36 pm

Hi, thanks for your response, absolutely I made a mix up, everything is working fine with
define('DB_DRIVER', 'mysql');

Newbie

Posts

Joined
Sun Jun 06, 2010 4:32 pm

Post by MrPhil » Sun Aug 05, 2018 9:16 pm

OK, BUT, keep in mind that MySQL could disappear in your host's next PHP build, so you should be thinking about moving to MySQLi. These days it's quite unusual not to have MySQLi available on a server, in addition to (or even, instead of) the old MySQL. If your host doesn't have MySQLi at all, they may be quite behind the times. Just be aware.

User avatar
Active Member

Posts

Joined
Wed May 10, 2017 11:52 pm

Post by straightlight » Sun Aug 05, 2018 10:11 pm

I would have to totally agree here. MySQL server library has been deprecated since quite sometime by the Industry as it no longer recommended to be used within production PCI servers since this library is no longer compliant with RFC standards compared to MySQLi.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 2 guests