Community Forums

OC 1.4.9.6 white screen after deleting an order

Bug reports here

OC 1.4.9.6 white screen after deleting an order

Postby steppen321 » Wed Nov 23, 2011 3:01 am

Hello everybody please help. A client of mine, whom I helped to install OpenCart, discovered very unpleasant thing in OpenCart 1.4:

(in Admin) On Sales > Orders page select orders you want to be deleted
then press "Delete" button
White Screen appers ( URL looks smth like this: http://mydomain.com/admin/index.php?rou ... b36ea4ff6d )

Administrator then is forced to login to admin section once again.
When going back to Sales > Orders, selected orders are actually deleted, but white screen interrupting the work is so annoiyng disturbance.

Any thoughts how to fix it?
Last edited by steppen321 on Wed Nov 23, 2011 10:18 am, edited 2 times in total.
steppen321
 
Posts: 18
Joined: Mon Dec 13, 2010 10:32 am

Re: OC 1.4.9.6 white screen after deleting an order

Postby straightlight » Wed Nov 23, 2011 9:25 am

Hi,

fortunately, no outsiders can typically access your admin interface by simply providing your URL. Although, I would hide my token ID along with it for security reasons.

To answer your question, 1.4.9.6 is not the latest version developed of OpenCart, it would be best to upgrade to the latest release by following the upgrade instructions. If you go to your error log page under the admin, what is the reported event when an order gets deleted ? It looks to me that if you have to log in again each times you delete an order, the token may not be properly re-validated once the order gets actually deleted in order to redirect you to the main sale's order page to advise the admin that the order has been in fact deleted.
Regards,
Straightlight
straightlight
 
Posts: 2053
Joined: Mon Nov 14, 2011 10:38 am
Location: Canada, ON

Re: OC 1.4.9.6 white screen after deleting an order

Postby steppen321 » Wed Nov 23, 2011 10:18 am

Thanks straightlight for shared insights.

My token is fake, so its ok.

Upgrade is one of the options, but I consider it to be the worst scenario, because the client:
    won't pay any money for it
    product options will be lost when upgrading
    the client is super captious (I think he is from hell), so considering so many differencies in OC 1.5 (both frontend ad backend), I'd better block his phone number after an upgrade


For me it's clearly an OC 1.4 bug which i hope someone would help to patch.
steppen321
 
Posts: 18
Joined: Mon Dec 13, 2010 10:32 am

Re: OC 1.4.9.6 white screen after deleting an order

Postby straightlight » Wed Nov 23, 2011 10:41 am

If you go to your admin - > system - > error logs page, what does it report regarding the last actions from the sales orders when you delete one ?
Regards,
Straightlight
straightlight
 
Posts: 2053
Joined: Mon Nov 14, 2011 10:38 am
Location: Canada, ON

Re: OC 1.4.9.6 white screen after deleting an order

Postby steppen321 » Thu Nov 24, 2011 1:28 am

2011-11-23 8:49:29 - PHP Warning: Cannot modify header information - headers already sent by (output started at /home/user/domains/domain.com/public_html/admin/language/lithuanian/sale/order.php:81) in /home/user/domains/domain.com/public_html/vqmod/vqcache/vq2-system_engine_controller.php on line 27


The 27th line in that file is:

header('Location: ' . str_replace('&', '&', $url));


VQMod version - the newest 2.1.5


I think maybe I should try without VQMod.
steppen321
 
Posts: 18
Joined: Mon Dec 13, 2010 10:32 am

Re: OC 1.4.9.6 white screen after deleting an order

Postby steppen321 » Thu Nov 24, 2011 1:36 am

Well, it behaves the same without VQMod too.


This time error log showed that:

2011-11-24 7:35:30 - PHP Warning: Cannot modify header information - headers already sent by (output started at /home/user/domains/domain.com/public_html/admin/language/lithuanian/sale/order.php:81) in /home/user/domains/domain.com/public_html/system/engine/controller.php on line 27


Contents of the /system/engine/controller.php:

26 protected function redirect($url) {
27 header('Location: ' . str_replace('&', '&', $url));
28 exit();
29 }
steppen321
 
Posts: 18
Joined: Mon Dec 13, 2010 10:32 am

Re: OC 1.4.9.6 white screen after deleting an order

Postby awollenh » Fri Apr 13, 2012 1:38 am

Got the same error on 1.5.1.3 but the error log doesnt show any useful errors.

Don't know what i can do. :-/
awollenh
 
Posts: 8
Joined: Fri Jul 29, 2011 2:46 am

Re: OC 1.4.9.6 white screen after deleting an order

Postby straightlight » Fri Apr 13, 2012 6:15 am

Since you claim to have the same error as above, what is on line 81 of your admin/language/lithuanian/sale/order.php:81 ?
Regards,
Straightlight
straightlight
 
Posts: 2053
Joined: Mon Nov 14, 2011 10:38 am
Location: Canada, ON


Return to Bug Reports

Who is online

Users browsing this forum: mandamexico and 20 guests

Hosted by Arvixe Web Hosting