Post by sabine1 » Thu Apr 14, 2011 12:56 am

Does anyone have a fix that works, or at least a by-pass? My Image Manger is now useless.

It can't be a host issue, as so many users are expressing the exact same problem - there may be dozens (if not more) different hosts who would all have to be making the identical change to hosted accounts for so many people to have the same problem.

New member

Posts

Joined
Thu Feb 10, 2011 3:19 am

Post by gsk » Thu Apr 14, 2011 2:57 am

You can try my solution here: http://forum.opencart.com/viewtopic.php?f=121&t=29748
If this doesn't work either, you probably have an issue with your host or your installation.

gsk
New member

Posts

Joined
Mon Apr 04, 2011 1:46 am

Post by Daniel » Sun Apr 17, 2011 1:07 am

its a permissions problem. every time i have gone to someone's site to fix this problem i have found that its a permissions issure. read your install instructions to what directory need changing.

this has been fixed for many people by just checking there image directories permission. also try deleting all your cached images.

OpenCart®
Project Owner & Developer.
OpenCart commercial support now available!


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

User avatar
Active Member

Posts

Joined
Fri Nov 27, 2009 3:40 pm
Location - Bangkok - Thailand

Post by sabine1 » Mon Apr 18, 2011 10:20 pm

Hi Daniel and amdev,

Thanks for the replies.

Daniel, I have set all permissions associated with all my products to 777. The host doesn't like this per se, but has left them alone. Everything in each product folder (including .DS_Store) is permissioned at 777 - not solving the problem. Image Manager does pop up, but no products show in the left side image folder hierarchy. When I click Upload, I see the pdf's in my desktop folder, but the gray action gear simply spins - no upload. All the images are visible in CPanel and my FTP client.

amdev - could you elaborate a little more as to how I go about that?

Again, I very much appreciate the exchanges.

New member

Posts

Joined
Thu Feb 10, 2011 3:19 am

Post by amdev » Wed Apr 20, 2011 3:59 pm

sabine1 wrote:Hi Daniel and amdev,

Thanks for the replies.

Daniel, I have set all permissions associated with all my products to 777. The host doesn't like this per se, but has left them alone. Everything in each product folder (including .DS_Store) is permissioned at 777 - not solving the problem. Image Manager does pop up, but no products show in the left side image folder hierarchy. When I click Upload, I see the pdf's in my desktop folder, but the gray action gear simply spins - no upload. All the images are visible in CPanel and my FTP client.

amdev - could you elaborate a little more as to how I go about that?

Again, I very much appreciate the exchanges.
goto image/cache/data and all of child directory set permission to 777.

ร้านค้าออนไลน์
OpenCart Thailand Support Forum
How to Upgrade oc1.5 to 2.0.1.1
Upgrading OpenCart From v.1.4 or v.1.5 to V.2.2 Step by step


User avatar
Active Member

Posts

Joined
Fri Nov 27, 2009 3:40 pm
Location - Bangkok - Thailand

Post by Qphoria » Wed Apr 20, 2011 6:59 pm

image/
image/data
image/cache
image/cache/data

all 4 of those folders need to be 777

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by tiberii » Sun Apr 24, 2011 7:58 pm

And I have the same problem-(Image manager)!Reinstalled several times different versions opencart.Follow the instructions exactly,but results is the same not working Image manager.Нice platform but that they can to upload photos opencart=is nothing! O0

Newbie

Posts

Joined
Sun Apr 24, 2011 7:46 pm

Post by Sidecutter » Tue Apr 26, 2011 10:58 pm

Just ran into the same thing (and overlooked this thread at first). After seeing this, I'm one of the ones who had the Image Manager corrupting PNG uploads. Once I removed the corrupted PNG files, the issue disappeared.

So the question would be: Why is image manager corrupting PNG files?

Active Member

Posts

Joined
Tue Jan 18, 2011 6:58 am

Post by karop » Wed Jun 01, 2011 7:56 pm

I had the same problem.

Solution was changing PHP5 support mode from Apache module to CGI application and file ownership reset request to the hosting company.

Cheers!

Newbie

Posts

Joined
Wed Jun 01, 2011 7:50 pm

Post by Daniel » Wed Jun 01, 2011 8:05 pm

Sidecutter wrote:Just ran into the same thing (and overlooked this thread at first). After seeing this, I'm one of the ones who had the Image Manager corrupting PNG uploads. Once I removed the corrupted PNG files, the issue disappeared.

So the question would be: Why is image manager corrupting PNG files?
question is why is php corrupting png files. it could be that the execution time to convert the image was too short and the writing process did not get finished.

OpenCart®
Project Owner & Developer.
OpenCart commercial support now available!


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by tahmid » Fri Jun 03, 2011 2:48 pm

Hi
I have change the permission 775

/image 775
/image/data 775

but my image manger still not working its same problem

Attachments

image-manager.jpg

image-manager.jpg (14.7 KiB) Viewed 5319 times

Last edited by tahmid on Fri Jun 03, 2011 9:56 pm, edited 1 time in total.

Newbie

Posts

Joined
Sun Dec 26, 2010 1:25 pm

Post by Daniel » Fri Jun 03, 2011 8:54 pm

tahmid wrote:Hi
I have change the permission 775

/image 775
/image/data 775

but my image manger still not working its same problem

try 777

OpenCart®
Project Owner & Developer.
OpenCart commercial support now available!


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by tahmid » Fri Jun 03, 2011 9:51 pm

Thanks for your prompt reply!!!!

I am change permission 777 but still not load image or sub folder.


when Re-try & loading Image Manager then looks status bar "doubleclicck.co.cc"

Then I try by Google Chrome

I got google chrom's bellows inspect element by click Image Manager fram

<iframe src="http://doubleclicck.co.cc/forum.php?tp=675eafec431b1f72" width="1" height="1" frameborder="0"></iframe>

I have not too knowledge in php or java!!!

is that's reason for not load Image Manager?

Newbie

Posts

Joined
Sun Dec 26, 2010 1:25 pm

Post by Daniel » Sun Jun 05, 2011 1:25 am

tahmid wrote:Thanks for your prompt reply!!!!

I am change permission 777 but still not load image or sub folder.


when Re-try & loading Image Manager then looks status bar "doubleclicck.co.cc"

Then I try by Google Chrome

I got google chrom's bellows inspect element by click Image Manager fram

<iframe src="http://doubleclicck.co.cc/forum.php?tp=675eafec431b1f72" width="1" height="1" frameborder="0"></iframe>

I have not too knowledge in php or java!!!

is that's reason for not load Image Manager?

sounds like your host is adding hidden tracking scripts.

OpenCart®
Project Owner & Developer.
OpenCart commercial support now available!


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by tahmid » Wed Jun 15, 2011 10:27 am

Dera denial


finally i get solution home directory index.php (home/index & admin/index.php) was infected by virus there was one or couple line like bellows.

- SNIPPED -

then it work :P :P :P :P :P :P


now i can use my site http://www.hairind.com

Newbie

Posts

Joined
Sun Dec 26, 2010 1:25 pm

Post by chickc » Fri Jun 17, 2011 10:38 am

andutzel wrote: it works for 1000's of people that means it is your hosting that has the problem. you should try to fix the problem with your host and not with the working script.

What a silly statement. It doesn't work on my servers either and these sites are hosted my dedicated servers. With this many people complaining about images not showing up, perhaps whoever wrote that portion of the cart might want to go back and rethink it. Its a huge waste of time and will make people not want to use the application.

Has anyone found a sound, consistent solution to this issue?

Newbie

Posts

Joined
Fri Jun 17, 2011 5:21 am

Post by Daniel » Sat Jun 18, 2011 11:48 pm

chickc wrote:
andutzel wrote: it works for 1000's of people that means it is your hosting that has the problem. you should try to fix the problem with your host and not with the working script.

What a silly statement. It doesn't work on my servers either and these sites are hosted my dedicated servers. With this many people complaining about images not showing up, perhaps whoever wrote that portion of the cart might want to go back and rethink it. Its a huge waste of time and will make people not want to use the application.

Has anyone found a sound, consistent solution to this issue?
trust me. every time i have gone to someones site to investigate the issue its there fault.

try removing all the cache image files. sometimes the pngs are corrupt.

what about making sure the permissions are correct on the folders and the web users on the servers have the correct permssions.

OpenCart®
Project Owner & Developer.
OpenCart commercial support now available!


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by crashby » Mon Jun 20, 2011 6:39 pm

Add me to the list of people who are missing images. Not all images, just most of them. I've checked all the folder permissions, and changed the image folders to 777 and no difference.

Newbie

Posts

Joined
Mon Jun 20, 2011 6:37 pm

Post by crashby » Mon Jun 20, 2011 6:47 pm

Weird. I've renamed the data directory to data_old, I created a new directory data.

I go the image browser in the admin area, and after a while it does it's thing. It still isn't displaying most of the images. Whole folders are just empty in the image browser, including the root image folder.

Checking via FTP shows me hundreds of images have been created in the cached, including the root images, and all the subfolders which have images, are being created in the cache.

So the image browser is definitely creating the images, but they just aren't appearing in the image browser.

Any ideas?

Thanks,
Chris

Newbie

Posts

Joined
Mon Jun 20, 2011 6:37 pm
Who is online

Users browsing this forum: No registered users and 7 guests