Post by Milord98735 » Wed Jan 09, 2019 10:21 pm

Hello,

I have a problem when I create a product, it appears in the shop but can not edit to edit the description or add an image.
By clicking EDIT, I have a blank page instead of the product page.
In the System / Error Logs tab, I have this:

Code: Select all

 2019-01-09 8:14:32 - PHP Warning:  mysqli::query(): (21000/1242): Subquery returns more than 1 row in /home/XXXX/XXXX/htdocs/system/database/mysqli.php on line 17 
Is this the cause?
Thank you for your help.
Last edited by Milord98735 on Fri Jan 18, 2019 12:53 am, edited 1 time in total.

Opencart V.1.5.6.4 - Theme Journal


User avatar
Newbie

Posts

Joined
Sun Dec 23, 2018 2:19 pm

Post by Milord98735 » Thu Jan 10, 2019 3:20 am

Hello,
this is where the error should be if I understood correctly :
Image

Opencart V.1.5.6.4 - Theme Journal


User avatar
Newbie

Posts

Joined
Sun Dec 23, 2018 2:19 pm

Post by ADD Creative » Thu Jan 10, 2019 8:18 pm

The issue is often caused by a duplicate entry in the database. Are there any other error messages that may be related? If not it's often the url_alias table having two entries for one product.

The duplicate entry is usually caused by a modification or extension.

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by Milord98735 » Fri Jan 11, 2019 2:43 pm

Thank you for the answer, I will see at the level of extensions.
Regards,

Opencart V.1.5.6.4 - Theme Journal


User avatar
Newbie

Posts

Joined
Sun Dec 23, 2018 2:19 pm

Post by Milord98735 » Fri Jan 11, 2019 3:44 pm

I can not find what is causing this error.
I removed the item and put it back again. impossible to rewrite. And this is true for most of the latest product additions.

Opencart V.1.5.6.4 - Theme Journal


User avatar
Newbie

Posts

Joined
Sun Dec 23, 2018 2:19 pm

Post by ADD Creative » Fri Jan 11, 2019 11:40 pm

Did you look in the url_alias table in your database for any duplicates using the same product_id?

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by Milord98735 » Sat Jan 12, 2019 8:50 pm

hi,

everything seems normal ; no duplicate !

Opencart V.1.5.6.4 - Theme Journal


User avatar
Newbie

Posts

Joined
Sun Dec 23, 2018 2:19 pm

Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by Milord98735 » Sun Jan 13, 2019 2:57 am

Thank you for your help, I will see the side of the theme, there must be a conflict with the example product links.

Opencart V.1.5.6.4 - Theme Journal


User avatar
Newbie

Posts

Joined
Sun Dec 23, 2018 2:19 pm

Post by Milord98735 » Fri Jan 18, 2019 12:52 am

[CLOSED]

Opencart V.1.5.6.4 - Theme Journal


User avatar
Newbie

Posts

Joined
Sun Dec 23, 2018 2:19 pm
Who is online

Users browsing this forum: No registered users and 14 guests