Post by OC2PS » Wed Oct 09, 2013 4:25 pm

Ensure your image files don't have any spaces in their names.

In fact, go through the Photos not appearing in emails? list in the OP.

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by xxvirusxx » Wed Oct 09, 2013 10:36 pm

I just insert test produtcs, with image test1.jpg,test2.jpg,test3.jpg directly in image/data, without category folder.

Now in email duplicate product image for 3 times.
The same in both email owner and customer.

Image

I will install 1.5.5.1 in another folder and i will testing.
Last edited by xxvirusxx on Wed Oct 09, 2013 10:43 pm, edited 1 time in total.

Free converted extensions


Active Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm

Post by OC2PS » Wed Oct 09, 2013 10:42 pm

Time for a link to your shop. If you don't want to post in public, then PM it to me.

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by dr770 » Tue Nov 05, 2013 10:31 pm

Ensure your image files don't have any spaces in their names.
Hi, is there really no way to remove this limitation? my client has uploaded tenth of pictures with spaces...
but thanks alot for the free extension!

New member

Posts

Joined
Mon Oct 15, 2007 1:53 am

Post by OC2PS » Tue Nov 05, 2013 10:42 pm

dr770 wrote:
Ensure your image files don't have any spaces in their names.
Hi, is there really no way to remove this limitation?
Unfortunately, not as this is more of a server and email client issue - completely outside the control of the extension...

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by IP_CAM » Tue Jun 17, 2014 7:58 am

Great Mod, thank you ! Worked perfect on spot !
The ideal way to present nice professional HTML e-Mails.

Ernie

OpenShop v.1.7 (OC v.1.5.6.1-4)

Image
Last edited by IP_CAM on Tue Jun 17, 2014 8:29 am, edited 1 time in total.

For Sale: Top URL's, including an OpenCart V-Pro Shop!
A wide range of matching Designs can be seen here: http://www.opencart.li
For Information on URL's offered, please contact me at: jti@jacob.ch
Hundreds of Mods in 380+ Repositories for OC v.1.5.x - v.2.3.x
to be found on my Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by IP_CAM » Tue Jun 17, 2014 8:17 am

Modify Line 8 of the XML, to align Product Name to the image vertical middle:
>>>>><img style="vertical-align:middle;" src=<<<<<

Code: Select all

<a href="<?php echo $product['href']; ?>"><img style="vertical-align:middle;" src="<?php echo $product['thumb']; ?>" 
looks better...

Ernie

Image

For Sale: Top URL's, including an OpenCart V-Pro Shop!
A wide range of matching Designs can be seen here: http://www.opencart.li
For Information on URL's offered, please contact me at: jti@jacob.ch
Hundreds of Mods in 380+ Repositories for OC v.1.5.x - v.2.3.x
to be found on my Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by IP_CAM » Tue Jun 17, 2014 8:35 am

dr770 wrote:
Ensure your image files don't have any spaces in their names.
Hi, is there really no way to remove this limitation? my client has uploaded tenth of pictures with spaces...
but thanks alot for the free extension!
Spaces in File Names are a NO-GO on a Website.. but take it or leave it...

Ernie

For Sale: Top URL's, including an OpenCart V-Pro Shop!
A wide range of matching Designs can be seen here: http://www.opencart.li
For Information on URL's offered, please contact me at: jti@jacob.ch
Hundreds of Mods in 380+ Repositories for OC v.1.5.x - v.2.3.x
to be found on my Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by straightlight » Thu Jun 26, 2014 1:11 am

IP_CAM wrote:
dr770 wrote:
Ensure your image files don't have any spaces in their names.
Hi, is there really no way to remove this limitation? my client has uploaded tenth of pictures with spaces...
but thanks alot for the free extension!
Spaces in File Names are a NO-GO on a Website.. but take it or leave it...

Ernie
Correct. Common names should be used with underscores whenever using separated words on a file name.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by YDA » Fri Jul 11, 2014 1:24 am

Hi,
I am using 1.5.5.1 and as I activate https in BO the products pictures does not show anymore on emails.
I modified the config.php file in boths admin and FO and it does not work either.
I deactivate the https in the admin and the emails went fine with pictures.
Can you help me solve this trouble
Have a nice day
Yan

Opencart 1.5.5.1
Linux and Windows Seven
Dedicated Servers 1&1


User avatar
YDA
Newbie

Posts

Joined
Tue Jul 08, 2014 10:40 pm

Post by OC2PS » Tue Jul 15, 2014 1:33 am

IP_CAM wrote:Modify Line 8 of the XML, to align Product Name to the image vertical middle
Ernie,

Thanks for the tip and for helping out with answers!

I guess alignment is a matter of taste - we prefer the text to be on top :-)

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by OC2PS » Tue Jul 15, 2014 1:34 am

YDA wrote:I am using 1.5.5.1 and as I activate https in BO the products pictures does not show anymore on emails.
I modified the config.php file in boths admin and FO and it does not work either.
I deactivate the https in the admin and the emails went fine with pictures.
Yan,

I'll try to replicate and resolve this week, though with the current workload, it's hard to promise anything.

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by YDA » Wed Jul 23, 2014 6:54 pm

HI
Thank you for helping as I cannot solve this https bug with this extension
Thank you
Yan

Opencart 1.5.5.1
Linux and Windows Seven
Dedicated Servers 1&1


User avatar
YDA
Newbie

Posts

Joined
Tue Jul 08, 2014 10:40 pm

Post by aviatel » Sun Mar 01, 2015 4:30 pm

working in OC 2.0.1.1 ?

New member

Posts

Joined
Sun Feb 10, 2013 4:15 pm

Post by OC2PS » Sun Mar 01, 2015 5:40 pm

aviatel wrote:working in OC 2.0.1.1 ?
Probably not. I am trying to see if Daniel/ James would include this in the core. Submitted a patch https://github.com/opencart/opencart/pull/2705 Waiting for their feedback.

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by aviatel » Sun Mar 01, 2015 5:44 pm

Thanks!

New member

Posts

Joined
Sun Feb 10, 2013 4:15 pm

Post by YDA » Fri Apr 24, 2015 9:25 pm

HI OC22PS,
Did you remember my last year question relating to https trouble receiving orders emails not showing pictures
You told me you will try to solve it!!
Have you got time to do so??
Many thanks for your reply
Yan

Opencart 1.5.5.1
Linux and Windows Seven
Dedicated Servers 1&1


User avatar
YDA
Newbie

Posts

Joined
Tue Jul 08, 2014 10:40 pm

Post by IP_CAM » Sat Apr 25, 2015 1:54 am

dr770 wrote:
Ensure your image files don't have any spaces in their names.
Hi, is there really no way to remove this limitation? my client has uploaded tenth of pictures with spaces...
but thanks alot for the free extension!
Onby, since this is still of interest, a few Links, related to the quoted content:

https://www.google.ch/search?q=Frontend ... s+opencart
http://www.opencart60s.com/opencart/fro ... 35569.html
http://www.opencart.com/index.php?route ... n_id=14343
http://www.bulkrenameutility.co.uk/Main_Intro.php
http://www.advancedrenamer.com/

Greetings!
Ernie

For Sale: Top URL's, including an OpenCart V-Pro Shop!
A wide range of matching Designs can be seen here: http://www.opencart.li
For Information on URL's offered, please contact me at: jti@jacob.ch
Hundreds of Mods in 380+ Repositories for OC v.1.5.x - v.2.3.x
to be found on my Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by OC2PS » Sat Apr 25, 2015 2:23 am

YDA wrote: https trouble receiving orders emails not showing pictures
I think the aforementioned patch resolves the issue. If it is included in OpenCart core, you will not face the issue again.

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by rakshadolphin » Thu Jul 23, 2015 12:29 pm

Do the product image and product name in the email have url which will take you to the products on the website?
I need the url on the image which will take the user to the product details on the website. Please suggest

Newbie

Posts

Joined
Sun May 19, 2013 6:18 pm
Who is online

Users browsing this forum: No registered users and 8 guests