Post by OC2PS » Fri Aug 16, 2013 6:18 pm

dansk wrote:Same problem here.
Busy at the moment. Let me have a look during the weekend.

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by ibietela » Sat Aug 24, 2013 1:24 pm

Thank you for this module... I am using version 1.5.6 don't know if it will work out. I used a premium theme

New member

Posts

Joined
Fri Nov 09, 2012 12:39 am

Post by OC2PS » Sat Aug 24, 2013 4:22 pm

ibietela wrote:I am using version 1.5.6
The module works with OC 1.5.6 no problem.
ibietela wrote:I use a premium theme
Ah, then it's a bit of a hit or miss. If it works, great. If it doesn't, you need to get custom development done to adapt it for your theme. If you'd like me to do the custom development, PM me.
OC2PS wrote: Is it working?
After installing, you can check that it;s working by providing a product page URL at http://www.google.com/webmasters/tools/richsnippets
When checking your product page at the above tool, remember:
  1. You will see stars only if the product page you are testing has reviews.
  2. Scroll down and see the whole page. The relevant stuff is under the headings "Google search preview" and "Extracted rich snippet data from the page"
  3. Under the heading "Extracted Author/Publisher for this page", you will see "Page does not contain authorship markup. Learn more." Do not panic! This is normal. Product and Review pages are not supposed to have authorship markup. Authorship markup is related more to blog posts and articles and requires integration with Google+ accounts...an entirely different beast from what we are trying to do at OpenCart
Image

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by samaraki » Mon Sep 09, 2013 3:38 am

I couldn't get this to work with my theme...

New member

Posts

Joined
Fri Jul 26, 2013 2:36 pm

Post by OC2PS » Mon Sep 09, 2013 4:23 pm

samaraki wrote:I couldn't get this to work with my theme...
Then you need to hire someone to customize it for your theme.

If you want me to do it, PM me.

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by Nawid » Fri Sep 13, 2013 10:27 pm

Dear sir,

I've succesfully installed this on our site, but when I open a product, the table "description" and "reviews" and "related" are suddenly moved to right. I mean like the whole table, as soon as I delete "z-google-rich-snippets-2.xml" from "vqmod/xml" it's ok again.

Please see attached image for reference.

What's wrong with that? EDIT: I'm using OC 1.5.6

Attachments

error.jpg

when I open a product, the table "description" and "reviews" and "related" are suddenly moved to right - error.jpg (56.74 KiB) Viewed 7936 times


User avatar
New member

Posts

Joined
Fri Aug 19, 2011 6:47 am

Post by OC2PS » Sat Sep 14, 2013 2:03 am

Nawid wrote:when I open a product, the table "description" and "reviews" and "related" are suddenly moved to right
Sorry for your trouble and thanks for the screenshot.

Unfortunately, I am unable to confirm or diagnose the issue at the moment as we are busy moving servers. Will try to have a look on Tue/Wed. Thanks for your patience.

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by deon_12 » Tue Sep 17, 2013 5:02 pm

Hi,

I've installed the module, but when I test it on google tool, it doesn't display rich snippet information (i.e. price, availability, star review).
My configuration as follow:
- Opencart 1.5.5.1
- VQmod 2.4.1
- Default theme
- Extension: Google Rich Snippets 1.9.7
- Testing URL: http://www.galerimedika.com/Timbangan-B ... mry-EB9003

Does the module doesn't support VQmod 2.4.1?

I try another extension SEO Sniper, the rich snippet information is displayed, but it cannot display Special Price.
I interested to install your module, as the module can display either 'Special Price' or 'Price' depends on the product configuration.

Newbie

Posts

Joined
Tue Sep 17, 2013 4:55 pm

Post by OC2PS » Tue Sep 17, 2013 9:29 pm

deon_12 wrote:Does the module doesn't support VQmod 2.4.1?
Module supports vqmod 2.4.1 and is adding markup to your page just fine.

The problem is
Google Rich Snippets Tool wrote:Error: This information will not appear as a rich snippet in search results, because it is contained in a hidden HTML element. Except in special circumstances, Google won't display content that is not visible to the user. You should mark up the text that actually appears to your users when they visit your web pages.
You have some hidden markup on the page and Google doesn't like elements that normal visitors can't see. Remove your hidden markup and you'll be fine.

(this module does not add any hidden markup on your page)

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by Nawid » Fri Sep 20, 2013 9:57 pm

OC2PS wrote:
Nawid wrote:when I open a product, the table "description" and "reviews" and "related" are suddenly moved to right
Sorry for your trouble and thanks for the screenshot.

Unfortunately, I am unable to confirm or diagnose the issue at the moment as we are busy moving servers. Will try to have a look on Tue/Wed. Thanks for your patience.
Dear sir, have you been able to look for the problem?

Best regards,
Nawid

User avatar
New member

Posts

Joined
Fri Aug 19, 2011 6:47 am

Post by deon_12 » Mon Sep 23, 2013 9:51 pm

Hi,

Thanks for your very clear explation. I've found the module that caused this hidden markup, and remove it. Now the rich snippet works fine. Thanks again :)

Regards,
deon_12
OC2PS wrote:
deon_12 wrote:Does the module doesn't support VQmod 2.4.1?
Module supports vqmod 2.4.1 and is adding markup to your page just fine.

The problem is
Google Rich Snippets Tool wrote:Error: This information will not appear as a rich snippet in search results, because it is contained in a hidden HTML element. Except in special circumstances, Google won't display content that is not visible to the user. You should mark up the text that actually appears to your users when they visit your web pages.
You have some hidden markup on the page and Google doesn't like elements that normal visitors can't see. Remove your hidden markup and you'll be fine.

(this module does not add any hidden markup on your page)

Newbie

Posts

Joined
Tue Sep 17, 2013 4:55 pm

Post by wal_j » Mon Oct 07, 2013 12:21 am

Nawid wrote:Dear sir,

I've succesfully installed this on our site, but when I open a product, the table "description" and "reviews" and "related" are suddenly moved to right. I mean like the whole table, as soon as I delete "z-google-rich-snippets-2.xml" from "vqmod/xml" it's ok again.

Please see attached image for reference.

What's wrong with that? EDIT: I'm using OC 1.5.6
I believe that for OC Ver 1.5.6 there is a layout change for the product.tpl. and therefore one search tag needs updating.
in z-google-rich-snippets-2.xml
Change search from

Code: Select all

<?php if ($options) { ?>
to

Code: Select all

<?php if ($profiles): ?>
That should help your layout issue!

New member

Posts

Joined
Tue May 12, 2009 11:51 pm

Post by OC2PS » Thu Oct 17, 2013 10:37 pm

Nawid wrote:Dear sir, have you been able to look for the problem?
wal_j is correct. This has been fixed in latest version 1.9.8. Please download and install the latest version.

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by gerritkoi » Tue Oct 22, 2013 2:16 am

Google Rich Snippets does not work with shoppica1 theme no error messages

testing site http://www.product-veilingen.eu/
any idea how to fix this

gr gerrit

http://www.koicentrum.eu Alles voor Koi en Vijver, Opencart 1.5.4 Vqmod 2.4.1


New member

Posts

Joined
Wed Jun 05, 2013 2:16 am

Post by OC2PS » Tue Oct 22, 2013 3:00 am

gerritkoi wrote:not work with shoppica1
Shoppica 2 version of extension is at http://www.opencart.com/index.php?route ... on_id=7140
Sorry, there is no Shoppica 1 version. No plan for one either.

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by pikapika » Tue Nov 05, 2013 7:15 am

Thank you for sharing this vqmod.
My product title doesn't include the brand name and the brand name is actually stored and shown under manufacturer.
Is there anyway to capture the brand as well as the product title?

Thank you for your help!

http://www.lunatu.com
Japanese and Korean Make up store in the UK
Worldwide Fast Shipping


Newbie

Posts

Joined
Tue Nov 05, 2013 7:13 am

Post by OC2PS » Wed Nov 06, 2013 3:36 pm

pikapika wrote:brand name is actually stored and shown under manufacturer.
Is there anyway to capture the brand as well as the product title?
I take it that you want Google to see product name as a combination of brand name and product name. If so, you should add brand name to the product name...Google really doesn't like trickery...
That being said, if your problem is not that you dont want to include brand name in the title and product name, but merely that you already have lots of products and dont want to change them all manually, then yeah, I could write a small extension for you. PM me if interested.

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by Nawid » Sat Nov 09, 2013 10:12 pm

wal_j wrote: I believe that for OC Ver 1.5.6 there is a layout change for the product.tpl. and therefore one search tag needs updating.
in z-google-rich-snippets-2.xml
Change search from

Code: Select all

<?php if ($options) { ?>
to

Code: Select all

<?php if ($profiles): ?>
That should help your layout issue!
Thank you!
OC2PS wrote:
Nawid wrote:Dear sir, have you been able to look for the problem?
wal_j is correct. This has been fixed in latest version 1.9.8. Please download and install the latest version.
Excellent, it's working perfect now.
Thank you all for your great time and effort.

User avatar
New member

Posts

Joined
Fri Aug 19, 2011 6:47 am

Post by stokeyblokey » Wed Nov 13, 2013 2:27 am

Thank you for this extension OC2PS, once I had actually read the instructions properly it was simple to install and get working.

€5 donated - grab a coffee or beer on me ;D

Stokey


User avatar
Active Member

Posts

Joined
Sat Aug 31, 2013 10:19 pm

Post by OC2PS » Thu Nov 14, 2013 10:21 am

I appreciate it. Cheers!

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary
Who is online

Users browsing this forum: No registered users and 5 guests