Post by cdamianou » Fri Feb 02, 2018 3:06 am

Hi

I was wondering if someone can help. I cannot figure this out.

I have updated VQmod to v2.6.3-opencart. I followed all the instructions and now get the following error.

Fatal error: Cannot instantiate abstract class VQMod in /home/XXXX/public_html/vqmod/vqcache/vq2-system_engine_loader.php on line 8

My index.phi has the following
// VirtualQMOD
require_once('./vqmod/vqmod.php');
VQMod::bootup();

// VQMODDED Startup
require_once(VQMod::modCheck(DIR_SYSTEM . 'startup.php'));

I am pulling my hair out and not sure what else to try.

Thanks for your help

http://www.magictao.co.uk


Active Member

Posts

Joined
Tue Aug 09, 2011 2:13 pm

Post by straightlight » Fri Feb 02, 2018 6:52 am

DOM corruption on the index.php file. Re-upload your index.php and admin/index.php file from the original OC ZIP file downloaded from opencart.com and manually add those VQMod lines with a compatible text editor as well as re-uploading both files in UTF-8 encoding mode.

Do the same by re-uploading the VQMod ZIP file but with your host file manager console then use the extract function.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by cdamianou » Sat Feb 03, 2018 3:23 pm

Hi Straightlight

Thank you for your reply. I have tried following your instruction. Now i am getting what I got before I tried to upload an updated vqmod and that is a blank page for both the front page and admin.

There was an issue with the server and now I cannot seem to sort this out.

Your help is very much appreciated. Do you have any other suggestions?

After writing the above I re downloaded Opencart 1.5.6, uploaded the index files, re installed vqmod and still get

Fatal error: Cannot instantiate abstract class VQMod in /home/xxxxx/public_html/vqmod/vqcache/vq2-system_engine_loader.php on line 8

http://www.magictao.co.uk


Active Member

Posts

Joined
Tue Aug 09, 2011 2:13 pm

Post by straightlight » Sat Feb 03, 2018 10:58 pm

If you did uploaded the vqmod folder by using your host's file manager console and installed manually over index.php and admin/index.php file, since you are using an old version of Opencart, try with a recent version and see if this issue persists. If so, contact your host.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by IP_CAM » Sun Feb 04, 2018 3:13 am

Well, instead of installing another OC Version, just to find out, if something still works, :crazy:
you better just upload a your Version virgin OC ROOT/index.php and ADMIN/index.php
file, and then, upload and install a VqMod Version 2.6.1 the regular way again. It should then work,
and it makes no sense anyway, to install a later VqMod Version into your OC 1.5.x.
Ernie

For Sale: Top URL's, including OpenCart V-Pro installed, like seen here:
http://www.bigmax.ch - http://www.ipcam.li - http://www.opencart.li
For Information + URL's offered, please contact me at: jti@jacob.ch
I am NOT available for Custom Support in existing OC Installations!
My Github Repositories: https://github.com/IP-CAM
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by straightlight » Sun Feb 04, 2018 5:13 am

Why the hell beyond earth or any planets around would someone want to fallback with Opencart to also fallback on VQMod installations while the other way around could be done by simply trying with newer versions? !

Upgrading is the point of evolving with technology and being compliant with the Industry. VQMod, as being part of using PHP as well, is no exception.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by IP_CAM » Sun Feb 04, 2018 2:54 pm

Well, OC v.1.5.6.x don't use OcMod + VqMod, among other things, possibly requiring
more intelligent VqMod Engines, partly in order, to manage the two step-sisters, to so get
along as smooth and efficient as possible.

But VqMod 2.6.1 workes perfect with 1.5.6.x, and only a fool changes perfect working tools,
without a very good reason. To run a successful shop is also not, to always jump onto the latest
Code Releases. Especially under the aspect, that most Things, newly offered around OC,
have rarely been tested with the uncounted masses of different setups, as one can easy find out,
when reading many of the topics in this place.

But there is a still 'better' solution, at best after one has finished testing things in v.1.5.6.x,
since it frequently hinders DEV-Changes to immediately function, due to it's automatic Caching Design.
it's called VqMod Pro, and it really still adds some spice to the meat, among improving
some tasks, speed, and routines in a fully automatic way, in the admin section as well as the front.
It was in the Ext.Section for a while, but was then removed, and famous MaxD decided to concentrate
on more important things, instead of frequently beeing under fire, for free, and no good reason at all...

https://opencartforum.com/files/file/30 ... stabilnyy/
https://translate.google.com/translate? ... t=&act=url

But I am not a Pro, just a Tester and Knowledge-Collector, and I take and use, what I found out in about 10K+
hours of building, editing, and testing, to best match my needs and knowledge. And share some with others,
regardless of the Version used. This should not be so hard to understand.
It's not about Versions, it's all about Facts. Like those:
https://github.com/opencart/opencart/pull/6386
Ernie

For Sale: Top URL's, including OpenCart V-Pro installed, like seen here:
http://www.bigmax.ch - http://www.ipcam.li - http://www.opencart.li
For Information + URL's offered, please contact me at: jti@jacob.ch
I am NOT available for Custom Support in existing OC Installations!
My Github Repositories: https://github.com/IP-CAM
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: No registered users and 7 guests