Post by combusus » Mon Oct 01, 2012 2:32 pm

Hi bull5-i, this extension has been working great but found out it conflicts with Tcalp's extensions:
http://www.opencart.com/index.php?route ... on_id=6226


Specifically:
category_custom_page_footing.xml
category_custom_page_heading.xml
category_custom_page_title.xml
category_custom_slogan.xml

The above extensions fowl up the image captions and throws errors when saving a product, the errors are:
Notice: Undefined index: alt_text in /home/path/public_html/vqmod/vqcache/vq2-admin_model_catalog_product.php on line 184Notice: Undefined index: title_text in /home/path/public_html/vqmod/vqcache/vq2-admin_model_catalog_product.php on line 184Notice: Undefined index: language in /home/path/public_html/vqmod/vqcache/vq2-admin_model_catalog_product.php on line 267Warning: Invalid argument supplied for foreach() in /home/path/public_html/vqmod/vqcache/vq2-admin_model_catalog_product.php on line 267

It appears the alt_text is causing problems here. Is it possible to figure this out?
Last edited by combusus on Mon Oct 01, 2012 10:22 pm, edited 1 time in total.

User avatar
Newbie

Posts

Joined
Mon Feb 21, 2011 7:31 am

Post by bull5-i » Mon Oct 01, 2012 2:41 pm

You cannot link to extensions from your downloads section (the ones you have purchased), you need to give the extension's public link.

I could provide a paid customization service for resolving this issue as it is a conflict with a third party extension. PM me if you are interested.

|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm

Post by combusus » Mon Oct 01, 2012 10:24 pm

opps I didn't even realize the incorrect link, fixed. If I can't poke around and fix it myself I'll pay for your services, Thanks

User avatar
Newbie

Posts

Joined
Mon Feb 21, 2011 7:31 am

Post by rwalker » Sun Dec 09, 2012 2:51 am

Hi,

Do you know if this is compatible with cloud-zoom?

I couldn't seem to find info on it.

Thank you.

Discount Golf Clubs and Golf Equipment - Powered by Opencart


New member

Posts

Joined
Fri Jul 01, 2011 8:14 am

Post by bull5-i » Sun Dec 09, 2012 5:54 pm

The cloud-zoom implementations that I have seen so far cannot display image titles, because they just do not make use of the title tags. Currently it is the cloud-zoom limitation. If it made use of the title tags, then it could be supported.

|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm

Post by cj2070 » Sat Feb 02, 2013 5:20 am

I need some help with this extension , how can I get a hold of you by email ? Thank you

Newbie

Posts

Joined
Sat Feb 02, 2013 5:18 am

Post by bull5-i » Sat Feb 02, 2013 11:15 pm

You will find my contact email from the extension settings page under the About tab.

|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm

Post by Cleo » Sat May 25, 2013 1:13 pm

Hello

I have oc multistore and multilanguage with a custom theme which has a zoom in feature and a scroll feature for the pictures so I would like to know if you think that your module could work for me?

tks
Cleo
www.lesbricollesdecleo.com

My Store
Opencart v1.5.4 fr/en
Theme: Custom
vqmod-2.3.2


User avatar
Active Member

Posts

Joined
Wed Mar 09, 2011 5:19 am

Post by bull5-i » Sun May 26, 2013 4:30 pm

The extension will work with multilingual multistore installation. The extension can be customized to include the custom titles for the product pictures. The PrettyPhoto full sized image viewer can display custom titles, but I am not sure whether the scroll and zoom feature can make use of the actual image title tags or not.

|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm

Post by Cleo » Sun May 26, 2013 4:50 pm

Thank you for the reply

Well if it work with full sized image viewer it's better then nothing and also with multi language, if it doesn't show for the zoom and scroll it's not a big deal :)

I will try it!

Regards
Cleo

My Store
Opencart v1.5.4 fr/en
Theme: Custom
vqmod-2.3.2


User avatar
Active Member

Posts

Joined
Wed Mar 09, 2011 5:19 am

Post by Cleo » Sun May 26, 2013 7:17 pm

Well it looks like it's not working for me :( Probably because of my theme and all the feature I have in it!

The titles are added in the db but they are not displaying in the store

I already have the image tag configure in my template but I wanted to use this module for custom title but...

I am getting this error

Code: Select all

---------- Date: 2013-05-26 09:50:55 ~ IP : 173.194.99.84 ----------
REQUEST URI : /index.php?route=feed/google_base
MOD DETAILS:
   modFile   : /home/*****/public_html/vqmod/xml/custom_image_titles.xml
   id        : Add custom titles and alternative messages for all product and category images together with image sort order
   version   : 2.4.3
   vqmver    : 2.1.7
   author    : rmg
SEARCH NOT FOUND (ABORTING MOD): 'product_id'       => $query->row['product_id']
Anyway I gave you a 5* rating because the module is very easy to install.

Regards
Cleo

My Store
Opencart v1.5.4 fr/en
Theme: Custom
vqmod-2.3.2


User avatar
Active Member

Posts

Joined
Wed Mar 09, 2011 5:19 am

Post by bull5-i » Sun May 26, 2013 7:56 pm

This error indicates that you either have a conflict with another installed vqmod, you have manually modified the catalog/model/catalog/product.php file or you are not using correct version of CIT for your OpenCart version.

If you are using the correct version then you need to adjust the vqmod script to reflect the actual content of the file. You could try to rename the vqmod script file such that it gets executed before all other vqmods by adding "!" in front of the filename.

|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm

Post by Cleo » Sun May 26, 2013 8:03 pm

Hello

Thank you for the reply! I will re-install it later and try it again!

I will let you know if it's working

Regards
Cleo

My Store
Opencart v1.5.4 fr/en
Theme: Custom
vqmod-2.3.2


User avatar
Active Member

Posts

Joined
Wed Mar 09, 2011 5:19 am

Post by Cleo » Sun May 26, 2013 8:32 pm

Hello

Well renaming the xml file didn't do the trick!
I get the same error

I know that my product and category files are different then the default one because I have all the feature in them, I didn't do that it's the creator of the theme who did it!

Well if I can fix it later or if I ever change my theme I will be able to use it! :)

Regards
Cleo

My Store
Opencart v1.5.4 fr/en
Theme: Custom
vqmod-2.3.2


User avatar
Active Member

Posts

Joined
Wed Mar 09, 2011 5:19 am

Post by Cleo » Mon Jul 29, 2013 3:19 pm

Hi just want to let you know that I finally been able to adapt the extension for my theme :)

You were almost right when you said:
you are not using correct version of CIT for your OpenCart version
I said almost because I compare all my files with the code in your xml file and found out that the developer I hired to upgrade my store from v.1.5.2.1 to v1.5.4 didn't upgraded all the files :(

So I uploaded the version for 1.5.2.1 and mixed it with the version for 1.5.4 since I have files from both version and changed/adapt the xml file to match my files and also removed the code for the first image because since I have the zoom and expendo feature the text was bigger then my picture :)

I didn't want to change the files that were from version 1.5.2.1 because I fixed all the problems I had with the store and now that everything is working properly I prefer to leave it the way it is.

So after a lot of work and trial everything seems to be working ok now! All the titles and alt are showing for the category pictures and the few products I tried are ok too!

I thought I should let you know about it.

Regards

Cleo the happy camper :)

My Store
Opencart v1.5.4 fr/en
Theme: Custom
vqmod-2.3.2


User avatar
Active Member

Posts

Joined
Wed Mar 09, 2011 5:19 am

Post by bull5-i » Mon Jul 29, 2013 3:55 pm

Great to hear that!

|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm

Post by tinabanana » Thu Jul 16, 2015 8:37 am

Hi, i installed this on version 2.0.2 and it installed fine on the admin side but its not working on my custom theme, zmaxcart.

IF you could just let me know what code i need to edit to make it work.

All i really need is to change the default caption for when the image is blown up with the custom text

<figcaption>
<div class="mfp-bottom-bar">
<div class="mfp-title">add custom text here</div>
<div class="mfp-counter">1 of 6</div></div>
</figcaption>

UPDATE
I got great support, it was already in the FAQ bu I missed it, all i had to do was edit the xml file and change 'default' to 'mytheme'

From the faq:

In order to integrate the Custom Image Titles extension with your custom theme you need to modify the vqmod/xml/custom_image_titles.xml file. Find the blocks that edit the default theme template files (near the end of the file) and change the theme name from 'default' to your custom theme (folder name).

If the titles do not appear after this change, then your custom theme template structure must differ in some way from the default theme. In this case you need to further tailor the vqmod search & replace/insert patterns for the template files to deal with the structural peculiarities of your custom theme.

As due to the very nature of a custom theme there does not exist a universal solution. A custom theme may have a different way of displaying things. Take a look at the changes made to the default theme and work out adjustments to the search & replace patterns to suit your theme.

If you do not know how the vqmod script works, I kindly suggest you read about it from the vqmod wiki pages. vQmod log files (vqmod/logs/*.log) are helpful for debugging. They will tell you where the script fails (meaning which vqmod search line it does not find in the referenced file), so you need to adjust that part of the script.

New member

Posts

Joined
Tue May 05, 2015 10:19 pm

Post by zastil » Fri Sep 30, 2016 9:12 pm

OpenCart 2.1.0.1

Get this error

Notice: Indirect modification of overloaded property ModelModuleCustomImageTitles::$alerts has no effect in /home/futureglass/futureglass.eu/admin/model/module/custom_image_titles.php on line 82Notice: Indirect modification of overloaded property ModelModuleCustomImageTitles::$alerts has no effect in /home/futureglass/futureglass.eu/admin/model/module/custom_image_titles.php on line 82Notice: Indirect modification of overloaded property ModelModuleCustomImageTitles::$alerts has no effect in /home/futureglass/futureglass.eu/admin/model/module/custom_image_titles.php on line 82

Newbie

Posts

Joined
Thu Jun 25, 2015 6:56 pm

Post by bull5-i » Sat Oct 01, 2016 12:50 am

Support is not available without a valid license.

|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm

Post by AliceH » Tue Jun 13, 2017 9:12 pm

I have installed this on 2.3 and I the image tags and alt tags are not displaying in the product in admin. Additionally I am getting this error when I try to save the product
Notice: Undefined index: descriptions in /home/*****/public_html/vqmod/vqcache/vq2-system_storage_modification_admin_model_catalog_product.php on line 455Warning: Invalid argument supplied for foreach() in /home/*****/public_html/vqmod/vqcache/vq2-system_storage_modification_admin_model_catalog_product.php on line 455Notice: Undefined index: descriptions in /home/*****/public_html/vqmod/vqcache/vq2-system_storage_modification_admin_model_catalog_product.php on line 455Warning: Invalid argument supplied for foreach() in /home/*****/public_html/vqmod/vqcache/vq2-system_storage_modification_admin_model_catalog_product.php on line 455Notice: Undefined index: descriptions in /home/*****/public_html/vqmod/vqcache/vq2-system_storage_modification_admin_model_catalog_product.php on line 455Warning: Invalid argument supplied for foreach() in /home/*****/public_html/vqmod/vqcache/vq2-system_storage_modification_admin_model_catalog_product.php on line 455Notice: Undefined index: descriptions in /home/*****/public_html/vqmod/vqcache/vq2-system_storage_modification_admin_model_catalog_product.php on line 455Warning: Invalid argument supplied for foreach() in /home/*****/public_html/vqmod/vqcache/vq2-system_storage_modification_admin_model_catalog_product.php on line 455Warning: Cannot modify header information - headers already sent by (output started at /home/*****/public_html/admin/controller/startup/error.php:34) in /home/*****/public_html/system/library/response.php on line 12

http://www.embroideryallsorts.com.au


User avatar
Active Member

Posts

Joined
Sun Jan 09, 2011 11:00 am
Location - Australia
Who is online

Users browsing this forum: No registered users and 8 guests