Post by bull5-i » Fri Nov 18, 2011 4:36 am

Fixed compatibility with Custom Product Tab (vQmod) - released bugfix version 2.1.2 for this

|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm

Post by daledude » Fri Nov 18, 2011 4:42 am

Any chance of getting this to work/integrate with the export tool? ???

New member

Posts

Joined
Thu Dec 17, 2009 1:30 am

Post by bull5-i » Fri Nov 18, 2011 5:54 am

I've included a file for OC 1.5.1.x which should enable you to save the main image title and alt message, but not the additional images.

As the import/export tool supports only one language, it's of little help to me or anybody with multilingual shop. That's why I haven't considered adding support to it.
Adding the titles&alt messages for the additional images would take a good day's work at least, so unless you're willing to pay me for that it won't get to my TODO list.

Attachments

admin/model/tool/export.php


|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm

Post by bull5-i » Sat Feb 04, 2012 8:38 pm

Released version 2.2.0 for OpenCart 1.5.1.x as a vQmod.

Added option to hide the alternative text field to save space in case you do not use it.
Also added option to choose between tabbed and untabbed display of multilanguage edit fields (see pictures below)
admin_product_data_tabbed.png

Admin, product edit, main product image (tabbed view) - admin_product_data_tabbed.png (30.96 KiB) Viewed 4994 times

admin_product_data_untabbed.png

Admin, product edit, main product image (untabbed view) - admin_product_data_untabbed.png (34.32 KiB) Viewed 4994 times

admin_product_data_untabbed_wo_alt_text.png

Admin, product edit, main product image (untabbed view, without alternative text field) - admin_product_data_untabbed_wo_alt_text.png (30.63 KiB) Viewed 4994 times


|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm

Post by prompos123 » Wed Feb 08, 2012 1:03 pm

I need some help with this module. I have installed it and all looks good in Admin but none of the data I input is displayed on the site. I'm new to Opencart so need some hand holding.

Newbie

Posts

Joined
Sat Feb 04, 2012 10:12 am

Post by bull5-i » Wed Feb 08, 2012 3:38 pm

Sent you an email.

|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm

Post by bull5-i » Fri Mar 16, 2012 12:37 am

Released version 2.3.0:
  • Fixed: default values are not prefilled when adding a new language
  • Added: option to take the content from the admin language fields when secondary language fields are left empty

|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm

Post by Newbeing » Fri Mar 30, 2012 4:47 pm

Hi bull5-i I'm having problem getting this extension to work on my store. I have send you an private message here. Can you please take a look and get back to me asap. Thank you very much.

Newbie

Posts

Joined
Fri Dec 09, 2011 10:23 pm

Post by saintlade » Sat Apr 21, 2012 5:53 am

Hi Bull5-i,

just a quick one to say thanks for the module, works like a charm and I think it's a must to try and push the SEO to make your website jump up the rankings. Install was simple (gotta love Vqmod) and despite a highly customised template it's very easy to figure out what to change to get it working fine. If I had any complaints it would be that I want more! Would be nice to have the option to set Alt and Title for the Category Images as well. Would really appreciate a bit of help to get that working.

Thanks for the good work,

Stu

New member

Posts

Joined
Wed Oct 12, 2011 9:12 am

Post by bull5-i » Sat Apr 21, 2012 2:34 pm

Hi Stu,

I'm glad you like the extension.
As category images are more like design elements or sometimes they are not used at all I do not see the need in adding a custom title element to them. The alt message itself is the category name that is already in place by default. If you still wish to add custom titles and alt messages then my advice is to use the same analogy that I've used for product images. Add text fields for the alt and title message to the category table, add the input fields in the category edit page and then display them in the front end category page together with the image.
If you find it to be too big a bite to chew I could offer you a paid service to complete it for you. But you should have a very good example at your displosal in the form of this extension to complete it yourself.

Cheers,
bull5-i

|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm

Post by saintlade » Sun Apr 22, 2012 1:35 am

Hi bull5-i,

thanks for that, shall have another crack at it and if I'm still struggling I'll come to you.

Cheers,

Stu

New member

Posts

Joined
Wed Oct 12, 2011 9:12 am

Post by Moheb » Thu Apr 26, 2012 7:31 am

hi Bulli
I just purchased this yesterday unfortunately my site has many modifications to it and it doesn't seem to want to work, can i give you access to my website and you please help install it properly for me without overwriting any files etc?
Thanks in advance

Newbie

Posts

Joined
Sat Oct 15, 2011 8:24 am

Post by bull5-i » Thu Apr 26, 2012 2:17 pm

Hi Moheb,
Yes you can. I would need FTP & store admin access.

|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm

Post by regsavon » Wed May 09, 2012 10:15 pm

Hi There.
Just about to buy your module.
I have OC Version 1.5.2.1 installed.

Which link do i click on to order?
- CustomImageTitles_151 [v2.1] v1.5.1 [ Download ]
or
- CustomImageTitles_oc152x [v2.3.1] vQmod v1.5.2, v1.5.2.1 [ Download ]

Thanks
Rich

Newbie

Posts

Joined
Wed May 09, 2012 10:13 pm

Post by bull5-i » Wed May 09, 2012 10:36 pm

The second one is for OC 1.5.2.1.

|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm

Post by regsavon » Wed May 09, 2012 11:09 pm

Hi I have purchased & uploaded all the files from the UPLOAD folder. And installed the module.
However, in Home :: Modules :: Custom Product Image Titles (CPIT)
I am getting this error: vQmod does not seem to be installed.

I do have a vqmod folder & it all looks ok.

Please can you advise how i fix?

Using Version 1.5.2.1
Thanks. Rich

Newbie

Posts

Joined
Wed May 09, 2012 10:13 pm

Post by bull5-i » Wed May 09, 2012 11:14 pm

Having a folder does not mean it is installed. Did you download vQmod from http://code.google.com/p/vqmod/ and install it as per instructions found on that site?

|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm

Post by bull5-i » Wed May 23, 2012 7:13 pm

Released version 2.4.0:
  • Added: custom category image titles & alternate messages
  • Added: product main image titles & alts are visible also on category and search pages

|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm

Post by jarek79 » Sat Jun 23, 2012 10:20 pm

I got few errors after installing CIT, can you please help?

I run 1.5.1.3 on Universal theme
This an error I get from error log

2012-06-23 14:19:16 - PHP Notice: Undefined variable: text_tax in /home/amazingg/public_html/vqmod/vqcache/vq2-admin_view_template_common_header.tpl on line 161
2012-06-23 14:19:16 - PHP Notice: Undefined variable: tax_rate in /home/amazingg/public_html/vqmod/vqcache/vq2-admin_view_template_common_header.tpl on line 164
2012-06-23 14:19:16 - PHP Notice: Undefined variable: text_tax_rate in /home/amazingg/public_html/vqmod/vqcache/vq2-admin_view_template_common_header.tpl on line 164

and this one is in vqmod manager

---------- Date: 2012-06-23 14:05:55 ~ IP : 86.30.166.34 ----------
REQUEST URI : /admin/index.php?route=module/vqmod_manager/clear_log&token=08e3b5855bde7e93a0bc955f9053573e
MOD DETAILS:
modFile : /home/amazingg/public_html/vqmod/xml/custom_image_titles.xml
id : Add custom titles and alternative messages for all product and category images together with image sort order
version : 2.4.0
vqmver : 1.0.7
author : rmg
Could not resolve path for [catalog/view/theme/shoppica/template/product/category.tpl] (SKIPPED)
Could not resolve path for [catalog/view/theme/shoppica/template/product/product.tpl] (SKIPPED)
Could not resolve path for [catalog/view/theme/shoppica/template/product/search.tpl] (SKIPPED)

Can you please help me resolve it?

Thank You

Jerry

Amazing Gift Boxes - Is an online shop specializing in unique and exclusive hand made gift packaging. Use promo code "code10" to get 10% off and free delivery on orders over £30. | Gift Bags | Gift Boxes


User avatar
New member

Posts

Joined
Tue Jun 05, 2012 10:23 pm


Post by bull5-i » Sun Jun 24, 2012 3:30 pm

Hi Jerry,

The tax_rate related error are not caused by the CIT extension. They could be caused by another mod or it's some OC bug.
You can ignore the vqmod errors if you are not using the shoppica theme. To get rid of those "Could not resolve path for" lines from the vqmod log file you need t edit the custom_image_titles.xml and remove all blocks that try to edit the files for shoppica theme. They should be at the end of the file.

BR,
bull5-i

|V|355 \/\/17|-| 7}{3 |3357, ... [you know the rest]

Commercial mods: New! Questions & Answers PRO - Admin Quick Edit PRO - Product Downloads PRO - Custom Product Tab PRO - New! Product Quick Edit Plus

All mods & extensions by me


Active Member

Posts

Joined
Tue Jan 11, 2011 8:49 pm
Who is online

Users browsing this forum: No registered users and 12 guests