Post by gob33 » Mon Feb 09, 2015 1:38 am

I dont know. I dont know what you have done, or installed and even what version of extension and OC you are using.
You come, said that dont work and count on me to repair.
And you already asked that on 4 nov 2012.
Last edited by gob33 on Mon Feb 09, 2015 1:57 am, edited 1 time in total.

All my extensions


Active Member

Posts

Joined
Wed Feb 10, 2010 8:43 am
Location - France

Post by dudumagic » Mon Feb 09, 2015 1:56 am

Version 1.5.4

and all is work . i don't say no work . just have double in the admin .

i post the code of 2 files

New member

Posts

Joined
Tue Sep 04, 2012 12:51 am

Post by gob33 » Mon Feb 09, 2015 1:59 am

No you dont expose code here.
I dont care your 2 files. Support is done is private or nothing. And send all your cache.

All my extensions


Active Member

Posts

Joined
Wed Feb 10, 2010 8:43 am
Location - France

Post by caseyz » Wed Apr 22, 2015 7:16 am

I purchased your module and installed it on Mijoshop (OPENCART V 1.5.5.1). Everything seemed to install fine, however, upon installing, my previous history isn't visible, and I can see the fields for the Package Tracking Service, the "Automatically check customer notification" triggers, etc, however, when I click "Add history" nothing happens. I checked in the SQL database and nothing is being added.

I know you don't mention compatibility with Mijoshop, just curious if you plan on integrating the module to work with it or have any advice as to what to look for.

Newbie

Posts

Joined
Wed Apr 22, 2015 7:04 am

Post by caseyz » Fri Apr 24, 2015 2:19 am

I recently purchased the Package Tracking Service module.
I am on a version of Opencart 1.5.5.1 (Mijoshop)
I uploaded and installed the vqmod and the module states that it installs properly, however, it also displays a warning:
" Warning: Your SQL database seems to be missing table '#__mijoshop_return_history' !"

and when I try to view the order history, the new tracking fields show up, however, the older order history is missing, and when I try to add tracking history, nothing happens.

Any help would be appreciated.

Newbie

Posts

Joined
Wed Apr 22, 2015 7:04 am

Post by gob33 » Tue Apr 28, 2015 5:10 pm

Simply, extension is not programmed for Mijoshop. Special modifications for Mijoshop always need to be done for any extension. You must try by yourself to adapt as i have no plan to make a special version.

All my extensions


Active Member

Posts

Joined
Wed Feb 10, 2010 8:43 am
Location - France

Post by JBGood » Wed Sep 09, 2015 9:43 am

Do you have a timeline to update Package Tracking Service to Opencart 2.0?

New member

Posts

Joined
Tue Aug 21, 2012 7:51 pm

Post by gob33 » Wed Sep 09, 2015 4:38 pm

This extension is in the group who touch to order history and order status.
If you read forum, specially 2.0 bugs, you will see many people get an unresolved json error at this point.
Thats my case and so I can test further my extension or put online something which buyers will say "your extension dont work".

Another point is the summernote editor inside 2.0 which is unable to do an equivalent of what was programmed for ckeditor in 1.5.x.

In front of that, Ive decided to suspend work on version for 2.0 (no date), and wait for the team to get conscious they have a problem there. My work is now focused in a new completely reworked extension v6 for 1.5.x and villagedefrance very good clone 1.7.x.

All my extensions


Active Member

Posts

Joined
Wed Feb 10, 2010 8:43 am
Location - France

Post by gob33 » Thu Mar 24, 2016 1:08 am

Version 20160322 for Opencart 2 released.
It will start with OC.2.2.0.0 and is not compatible with previous OC2.x versions.
Now you can prepare any message(s) you want for history (with/without tracking infos) in text or html.
Package Tracking Service 6.0

All my extensions


Active Member

Posts

Joined
Wed Feb 10, 2010 8:43 am
Location - France

Post by gob33 » Tue Jun 21, 2016 11:49 pm

Update 20160621: Correction of a bug in controller (giving "data" and "type" errors) for versions OC2.x.

All my extensions


Active Member

Posts

Joined
Wed Feb 10, 2010 8:43 am
Location - France

Post by gob33 » Sun Jul 10, 2016 11:13 pm

Update 20160710 v6.1: Changed test on JSON_PRETTY_PRINT for old PHP versions.
Added carrier's customer contact fields and their associated tags.

All my extensions


Active Member

Posts

Joined
Wed Feb 10, 2010 8:43 am
Location - France

Post by chriswsm » Tue Oct 11, 2016 5:25 pm

Hi there

Had quite a few issues with this product using V 6.1 - 20160710 [ vQmod ] with OC 1.5.5.1.
All seem to be random, however...This one is sticking around, so can you please take a look?

When in the Admin Area, accessing a Client order (Sales -> Orders) using View against the Order... I add a Note to the order and click Add Note, and I get this error:
Fatal error: Call to undefined function isHTML() in /var/www/vhosts/smokeyschemsite.com/httpdocs/vqmod/vqcache/vq2-admin_controller_sale_order.php on line 2869

The code for that line is:
2868: // PACKAGE_TRACKING_SERVICE_MODIFICATION_BEGIN (ORDER_HISTORY)
2869: => (isHTML($decoded_str = html_entity_decode($result['comment'], ENT_QUOTES, 'UTF-8')) ? $decoded_str : newline2break($decoded_str, true)),
2870: // PACKAGE_TRACKING_SERVICE_MODIFICATION_END (ORDER_HISTORY)

The Note has been added and I can see it in the Note section of the Dashboard, but when I view the order, the above error is written where the Note should be and also at the top of the order details.

Regards
Chris

Newbie

Posts

Joined
Tue Jan 12, 2016 7:30 pm

Post by gob33 » Tue Oct 11, 2016 8:59 pm

Tested and checked v6.1-2016071 with 1.5.5.1 = no problems, no errors.
You must have a call to

Code: Select all

$this->load->model('module/package_tracking');
just before your line 2868, if not it cant find the isHTML() function.

Check also your error and vqmanager log files if any conflicts.

All my extensions


Active Member

Posts

Joined
Wed Feb 10, 2010 8:43 am
Location - France

Post by chriswsm » Wed Jan 18, 2017 7:27 pm

Thanks... I've got this sorted...

Excellent product...thank you

Newbie

Posts

Joined
Tue Jan 12, 2016 7:30 pm

Post by chriswsm » Wed Jan 18, 2017 7:39 pm

Hi there

Version: 6.1 - 20160710 [ vQmod ]
OC Version 1.5.5.1

I have noticed an issue with Chrome...
When I try to add a Comment Template (any one), all I get is the loading.gif image alongside the language dropdown.

This does not happen in FireFox. I can't see anything in any logs, to indicate where this issue may rest.

I've tried on a few laptops now, not all mine, and they all fail at this point. Are there any limitations with Chrome?

Thanks for your help

Chris

Newbie

Posts

Joined
Tue Jan 12, 2016 7:30 pm

Post by coolshop » Wed Oct 25, 2017 11:02 am

I am able to install and configure the settings and template. However, when I try to save the order history I get " Warning: You do not have permission to access the API!".
Also, what do I need to do to make the email that the customer receives, the entry on the order history that the admin sees and that the customer sees have the HTML tracking (clickable) link instead of plain text?

New member

Posts

Joined
Sun Sep 09, 2012 10:31 am

Post by marwan83 » Thu Aug 02, 2018 6:30 pm

Hi,

Im having a problem when I try to add the tracking link to the order history. I have configured the tracking link and tracking number variable. When uodating the order, the tracking link appears good, but, in place of the tracking number I get “undefined”. Can you please help?

New member

Posts

Joined
Wed Oct 24, 2012 2:52 am

Post by gob33 » Thu Aug 09, 2018 5:49 am

Check you write correctly "{$tracking_number}".

All my extensions


Active Member

Posts

Joined
Wed Feb 10, 2010 8:43 am
Location - France
Who is online

Users browsing this forum: No registered users and 8 guests