Post by Qphoria » Thu Dec 11, 2008 1:40 am

Designed for OpenCart 0.7.9
Will NOT work with older versions

This is a proper cleanup and update of the old "Featured/SpecialOffer/Latest" contrib for 0.7.9

This one is more of a "plug-n-play" out of the box.

DESCRIPTION
==========
This contrib simply adds 3 new modules in OpenCart to show:
- Latest Products Added
- Featured Products
- Special Offer Products
on the Home page (can be easily changed to show on all pages)

You can set products to be Featured or Special from the Admin->Catalog->Product->Update page under the "Home" tab.

Download

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Qphoria » Sun Dec 28, 2008 6:04 pm

Update:

v079.2:
- added missing code for featured/special status save in admin/controller/product.php
- added back "No current products found" under the headers on the homepage if there were none found instead of leaving it just blank.

Download

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Qphoria » Thu Jan 15, 2009 5:59 am

Update:

v079.3:
- added changes for the updated admin/template/default/content/product.tpl file for the Fckeditor.

Download

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by jamble » Sat Jan 31, 2009 3:12 am

Hi,

I installed this and get the following error when I try to edit a product in the admin

Fatal error: Call to undefined method Request::gethtml() in Y:\xampp\htdocs\e-commerce\opencart2\admin\controller\product.php on line 433

Everything else seems to be alright, the modules added and they display on the homepage of my test store but I can't seem to access the product info in the admin. I downloaded the last zip from the downloads section and am running the 0.79 version from svn

Any thoughts on how to solve?

Thanks!

Newbie

Posts

Joined
Thu May 08, 2008 11:08 pm

Post by Qphoria » Sat Jan 31, 2009 4:05 am

If you updated to 0.7.9 you shouldn't have that error. Unless you overwrote the library/environment/request.php file with an old version. Reupload that file from the 0.7.9 zip.

Also, we just released OpenCart 0.7.9 Final so you might want to upgrade.

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am
Who is online

Users browsing this forum: No registered users and 2 guests