Post by Qphoria » Fri Nov 07, 2008 8:21 pm

kinda hoped all the bugs would be addressed first before enhancements were made, unless you fixed all those too?

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by fido-x » Fri Nov 07, 2008 8:59 pm

This package only provides a replacement "admin/controller/generate_url_alias.php" file and a corresponding "admin/language/english/controller/generate_url_alias.php" file. All the bugs you mention are due to routing issues and not with the actual url alias generation process.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by Qphoria » Fri Nov 07, 2008 9:06 pm

except the bug with balls-andamp-baskets was in that file to get rid of the "amp"

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by fido-x » Fri Nov 07, 2008 9:26 pm

Qphoria wrote: except the bug with balls-andamp-baskets was in that file to get rid of the "amp"
That issue has been addressed in the replacement "generate_url_alias.php" file.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by mikeytrw » Fri Dec 05, 2008 10:36 pm

Hey guys,

Great contrib....


I noticed that products with '+' symbols in their name were not working with this contrib, to fix I added the following lines:

Code: Select all

$value = str_replace('+', 'and', $value);
below

Code: Select all

$value = str_replace(' ', '-', $value);
and

Code: Select all

$alias = str_replace('+', 'and', $alias);
below

Code: Select all

$alias = str_replace(' ', '-', $alias);

in generate_url_alis.php

Thanks :)

New member

Posts

Joined
Tue May 27, 2008 9:28 pm

Post by Jacob » Fri Dec 12, 2008 9:43 pm

Contribution Name
OpenCart 0.7x SEO Upgrade Package

"Just drop the files into your site root (all files are in correct folders) then run the dbupdate.sql, Login to your admin panel and choose to enable which ever feature(s) you like."

So as a php novice this sounds great something I can do myself!

But after trying to follow this thread I am now wondering if all the problems mentioned have been solved, meaning all I have to do is follow the instructions above?

Big thanks

Running v1.5.5.1


Active Member

Posts

Joined
Thu Dec 04, 2008 9:17 pm

Post by Qphoria » Fri Dec 12, 2008 10:34 pm

actually there are even more problems now. since 079 RC5 has locator.php changes this contrib needs lots of updates. I will release my custom fixed version of this later today

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Jacob » Fri Dec 12, 2008 11:53 pm

Great! how will we hear about it?

Running v1.5.5.1


Active Member

Posts

Joined
Thu Dec 04, 2008 9:17 pm

Post by Qphoria » Fri Dec 12, 2008 11:56 pm

i will post the message here of course

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Jacob » Fri Dec 19, 2008 10:54 pm

Hi Qphoria

I know you said you would post here but it's been awhile, did the custom fix get done?

Thanks

Running v1.5.5.1


Active Member

Posts

Joined
Thu Dec 04, 2008 9:17 pm

Post by Qphoria » Fri Dec 19, 2008 11:05 pm

oh.. yea.. sorry.. I will try to get to it today.

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Jacob » Sun Jan 11, 2009 9:21 pm

Has this been done? :)

Running v1.5.5.1


Active Member

Posts

Joined
Thu Dec 04, 2008 9:17 pm

Post by Qphoria » Mon Jan 12, 2009 10:43 pm

It was delayed waiting for RC6. There were some url structure changes that needed to be in place before updating this. I will update later today

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Jacob » Tue Jan 13, 2009 12:48 am

Oh great  :)

Running v1.5.5.1


Active Member

Posts

Joined
Thu Dec 04, 2008 9:17 pm

Post by Qphoria » Tue Jan 13, 2009 5:23 am

OK Here it is:

It was originally fixed using 0.7.9-RC2, and I've made a few updates for RC6 but I think it should work for all 0.7.9 RC versions.

Changes from the original:
- Moved SEO to its own 'seo_tools' controller (instead of the settings tab)
- Added '&amp' as one of the replace options to avoid "balls-andamp-baskets.html"
- Removed the included library/application/router.php file as the feature it creates it doesn't really pertain to SEO.
- Removed the included htaccess file as that already has been updated to be the same in 0.7.9
- Changed HOSTING_DIR to HTTP_CATALOG
- Using the updated 0.7.9 layout.tpl file
- Fixed the googleverify code in the layout.tpl file
- Included bruce's search.php fix
- Updated readme

Let me know if you have any problems:

Attachments

Last edited by Qphoria on Tue Jan 13, 2009 5:30 am, edited 1 time in total.

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Jacob » Tue Jan 13, 2009 6:02 pm

Just a very basic question,  the upload/index.php file already exists and is quite different to the new one. I am not sure if I should upload it.

Thanks to you and David Gilbert.

Running v1.5.5.1


Active Member

Posts

Joined
Thu Dec 04, 2008 9:17 pm

Post by Qphoria » Tue Jan 13, 2009 6:05 pm

Jacob wrote: Just a very basic question,  the upload/index.php file already exists and is quite different to the new one.
You can always trust an OpenCart Dev :)

There are only 2 new google sections in the index.php file. Add those to your index file if you are unsure

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Jacob » Tue Jan 13, 2009 6:18 pm

:D

Suppose I could have worked that out myself.

And this
// Initialisation

Running v1.5.5.1


Active Member

Posts

Joined
Thu Dec 04, 2008 9:17 pm

Post by Qphoria » Tue Jan 13, 2009 6:32 pm

Jacob wrote:
And this
// Initialisation
That's actually part of 0.7.9-RC6

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Jacob » Tue Jan 13, 2009 11:08 pm

From the install.txt:
1) Upload all of the files within the upload directory to your server! Then in PHPMyAdmin, Run the dbupdate.sql


2) Login to your admin panel and set url Alias on under the SEO Tab of the settings panel

I have uploaded all the files, run the sql code and made the new files accessible to user  in Admin>User Group (which BTW is not mentioned in the install.txt), I suppose you know that and thought if people have come thus far they will know to do it.


I don't have a SEO Tab (Is that part of 0.7.9-RC6?) I do have the url Alias option under the Shop Tab.

Cheers
Last edited by Jacob on Tue Jan 13, 2009 11:11 pm, edited 1 time in total.

Running v1.5.5.1


Active Member

Posts

Joined
Thu Dec 04, 2008 9:17 pm
Who is online

Users browsing this forum: No registered users and 3 guests