Post by Qphoria » Thu Jan 15, 2009 10:47 pm

one step at a time.

Looking at your xml file output, I think I see the problem.. or at least "a" problem. But I'm not sure why yet.

Your links are :
http://www.capxxxxxx.co.uk/shop/index.p ... eira__id=4
they should be
http://www.capxxxxxx.co.uk/shop/product-1.html


Did you run the http://www.mysite.com/shop/admin/index. ... _url_alias address first?

Or perhaps something not working with your version of OpenCart and the contrib. If you did run the generator, I will try to install RC5 and see where the problem is. RC6 had a lot of url changes so that is likely part of problem, but I don't remember changing anything for that in the contrib

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Jacob » Fri Jan 16, 2009 1:45 am

They are like that because I changed them today in admin > url alias. I was told I could change them to what I wanted.

Sorry what do yo mean by 'run'

Running v1.5.5.1


Active Member

Posts

Joined
Thu Dec 04, 2008 9:17 pm

Post by Qphoria » Fri Jan 16, 2009 6:52 am

Jacob wrote: They are like that because I changed them today in admin > url alias. I was told I could change them to what I wanted.
erm.. take a look at the url alias faq to understand how it works:
http://forum.opencart.com/index.php/topic,2738.0.html
Sorry what do yo mean by 'run'
just load that page, and it should take you to the url alias page with all aliases pre-filled

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Jacob » Sat Jan 17, 2009 9:01 pm

erm.. take a look at the url alias faq to understand how it works:
http://forum.opencart.com/index.php/topic,2738.0.html
Ok, after reading your notes on how 'url alias' works.

I now understand it and realize I have made some mistakes

Please can you advise me on the next step I should take.

So far I have gone into Url Alias and manually changed everything including 'Url Query' (yes I know, silly me) to look something like this:

Code: Select all

Shoes_con=shoes_id=44
And url Aias to look like this:

Code: Select all

shoes_shoes.html 
I have missed out the remastering stage and also editing the .htaccess file

If I now go ahead and edit the .htaccsess file now what will happen?

Running v1.5.5.1


Active Member

Posts

Joined
Thu Dec 04, 2008 9:17 pm
Who is online

Users browsing this forum: No registered users and 4 guests