Post by Sea-Wing_Designs » Wed May 20, 2015 5:17 am

Hello, I have installed the import/export tool and tested it out. I exported the first 500 products and the file downloaded properly. I looked at it and all of the entries seemed correct. I then attempted to import the same file without changing it to see if every thing is working correctly and I got this error:
Uploaded spreadsheet file has validation errors!
See also 'System > Error Logs' for more details.
No server data has been changed.
The error log says this:

2015-05-19 14:14:25 - Export/Import: Worksheet 'AdditionalImages' cannot use product_id '103' because it is not listed in worksheet 'Products'!
2015-05-19 14:14:25 - Export/Import: Worksheet 'AdditionalImages' cannot use product_id '211' because it is not listed in worksheet 'Products'!
2015-05-19 14:14:25 - Export/Import: Worksheet 'AdditionalImages' cannot use product_id '229' because it is not listed in worksheet 'Products'!
2015-05-19 14:14:25 - Export/Import: Worksheet 'Rewards' cannot use product_id '103' because it is not listed in worksheet 'Products'!
2015-05-19 14:14:25 - Export/Import: Worksheet 'Rewards' cannot use product_id '211' because it is not listed in worksheet 'Products'!
2015-05-19 14:14:25 - Export/Import: Worksheet 'Rewards' cannot use product_id '229' because it is not listed in worksheet 'Products'!

What am I doing wrong? We are using OC v.1.5.5.1

Edit* I tried to do the same thing by exporting the options and then importing, and it worked just fine.

New member

Posts

Joined
Tue May 21, 2013 7:57 am

Post by IP_CAM » Wed May 20, 2015 10:25 pm

I assume, Rewards, as well as AdditionalImages, are not 'incoroprated/preset' Values in your import/export Mod, therefore, they cannot be 'used' as such. If you check on your Product ID's 103,211,229, you probably find some Rewards or AdditionalImages Information, related to those Products, therefore, it throw's the error on those.

Just an Idea!
Ernie
bigmax.ch/shop/

For Sale: Top URL's, including an OpenCart V-Pro Installation, similar to:
http://www.bigmax.ch - http://www.ipcam.li - http://www.jti.li
For Information + URL's offered, please contact me at: jti@jacob.ch
I am NOT available for Custom Support in existing OC Installations!
My Github Repositories: https://github.com/IP-CAM
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by Sea-Wing_Designs » Thu May 21, 2015 2:21 am

The weird thing is that when I look at the spreadsheet, those items don't exist. I tried to just export those item numbers and they don't export. So something else is going on here.

I tried just exporting one product that I know exists and when I import it I get the same error message and the error logs say:

2015-05-20 11:23:04 - Export/Import: Undefined option_name 'Add Gift Wrap' used in worksheet 'ProductOptions'!
2015-05-20 11:23:04 - Export/Import: Undefined option_name 'Add Gift Wrap' used in worksheet 'ProductOptionValues'!

I looked at that product and there are no columns for Add Gift Wrap.

New member

Posts

Joined
Tue May 21, 2013 7:57 am

Post by IP_CAM » Fri May 22, 2015 11:10 pm

Depending on the EXPORT-MOD, you use, VALUES, to be exported, may have to be pre-given/pre-defined by the Mod, like shown on the sample (unrelated to your specific problem!) below. Some of them may not exist, so are, as a consequence, just overlooked, or then advised, as ERROR, by the export-routine.

Possibly, at least..., if ALL Options/Attributes have been configured correctly, in the first Place. ;)

Code: Select all

			'customer_group'=> $result['customer_group'],
				'customer_name'      => $result['customer_name'],
				'email'=> $result['email'],
				'telephone'      => $result['telephone'],
				'payment_address'=> $result['payment_address'],
				'shipping_address'      => $result['shipping_address'],
				'payment_method'=> $result['payment_method'],
				'shipping_method'        => $result['shipping_method'] 
BUT SINCE the 'option_name' 'Add Gift Wrap' IS NOT pre-defined/used in worksheet 'ProductOptions', as well as other MOD-OPTIONS, added by you to OC, assumingly, it CANNOT be handled by the import/export MOD, used.

But it's just plain Guessing... ???
Ernie
bigmax.ch/os/

For Sale: Top URL's, including an OpenCart V-Pro Installation, similar to:
http://www.bigmax.ch - http://www.ipcam.li - http://www.jti.li
For Information + URL's offered, please contact me at: jti@jacob.ch
I am NOT available for Custom Support in existing OC Installations!
My Github Repositories: https://github.com/IP-CAM
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by Skawty » Wed Dec 23, 2015 12:08 am

Did you ever find a fix for this as i have the same problem?

User avatar
New member

Posts

Joined
Thu Nov 26, 2015 5:31 pm
Location - UK

Post by neatpleats » Tue Aug 22, 2017 12:06 pm

When you re-import your data, you need to change the .xlsx file to .xls. In your Excel program, export to the .xls which is an older version and that will import your data correctly.

Neat Pleats Lamps & home decor since 1993.


User avatar
New member

Posts

Joined
Mon May 17, 2010 7:29 pm
Location - Baltimore, MD
Who is online

Users browsing this forum: No registered users and 8 guests