Post by JNeuhoff » Tue Oct 07, 2014 5:00 am

The Export/Import Tool (V2.x) is now available for OpenCart 2, with the same same features as the one for OpenCart 1.5.x.
Last edited by JNeuhoff on Fri Aug 11, 2017 2:23 am, edited 1 time in total.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by allenshea » Tue Oct 07, 2014 8:32 am

Thanks for the contribution.

Can we have 1 more option when export products?

Select what data you want to export:
All(including Categories, product data, options, specials, discounts, rewards and attributes)
Categories
Products (including product data, options, specials, discounts, rewards and attributes)
Option definitions
Attribute definitions

Thanks!

By the way, in your new version, the 'viewed' is missing. Can you add it?

I know nothing about PHP and SQL, but I still try my best to understand it.


Active Member

Posts

Joined
Mon Dec 14, 2009 10:01 pm

Post by JNeuhoff » Tue Oct 07, 2014 2:18 pm

By the way, in your new version, the 'viewed' is missing. Can you add it?
It's not in there on purpose. During an Import, it preserves the existing viewed counts.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by allenshea » Tue Oct 07, 2014 2:42 pm

JNeuhoff wrote:
By the way, in your new version, the 'viewed' is missing. Can you add it?
It's not in there on purpose. During an Import, it preserves the existing viewed counts.

Yes, if for upgraded from old OC version, it is no need be there. But if I want upload all items for new installed OC version, it will be better have old data. Thanks!

I know nothing about PHP and SQL, but I still try my best to understand it.


Active Member

Posts

Joined
Mon Dec 14, 2009 10:01 pm

Post by mickgraham » Tue Oct 07, 2014 8:15 pm

HI

Im installing v2.0 now but I receive this error:

SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

OK

<b>Warning</b>: ftp_login(): This is a private system - No anonymous login in <b>/home/xxx/xxx/shop/vqmod/vqcache/vq2-admin_controller_extension_installer.php</b> on line <b>289</b>{"error":"Could not login as "}

Newbie

Posts

Joined
Mon Oct 15, 2012 7:40 pm

Post by hale » Tue Oct 07, 2014 9:40 pm

Hello,
You do not need vqmod for 2.0, I think.
I saw that Daniel had updated the file to fix the problem
admin/controller/extension/installer.php

Newbie

Posts

Joined
Thu Apr 29, 2010 11:06 pm

Post by JNeuhoff » Tue Oct 07, 2014 9:47 pm

mickgraham wrote:HI

Im installing v2.0 now but I receive this error:

SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

OK

<b>Warning</b>: ftp_login(): This is a private system - No anonymous login in <b>/home/xxx/xxx/shop/vqmod/vqcache/vq2-admin_controller_extension_installer.php</b> on line <b>289</b>{"error":"Could not login as "}
You don't need VQmod for the Export/Import tool for OpenCart 2.0, because it uses it's builtin OCmod. See the 'readme.txt' for details on how to install it.

User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by mickgraham » Tue Oct 07, 2014 10:21 pm

The error happens when I am installing it from Extensions Installer.
After about 50% of the install??

I don't see what this has to do with VQmod.

Newbie

Posts

Joined
Mon Oct 15, 2012 7:40 pm

Post by mickgraham » Tue Oct 07, 2014 11:23 pm

Hi

I removed all the files via FTP and tried to install again but I still get the same error.

Any other ideas?

rgds
Mick

Newbie

Posts

Joined
Mon Oct 15, 2012 7:40 pm

Post by JNeuhoff » Tue Oct 07, 2014 11:44 pm

<b>Warning</b>: ftp_login(): This is a private system - No anonymous login in <b>/home/xxx/xxx/shop/vqmod/vqcache/vq2-admin_controller_extension_installer.php</b> on line <b>289</b>{"error":"Could not login as "}
Sorry, I am unable to help, I am not able to reproduce your error. Remove VQmod, or at least, remove the VQmod XML which modifies the admin/controller/extension/installer.php

BTW.: The offending line could be this one:

Code: Select all

$login = ftp_login($connection, $this->config->get('config_ftp_username'), $this->config->get('config_ftp_password'));
which indicates who haven't got a running FTP server, or haven't configured OpenCart with the needed FTP login details.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by hale » Tue Oct 07, 2014 11:58 pm

Hello Mick,
I had the same problem, and then I noticed there was some newer files on github, so I download and replaced old files.
Download link:
https://github.com/opencart/opencart

After that, the error was fixed.
Please make use you change php.ini for the max execute value larger than 30 seconds and enable FTP on settings page.

I installed on localhost, have filezilla ftp server, open port 12121, enable but got this error
could not connect as 127.0.0.1:12121

Edit: after change the ftp port, your extension is installed successful :)
Thank you

Newbie

Posts

Joined
Thu Apr 29, 2010 11:06 pm

Post by JNeuhoff » Wed Oct 08, 2014 12:22 am

hale: I think there will be many more users having problems when testing OC2 extensions on a local PC because of not having a properly running FTP server. I am not quite sure why Daniel has chosen to use FTP for the final storing of already uploaded files in his admin/controller/extension/installer.php.

Anyway, thanks for sharing your solution with us.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by adb34 » Thu Oct 09, 2014 1:46 am

Hi

I have a fresh install with Opencart v2; vqmod v2 and this import/export v2

Under Admin, I could find the import/export under system tag. Where is it now? I cannot find it.

Thanks for your time and help

New member

Posts

Joined
Sat Sep 20, 2014 8:49 pm

Post by JNeuhoff » Thu Oct 09, 2014 2:33 am

adb34 wrote:Hi

I have a fresh install with Opencart v2; vqmod v2 and this import/export v2

Under Admin, I could find the import/export under system tag. Where is it now? I cannot find it.

Thanks for your time and help
It should be under admin > System > Export/Import

For OpenCart 2.0 it doesn't use vqmod. Have you followed the installation instructions from the 'readme.txt' file?

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by adb34 » Thu Oct 09, 2014 2:38 am

JNeuhoff wrote:
adb34 wrote:Hi

I have a fresh install with Opencart v2; vqmod v2 and this import/export v2

Under Admin, I could find the import/export under system tag. Where is it now? I cannot find it.

Thanks for your time and help
It should be under admin > System > Export/Import

For OpenCart 2.0 it doesn't use vqmod. Have you followed the installation instructions from the 'readme.txt' file?
It is all my fault. I did not load the plug-in correctly. After fighting with the ftp all done and sorted. Yes you are right with the location.

andy

New member

Posts

Joined
Sat Sep 20, 2014 8:49 pm

Post by adb34 » Thu Oct 09, 2014 2:46 am

JNeuhoff wrote:
<b>Warning</b>: ftp_login(): This is a private system - No anonymous login in <b>/home/xxx/xxx/shop/vqmod/vqcache/vq2-admin_controller_extension_installer.php</b> on line <b>289</b>{"error":"Could not login as "}
Sorry, I am unable to help, I am not able to reproduce your error. Remove VQmod, or at least, remove the VQmod XML which modifies the admin/controller/extension/installer.php

BTW.: The offending line could be this one:

Code: Select all

$login = ftp_login($connection, $this->config->get('config_ftp_username'), $this->config->get('config_ftp_password'));
which indicates who haven't got a running FTP server, or haven't configured OpenCart with the needed FTP login details.

I had the same problem, but got it sorted. As follows;

1. Systems/Setting; action - edit
2. tab - FTP
3. Complete the FTP info
4. FTP Root - is the root file where the opencart is E.G. /shops/OpenCart/opencart/
5. Enable FTP - Yes


I hope this sorts out your problem

andy

New member

Posts

Joined
Sat Sep 20, 2014 8:49 pm

Post by marmax » Fri Oct 10, 2014 4:51 am

Welcome :) I'm a newbie to opencart, although I have some limited experience with joomla/worpress.

I have had the same problem as mickgraham.

I have removed vqmod and set up ftp and was able finally to install extension. Succesfully imported 'options' but for 'categories' and 'products' I have folowing error:
Export/Import: Invalid header in the Categories worksheet
.

Much confusion.

From readme.txt:
Also, a pre-installed VQmod is required, get it from <https://github.com/vqmod/vqmod/wiki>
but in this thread I've read advise to Remove VQmod

Much confusion.

New member

Posts

Joined
Fri Oct 10, 2014 4:34 am

Post by JNeuhoff » Fri Oct 10, 2014 5:22 pm

Look guys, I can't help you unless you provide us with at least some basic details, such as:

OpenCart version
entries in system/logs/error.txt
entries in server's error_log
any other extensions installed

As regards VQmod: Versions for OpenCart 1.5.x does require it, for OpenCart 2.0 it's not needed, just follow the 'readme.txt' for installation.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by marmax » Fri Oct 10, 2014 7:16 pm

Hi,
I have installed 2.0.0.0 from sratch, linux server, php 5.5.9
No plugins installed. (only this export/import plugin)

I have exported 3 files, options, categories, products with default plugin parameters to default xlsx file in opencart 1.5.6.4. 'File 'Options' was imported succesfully (although 2 extra checkboxes I found in imported options), while for 'categories' and 'products' I get message:

Uploaded file is not a valid spreadsheet file or its values are not in the expected formats!
See also 'System > Error Logs' for more details.
No server data has been changed.

and in opencart log: Export/Import: Invalid header in the Categories worksheet

I'm afraid I have no eccess to server's error_log (shared server).

New member

Posts

Joined
Fri Oct 10, 2014 4:34 am

Post by JNeuhoff » Fri Oct 10, 2014 8:44 pm

marmax, send me a PM with your FTP and OpenCart login details, and I can then take a look at your server. I am unable to reproduce your error. I assume you are using the latest version 2.13 of the Export/Import tool?

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am

Who is online

Users browsing this forum: No registered users and 10 guests