Post by angadarora » Sat Sep 01, 2018 12:11 am

straightlight wrote:
Fri Aug 31, 2018 11:18 pm
angadarora wrote:
Fri Aug 31, 2018 11:00 pm
Hi

everything seems to work fine even my php server settings are set high but there is a strange error "ERR_EMPTY_RESPONSE" when i try to import a file with just 4000 products, and i checked apache error logs, php error logs, opencart error logs i just cant find the reason for this error. If i know the error reason i can try to resolve it on my end only.

PS: Forgot to mention i am using OpenCart 2.2.0.0
Just? Try to go a little bit lighter on the size of the products you are trying to import and see if that results better insights. Also ensure the max input size in your php.ini uses a decent and high value (999M?). If already increased, it is possible that your server may be automatically defined to a lower value by your web hosting service.
Well actually i am running on Amazon EC2 - Ubuntu, so i have full rights regarding memory and php.

Well the php settings are set quite high

memory_limit: 1024M
max_execution_time: 800
max_input_time: 800
upload_max_filesize: 1024M
post_max_size: 1024M

There are no errors in any of the error logs, (which is strange).
The best reason i can think of is that my apache/server is closing the connection before processing the data. But i tried timeout 600 in apache, still no help.

Newbie

Posts

Joined
Sun Dec 08, 2013 12:05 am

Post by straightlight » Sat Sep 01, 2018 12:13 am

The best reason i can think of is that my apache/server is closing the connection before processing the data. But i tried timeout 600 in apache, still no help.
Which protocols or extension do you use to instantiate a connection with Amazon?

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by splka » Fri Sep 07, 2018 12:31 am

Great tool. Uses not a lot of memory.
Everything looks good expet tags option, it dosen't export it
I mean values from "oc_product_description>tag" didn't propretly exporting and importing
Which solution is correct for this issue?
Thank you:)

Newbie

Posts

Joined
Wed Jun 20, 2018 6:02 pm

Post by alexgt2100 » Fri Sep 14, 2018 4:30 pm

Hello
I get this error. Can you help me? Thank you.
2018-09-13 17:38:22 - PHP Warning: simplexml_load_string(): Entity: line 1: parser error : Start tag expected, '<' not found in C:\AppServ\www\pangea\system\library\export_import\Classes\PHPExcel\Reader\Excel2007.php on line 88
2018-09-13 17:38:22 - PHP Warning: simplexml_load_string(): application/vnd.oasis.opendocument.spreadsheet in C:\AppServ\www\pangea\system\library\export_import\Classes\PHPExcel\Reader\Excel2007.php on line 88
2018-09-13 17:38:22 - PHP Warning: simplexml_load_string(): ^ in C:\AppServ\www\pangea\system\library\export_import\Classes\PHPExcel\Reader\Excel2007.php on line 88
2018-09-13 17:38:23 - Export/Import: Undefined attribute_group_name 'Processor' used in worksheet 'ProductAttributes'!
2018-09-13 17:38:23 - Export/Import: Undefined attribute_group_name 'Memory' used in worksheet 'ProductAttributes'!
2018-09-13 17:38:23 - Export/Import: Undefined attribute_group_name 'Processor' used in worksheet 'ProductAttributes'!
2018-09-13 17:38:23 - Export/Import: Undefined attribute_group_name 'Memory' used in worksheet 'ProductAttributes'!
2018-09-13 17:38:23 - Export/Import: Undefined attribute_group_name 'Processor' used in worksheet 'ProductAttributes'!
2018-09-13 17:38:23 - PHP Unknown: The Twig_Autoloader class is deprecated since version 1.21 and will be removed in 2.0. Use Composer instead. in C:\AppServ\www\pangea\system\library\template\Twig\Autoloader.php on line 12
2018-09-13 17:38:23 - PHP Unknown: Using Twig_Autoloader is deprecated since version 1.21. Use Composer instead. in C:\AppServ\www\pangea\system\library\template\Twig\Autoloader.php on line 30
2018-09-13 17:38:23 - PHP Unknown: Using Twig_Autoloader is deprecated since version 1.21. Use Composer instead. in C:\AppServ\www\pangea\system\library\template\Twig\Autoloader.php on line 30
2018-09-13 17:38:23 - PHP Unknown: Using Twig_Autoloader is deprecated since version 1.21. Use Composer instead. in C:\AppServ\www\pangea\system\library\template\Twig\Autoloader.php on line 30
2018-09-13 17:38:23 - PHP Unknown: Using Twig_Autoloader is deprecated since version 1.21. Use Composer instead. in C:\AppServ\www\pangea\system\library\template\Twig\Autoloader.php on line 30

Newbie

Posts

Joined
Fri Sep 14, 2018 3:51 am

Post by splka » Tue Sep 18, 2018 3:43 pm

2018-09-13 17:38:22 - PHP Warning: simplexml_load_string(): Entity: line 1: parser error : Start tag expected, '<' not found in C:\AppServ\www\pangea\system\library\export_import\Classes\PHPExcel\Reader\Excel2007.php on line 88

Open file Excel2007.php in editor, then find line 88 and show code from this line

Also, nice to know, plugin version and OC version

Newbie

Posts

Joined
Wed Jun 20, 2018 6:02 pm

Post by adnan.masd » Wed Sep 19, 2018 4:06 am

Hi,

The tool is perfect.

I am facing one issue. When I import an Excel sheet for Categories or Products, the SEO field in the sheet overrides the values in the system. I am using a separate extension for SEO (which is multilingual) thus all my SEO is overwritten and I have to redo it again. Is there a way to stop reading SEO from the Excel? I am using Opencart v2.3.2

Newbie

Posts

Joined
Sat Feb 11, 2017 10:37 pm

Post by Riken12 » Wed Sep 19, 2018 6:18 pm

Hello. When I try import my exls, I see in logs error: 2018-09-19 12:53:35 - Export/Import: Invalid worksheet names
What I need to do with worksheet names?

Newbie

Posts

Joined
Wed Sep 19, 2018 6:16 pm

Post by JNeuhoff » Wed Sep 19, 2018 8:36 pm

adnan.masd wrote:
Wed Sep 19, 2018 4:06 am
Hi,

The tool is perfect.

I am facing one issue. When I import an Excel sheet for Categories or Products, the SEO field in the sheet overrides the values in the system. I am using a separate extension for SEO (which is multilingual) thus all my SEO is overwritten and I have to redo it again. Is there a way to stop reading SEO from the Excel? I am using Opencart v2.3.2
Most OpenCart 2.x multi-lingual SEO tools use an extra DB field, e.g. 'oc_url_alias.language_id' in order to support it. If you contact us, we can provide a VQmod XML script to add suport for it to the Export/Import tool, for a charge.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by adnan.masd » Thu Sep 20, 2018 2:30 pm

Is there a way to turn it off. I dont want the import export to edit my seo

Newbie

Posts

Joined
Sat Feb 11, 2017 10:37 pm

Post by JNeuhoff » Thu Sep 20, 2018 4:13 pm

Riken12 wrote:
Wed Sep 19, 2018 6:18 pm
Hello. When I try import my exls, I see in logs error: 2018-09-19 12:53:35 - Export/Import: Invalid worksheet names
What I need to do with worksheet names?
Do an Export first, to see the required names and formats of the various worksheets, and then use them for the Import.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am

Who is online

Users browsing this forum: No registered users and 10 guests