Post by aptoautomotive.se » Wed Jan 17, 2018 11:00 pm

Hi,I am using the Export/Import tool, which is awesome and works brilliantly! Many thanks!
Just one question: I can import "Additional Images" for each product by entering the filepath on the tab with the same name, but I can't find any way to enter a filepath for the main image for each product. Am I missing something, or is this simply not supported?
Again, many thanks!!
Cheers,


Posts

Joined
Tue May 30, 2017 10:22 pm

User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by point » Fri Jan 26, 2018 3:11 pm

please help me. I am getting an error when exporting from version 2.3.x to version 3.0.


2018-01-26 6:36:39 - Export/Import: Invalid header in the Products worksheet
2018-01-26 6:36:39 - PHP Unknown: The Twig_Autoloader class is deprecated since version 1.21 and will be removed in 2.0. Use Composer instead. in /home/x1/public_html/system/library/template/Twig/Autoloader.php on line 12
2018-01-26 6:36:39 - PHP Unknown: Using Twig_Autoloader is deprecated since version 1.21. Use Composer instead. in /home/x1/public_html/system/library/template/Twig/Autoloader.php on line 30
2018-01-26 6:36:39 - PHP Unknown: Using Twig_Autoloader is deprecated since version 1.21. Use Composer instead. in /home/x1/public_html/system/library/template/Twig/Autoloader.php on line 30
2018-01-26 6:36:39 - PHP Unknown: Using Twig_Autoloader is deprecated since version 1.21. Use Composer instead. in /home/x1/public_html/system/library/template/Twig/Autoloader.php on line 30
2018-01-26 6:36:39 - PHP Unknown: Using Twig_Autoloader is deprecated since version 1.21. Use Composer instead. in /home/x1/public_html/system/library/template/Twig/Autoloader.php on line 30

Newbie

Posts

Joined
Fri Jan 26, 2018 3:09 pm

Post by JNeuhoff » Sat Jan 27, 2018 9:31 pm

The header for the 'Products' worksheet, and possibly for other worksheets, will be slightly different between different OpenCart versions. Do an Export first off your new OC 3.x, and then use the resulting worksheet to paste the old data into it's worksheets, and then import.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by lindsey80 » Mon Feb 05, 2018 4:49 am

Hello,

I have a fresh current install of opencart. I have exported a test product shown on line 1 of the spreadsheet and entered a sample of my products below. I have tried importing with product_id blank and also with numbers filled in. I can't find any instructions to tell you what you need to fill in but I can't get the import to work. I've also attached the error log, any help will be greatly appreciated!

Attachments

Sheet Imported


Newbie

Posts

Joined
Fri Feb 02, 2018 9:57 pm

Post by lindsey80 » Tue Feb 06, 2018 1:09 am

Hello,

I have tried to import via ocs & xls and am now getting this error

Error: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ''P0710D28',0,'P0710D28',1,10.99,0,NOW(),NOW(),NOW(),0.079,1,1,0,0,0,0,0,'1','1',' at line 1
Error No: 1064
INSERT INTO `oc77_product` (`product_id`,`quantity`,`sku`,`upc`,`ean`,`jan`,`isbn`,`mpn`,`location`,`stock_status_id`,`model`,`manufacturer_id`,`image`,`shipping`,`price`,`points`,`date_added`,`date_modified`,`date_available`,`weight`,`weight_class_id`,`status`,`tax_class_id`,`viewed`,`length`,`width`,`height`,`length_class_id`,`sort_order`,`subtract`,`minimum`) VALUES (51,50,'','','','','','','',,'P0710D28',0,'P0710D28',1,10.99,0,NOW(),NOW(),NOW(),0.079,1,1,0,0,0,0,0,'1','1','1','1');

I posted last night but it hasn't been approved yet?? I tried importing xlxs and that wouldn't work either. This is slightly frustrating as I have moved over from zen cart and would like to just import my products.

Thanks in advance

Newbie

Posts

Joined
Fri Feb 02, 2018 9:57 pm

Post by Umpire_1 » Tue Feb 06, 2018 11:07 am

Thanks for sharing this tool.

I'm trying to export data from a 1.5.6.4 site and import it into a 2.3.0.2 site. On the most recent version I installed the tool correctly. However, on my older 1.5.6.4 site I don't see "tool/export_import" in the user group permission selector menus. I have VQMod installed and I made sure to download the correct 1.5.x extension version, what can I do to fix this?

Newbie

Posts

Joined
Sun Feb 04, 2018 7:42 am

Post by JNeuhoff » Tue Feb 06, 2018 9:47 pm

Umpire_1 wrote:
Tue Feb 06, 2018 11:07 am
Thanks for sharing this tool.

I'm trying to export data from a 1.5.6.4 site and import it into a 2.3.0.2 site. On the most recent version I installed the tool correctly. However, on my older 1.5.6.4 site I don't see "tool/export_import" in the user group permission selector menus. I have VQMod installed and I made sure to download the correct 1.5.x extension version, what can I do to fix this?
Most likely the files weren't uploaded to the correct folders. Do you have a 'admin/model/tool/export_import.php', or a 'admin/controller/tool/export_import.php' file on your OpenCart server?

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by iontronix » Wed Feb 07, 2018 1:07 am

JNeuhoff wrote:
Wed Jan 17, 2018 11:17 pm
The main image path goes into the 'Products' sheet, see column 'image_name'.
hi there
i tried this and placed the path in the 'products" sheet in the column 'image_name', but when it imports there is still a blank main image. i have rechecked my paths and the images are all correct and in the correct folder, but no luck... the additional images show fine though.
please help
kind regards

Newbie

Posts

Joined
Fri Mar 28, 2014 4:27 am

Post by Umpire_1 » Wed Feb 07, 2018 7:19 am

JNeuhoff wrote:
Tue Feb 06, 2018 9:47 pm
Umpire_1 wrote:
Tue Feb 06, 2018 11:07 am
Thanks for sharing this tool.

I'm trying to export data from a 1.5.6.4 site and import it into a 2.3.0.2 site. On the most recent version I installed the tool correctly. However, on my older 1.5.6.4 site I don't see "tool/export_import" in the user group permission selector menus. I have VQMod installed and I made sure to download the correct 1.5.x extension version, what can I do to fix this?
Most likely the files weren't uploaded to the correct folders. Do you have a 'admin/model/tool/export_import.php', or a 'admin/controller/tool/export_import.php' file on your OpenCart server?
Thanks for the help. The problem was I'd renamed my admin folder so the /admin files didn't go in the right place.

EDIT: stupid question but where am I supposed to access the tool? Having enabled the permissions I don't see it under the System dropdown. Is this something to do with my renamed admin folder or is it located somewhere else?

Newbie

Posts

Joined
Sun Feb 04, 2018 7:42 am

Post by JNeuhoff » Wed Feb 07, 2018 11:34 pm

Umpire_1 wrote:
Wed Feb 07, 2018 7:19 am
Thanks for the help. The problem was I'd renamed my admin folder so the /admin files didn't go in the right place.

EDIT: stupid question but where am I supposed to access the tool? Having enabled the permissions I don't see it under the System dropdown. Is this something to do with my renamed admin folder or is it located somewhere else?
It should be under the 'System > Tools > Export/Import' menu. If you renamed your admin foldder, it may break a number of 3rd party extensions, and you may end up having to update your VQmod and/or OCmod XML files accordingly, including the ones for the Export/Import tool.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Umpire_1 » Fri Feb 09, 2018 6:59 am

JNeuhoff wrote:
Wed Feb 07, 2018 11:34 pm
Umpire_1 wrote:
Wed Feb 07, 2018 7:19 am
Thanks for the help. The problem was I'd renamed my admin folder so the /admin files didn't go in the right place.

EDIT: stupid question but where am I supposed to access the tool? Having enabled the permissions I don't see it under the System dropdown. Is this something to do with my renamed admin folder or is it located somewhere else?
It should be under the 'System > Tools > Export/Import' menu. If you renamed your admin foldder, it may break a number of 3rd party extensions, and you may end up having to update your VQmod and/or OCmod XML files accordingly, including the ones for the Export/Import tool.
Thanks again, I got it working by changing "/admin" to my custom folder name in the XML file. I was then able to export my categories and products and import them on the new site.

However, for some reason I can't view these categories and products in the backend, although they show on the frontend. In categories I see "text_no_results" and it gives the option to go to the second page: https://i.imgur.com/s1I0eoV.png and it's the same deal in products. When I try and add a new category/product it works (shows in the frontend), but doesn't show up in the backend. Note that originally I did "update/add data" imports and when it worked I redid the imports but checked the overwrite button to delete the test data. Apart from a few modifications this is a clean install of 2.3.0.2.

I've tried refreshing the modifications cache and doing a hard refresh of my browser, how can I fix this?

Newbie

Posts

Joined
Sun Feb 04, 2018 7:42 am

Post by Sandman_82 » Tue Feb 13, 2018 4:44 am

Hi,

I am having the repeat of an issue which was previously fixed by OpenCart support by upgrading the export/import tool (ticket #107308) but I am unable to update the tool using the prescribed method for the installer.

This issue i get when i try to export (I have tried various options) is that i get the following error:
This site can’t be reached
The web page at http://www.sitename.co.uk/admin/index.p ... Aanncq3iiC might be temporarily down or it may have moved permanently to a new web address.
ERR_INVALID_RESPONSE

As per the above ticket this was resolved by updating the Export/ Import tool. I have tried this via the Extension Installer but I get a server error message. I have given the error log details below.

Error log shows:
2018-02-10 22:07:44 - PHP Warning: set_time_limit(): Cannot set max execution time limit due to system policy in /customers/2/c/b/sitename.co.uk/httpd.www/admin/model/tool/export_import.php on line 6654

I did log this with OpenCart support again but they advised me that the developer prefers to have messages posted here. Any help would be gratefully appreciated.

Thanks.

Newbie

Posts

Joined
Sat Feb 18, 2017 10:48 pm

Post by JNeuhoff » Tue Feb 13, 2018 10:16 pm

Just comment out the offending line. Or better, switch to a decent webhost, because yours seem to have an overly restrictive PHP setup. Also, do the Export/Import in smaller batches to avoid potential memory or timeout issues.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Sandman_82 » Sun Feb 18, 2018 8:59 pm

Hi JNeuhoff,

I have tried to comment out the line and i get the same error, the error comes within 5 seconds so it doesn't even seem to reach the 1800 second limit that was set. I understand your comments about the provider and I will take them on-board at renewal unfortunately it would be some upheaval to migrate to a new provider now. I have also tried to export one item but the export still fails.

Previously you have assisted and updated the Export/ Import tool so i tried this via the Extension Installer but i get a "Internal Server Error" message and the install stops. Any help or guidance would be most appreciated.

Thanks

Newbie

Posts

Joined
Sat Feb 18, 2017 10:48 pm
Who is online

Users browsing this forum: No registered users and 6 guests