Post by figs » Thu Nov 09, 2017 3:34 am

Hello, having an issue on import. It will not import the tags column. And it wiped out all the existing data. Any advice? This is on an incremental upload. EDIT: just tried the erase all data option as well.
just upgraded to 3.19 but same issue happened in 3.17 or whatever I had installed previously.

Edit, if I look in SQL, the tags are there, they just do not show up in the products on edit, nor do they export out the next time. Also search does not find teh terms (the whole reason I use tags to begin with.)

Mike

Newbie

Posts

Joined
Fri May 30, 2014 12:37 am

Post by JNeuhoff » Thu Nov 09, 2017 9:47 pm

figs wrote:
Thu Nov 09, 2017 3:34 am
Hello, having an issue on import. It will not import the tags column. And it wiped out all the existing data. Any advice? This is on an incremental upload. EDIT: just tried the erase all data option as well.
just upgraded to 3.19 but same issue happened in 3.17 or whatever I had installed previously.

Edit, if I look in SQL, the tags are there, they just do not show up in the products on edit, nor do they export out the next time. Also search does not find teh terms (the whole reason I use tags to begin with.)

Mike
What is your OpenCart version? Was it a fresh install, or an upgrade from a previous version?

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by figs » Tue Nov 14, 2017 4:27 am

JNeuhoff wrote:
Thu Nov 09, 2017 9:47 pm
figs wrote:
Thu Nov 09, 2017 3:34 am
Hello, having an issue on import. It will not import the tags column. And it wiped out all the existing data. Any advice? This is on an incremental upload. EDIT: just tried the erase all data option as well.
just upgraded to 3.19 but same issue happened in 3.17 or whatever I had installed previously.

Edit, if I look in SQL, the tags are there, they just do not show up in the products on edit, nor do they export out the next time. Also search does not find teh terms (the whole reason I use tags to begin with.)

Mike
What is your OpenCart version? Was it a fresh install, or an upgrade from a previous version?
It was a fresh install on a new server. OC 2.3.0.2 I have a test site that you can see the issue on. We have a custom product, quote, sales tool that allows us to make quotes but all of our mods are via OCmod. No errors logged via the process.

Newbie

Posts

Joined
Fri May 30, 2014 12:37 am

Post by JNeuhoff » Wed Nov 15, 2017 12:20 am

figs wrote:
Tue Nov 14, 2017 4:27 am
It was a fresh install on a new server. OC 2.3.0.2 I have a test site that you can see the issue on. We have a custom product, quote, sales tool that allows us to make quotes but all of our mods are via OCmod. No errors logged via the process.
Send me a PM with your FTP and OpenCart admin login details, and I can take a quick look at it.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by JNeuhoff » Wed Nov 15, 2017 1:30 am

JNeuhoff wrote:
Wed Nov 15, 2017 12:20 am
figs wrote:
Tue Nov 14, 2017 4:27 am
It was a fresh install on a new server. OC 2.3.0.2 I have a test site that you can see the issue on. We have a custom product, quote, sales tool that allows us to make quotes but all of our mods are via OCmod. No errors logged via the process.
Send me a PM with your FTP and OpenCart admin login details, and I can take a quick look at it.
I took a look at your OpenCart 2.3.0.2 server. There should be no 'oc_product_tag' DB table, that one was used in previous versions, but not in 2.3.0.2. Just remove this DB table, and then re-import your products including the tags again, and the tags should correctly end up into the 'oc_product_description.tag' field.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by eaglecomr » Thu Nov 30, 2017 6:41 pm

OpenCart Version 3.0.2.0
opencart-3-x-export-import-multilingual-3-19

Getting following errors. Plz suggest what should be done. I am exporting the data and importing the same file without any modifications to test if any errors are there.


2017-10-30 17:37:53 - PHP Warning: unlink(/home/delhibar/ocartdata/storage/cache/cache.catalog.language.1509384131): No such file or directory in /home/delhibar/public_html/system/library/cache/file.php on line 17
2017-10-30 17:37:53 - PHP Warning: Cannot modify header information - headers already sent by (output started at /home/delhibar/public_html/system/framework.php:271) in /home/delhibar/public_html/catalog/controller/startup/session.php on line 25
2017-10-30 17:37:53 - PHP Warning: Cannot modify header information - headers already sent by (output started at /home/delhibar/public_html/system/framework.php:271) in /home/delhibar/ocartdata/storage/modification/catalog/controller/startup/startup.php on line 104
2017-10-30 17:37:53 - PHP Warning: Cannot modify header information - headers already sent by (output started at /home/delhibar/public_html/system/framework.php:271) in /home/delhibar/ocartdata/storage/modification/catalog/controller/startup/startup.php on line 162
2017-11-30 10:16:31 - Export/Import: Worksheet 'ProductSEOKeywords' cannot use product_id '35' because it is not listed in worksheet 'Products'!
2017-11-30 10:16:31 - PHP Unknown: The Twig_Autoloader class is deprecated since version 1.21 and will be removed in 2.0. Use Composer instead. in /home/delhibar/public_html/system/library/template/Twig/Autoloader.php on line 12
2017-11-30 10:16:31 - PHP Unknown: Using Twig_Autoloader is deprecated since version 1.21. Use Composer instead. in /home/delhibar/public_html/system/library/template/Twig/Autoloader.php on line 30
2017-11-30 10:16:31 - PHP Unknown: The Twig_Function_Function class is deprecated since version 1.12 and will be removed in 2.0. Use Twig_SimpleFunction instead. in /home/delhibar/public_html/system/library/template/Twig/Function/Function.php on line 13
2017-11-30 10:16:31 - PHP Unknown: The Twig_Function class is deprecated since version 1.12 and will be removed in 2.0. Use Twig_SimpleFunction instead. in /home/delhibar/public_html/system/library/template/Twig/Function.php on line 12
2017-11-30 10:16:31 - PHP Unknown: Passing a name as a first argument to the Twig_Environment::addFunction method is deprecated since version 1.21. Pass an instance of "Twig_SimpleFunction" instead when defining function "staticCall". in /home/delhibar/public_html/system/library/template/Twig/Environment.php on line 1100
2017-11-30 10:16:31 - PHP Unknown: Using Twig_Autoloader is deprecated since version 1.21. Use Composer instead. in /home/delhibar/public_html/system/library/template/Twig/Autoloader.php on line 30
2017-11-30 10:16:31 - PHP Unknown: Passing a name as a first argument to the Twig_Environment::addFunction method is deprecated since version 1.21. Pass an instance of "Twig_SimpleFunction" instead when defining function "staticCall". in /home/delhibar/public_html/system/library/template/Twig/Environment.php on line 1100
2017-11-30 10:16:31 - PHP Unknown: Using Twig_Autoloader is deprecated since version 1.21. Use Composer instead. in /home/delhibar/public_html/system/library/template/Twig/Autoloader.php on line 30
2017-11-30 10:16:31 - PHP Unknown: Passing a name as a first argument to the Twig_Environment::addFunction method is deprecated since version 1.21. Pass an instance of "Twig_SimpleFunction" instead when defining function "staticCall". in /home/delhibar/public_html/system/library/template/Twig/Environment.php on line 1100
2017-11-30 10:16:31 - PHP Unknown: Using Twig_Autoloader is deprecated since version 1.21. Use Composer instead. in /home/delhibar/public_html/system/library/template/Twig/Autoloader.php on line 30
2017-11-30 10:16:31 - PHP Unknown: Passing a name as a first argument to the Twig_Environment::addFunction method is deprecated since version 1.21. Pass an instance of "Twig_SimpleFunction" instead when defining function "staticCall". in /home/delhibar/public_html/system/library/template/Twig/Environment.php on line 1100

Newbie

Posts

Joined
Mon Sep 10, 2012 9:19 pm

Post by JNeuhoff » Thu Nov 30, 2017 9:34 pm

@ eaglecomr : The only relevant message is this one:

017-11-30 10:16:31 - Export/Import: Worksheet 'ProductSEOKeywords' cannot use product_id '35' because it is not listed in worksheet 'Products'!

It is clear enough: Either add a line in the 'Products' worksheet for product_id=35, or delete this line form the 'ProductSEOKeywords'.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by optik » Sun Dec 03, 2017 4:50 pm

The extension has installed correctly,according to instructions,but it does not appear in the menu.
http://prntscr.com/hiei90
http://prntscr.com/hieiqw
Opencart Version 3.0.2.0 (rs.2)

Newbie

Posts

Joined
Sun Dec 03, 2017 3:07 pm

Post by JNeuhoff » Tue Dec 05, 2017 12:51 am

optik wrote:
Sun Dec 03, 2017 4:50 pm
The extension has installed correctly,according to instructions,but it does not appear in the menu.
http://prntscr.com/hiei90
http://prntscr.com/hieiqw
Opencart Version 3.0.2.0 (rs.2)
No, it hasn't been installed correctly. Please follow all the steps of the installation instruction.

User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by MAD King » Thu Dec 07, 2017 12:38 am

Will all images be exported with links to them?

New member

Posts

Joined
Wed Nov 19, 2014 10:55 pm

Post by JNeuhoff » Thu Dec 07, 2017 7:58 pm

MAD King wrote:
Thu Dec 07, 2017 12:38 am
Will all images be exported with links to them?
Only image names are exported, not the actual image files.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by MAD King » Thu Dec 07, 2017 10:31 pm

and no link to the images as well?

New member

Posts

Joined
Wed Nov 19, 2014 10:55 pm

Post by JNeuhoff » Thu Dec 07, 2017 11:01 pm

MAD King wrote:
Thu Dec 07, 2017 10:31 pm
and no link to the images as well?
I don't understand your question. Image names are specified as paths relative to DIR_IMAGE in the worksheet's image column, with values like 'catalog/demo/iphone_1.jpg' etc.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by MAD King » Thu Dec 07, 2017 11:07 pm

Link to images:

https://www.domain.com/images/catalog/demo/iphone_1.jpg

Exporting to csv to import into another program with with full image path.

New member

Posts

Joined
Wed Nov 19, 2014 10:55 pm
Who is online

Users browsing this forum: No registered users and 8 guests