Post by pm-netti » Fri Oct 14, 2016 7:29 pm

user123 wrote:Opencart 2.3.0.2 ei vaihdu kieli, niin onko tämä oikea asetus tähän versioon Locale: sv_SE.UTF-8,sv_SE,swedish?
Jes.
Versioissa 2.3 ja 2.2 on se erikoisuus, että tietyntyppinen päivitys ei vaihda uutta kielikoodia tauluun setting. Jotta kielihomman saa toimimaan, setting tauluun täytyy saada vaihdettu config_language ja config_admin_language value-sarakkeeseen uusi kielikoodi, joka on sama kuin hakemiston nimi, esim. fi-fi. Tämän joutuu tekemään manuaalisesti, jos ei käytä jotain automaattista päivitysohjelmaa.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by tkhki » Mon Nov 21, 2016 3:27 am

Asensin version 2.3.0.2 ja suomen kielen siihen. Jostain syystä Suomen lippu puuttuu ja osa backendin käännöksistä. Vasemman reunan palkki on vielä ainakin enkuksi. Oonko ryssiny asennuksessa vai pittääkö vielä suomennella ite. Lisäsin myös admin_language_fi-FI kansioon lipun kuvan fi-FI.png, mut se ei näyttäny auttavan. Osaisko joku jeesata. Kiitti! Liitteenä kuva jossa näkyy ongelma. :)


edit: Ilmeisesti jotain väärin tuli asennettua..Poistin kielipaketin. Saakos kielipaketin toimimaan 2.3.0.2 versiossa. En oikein ymmärtänyt edellä olevista kommenteista?

Attachments

lippu puuttuu ja osa käännöksistä.JPG

lippu puuttuu ja osa käännöksistä.JPG (53.83 KiB) Viewed 704 times


Newbie

Posts

Joined
Mon Nov 21, 2016 3:19 am

Post by pm-netti » Mon Nov 28, 2016 5:02 am

tkhki wrote:Asensin version 2.3.0.2 ja suomen kielen siihen. Jostain syystä Suomen lippu puuttuu ja osa backendin käännöksistä. Vasemman reunan palkki on vielä ainakin enkuksi. Oonko ryssiny asennuksessa vai pittääkö vielä suomennella ite. Lisäsin myös admin_language_fi-FI kansioon lipun kuvan fi-FI.png, mut se ei näyttäny auttavan. Osaisko joku jeesata. Kiitti! Liitteenä kuva jossa näkyy ongelma. :)


edit: Ilmeisesti jotain väärin tuli asennettua..Poistin kielipaketin. Saakos kielipaketin toimimaan 2.3.0.2 versiossa. En oikein ymmärtänyt edellä olevista kommenteista?
Oliko sinulla hakemiston nimi, kielitiedoston nimi ja kuvatiedoston nimi sama eli "fi-FI"? Kannattaa katsoa mallia hakemistosta language/en-gb.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by tkhki » Mon Nov 28, 2016 5:25 pm

pm-netti wrote:
tkhki wrote:Asensin version 2.3.0.2 ja suomen kielen siihen. Jostain syystä Suomen lippu puuttuu ja osa backendin käännöksistä. Vasemman reunan palkki on vielä ainakin enkuksi. Oonko ryssiny asennuksessa vai pittääkö vielä suomennella ite. Lisäsin myös admin_language_fi-FI kansioon lipun kuvan fi-FI.png, mut se ei näyttäny auttavan. Osaisko joku jeesata. Kiitti! Liitteenä kuva jossa näkyy ongelma. :)


edit: Ilmeisesti jotain väärin tuli asennettua..Poistin kielipaketin. Saakos kielipaketin toimimaan 2.3.0.2 versiossa. En oikein ymmärtänyt edellä olevista kommenteista?
Oliko sinulla hakemiston nimi, kielitiedoston nimi ja kuvatiedoston nimi sama eli "fi-FI"? Kannattaa katsoa mallia hakemistosta language/en-gb.
Huomasin sinun sivuilta kielipaketin, latasin sen, muutin muutaman kansion fi-fi ja nyt korjaantu tuo kuvan lippu ongelma, mut sivussa oleva paneelin tekstit on enkuksi edelleen. Se ei oo suuri ongelma, jos nyt muut pelaa, mut kuuluisiko ne olla suomennettuna? Kiitti!

Newbie

Posts

Joined
Mon Nov 21, 2016 3:19 am

Post by pm-netti » Mon Nov 28, 2016 7:21 pm

tkhki wrote:
pm-netti wrote:
tkhki wrote:Asensin version 2.3.0.2 ja suomen kielen siihen. Jostain syystä Suomen lippu puuttuu ja osa backendin käännöksistä. Vasemman reunan palkki on vielä ainakin enkuksi. Oonko ryssiny asennuksessa vai pittääkö vielä suomennella ite. Lisäsin myös admin_language_fi-FI kansioon lipun kuvan fi-FI.png, mut se ei näyttäny auttavan. Osaisko joku jeesata. Kiitti! Liitteenä kuva jossa näkyy ongelma. :)


edit: Ilmeisesti jotain väärin tuli asennettua..Poistin kielipaketin. Saakos kielipaketin toimimaan 2.3.0.2 versiossa. En oikein ymmärtänyt edellä olevista kommenteista?
Oliko sinulla hakemiston nimi, kielitiedoston nimi ja kuvatiedoston nimi sama eli "fi-FI"? Kannattaa katsoa mallia hakemistosta language/en-gb.
Huomasin sinun sivuilta kielipaketin, latasin sen, muutin muutaman kansion fi-fi ja nyt korjaantu tuo kuvan lippu ongelma, mut sivussa oleva paneelin tekstit on enkuksi edelleen. Se ei oo suuri ongelma, jos nyt muut pelaa, mut kuuluisiko ne olla suomennettuna? Kiitti!
Moi. Se oli paketti, jonka "kokoamisen" olin aloittanut joskus elokuussa ja se oli jäänyt kesken. Olen nyt siirtänyt ne menun tekstit tiedostosta menu.php tiedostoon column_left.php ja lisännyt pari muuta tiedostoa. Tämä on vielä puutteellinen. Joku voi keksiä, mitä uupuu.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland
Who is online

Users browsing this forum: No registered users and 4 guests