Post by danielstv » Fri Mar 08, 2013 5:30 pm

Hi, I'm having a bit of trouble getting the Realex Redirect Payment module to work. I have it uploaded to the correct place and have enabled the app and put in the relevant details and all is okay.

It lets me put through a payment (test) but the redirect back to the website just comes up with this error message: "Your transaction has been successful but there was a problem connecting back to the merchant's web site.
Please contact the merchant and advise them that you received this error message. Thank you."

I have given realex a ring with the correct redirect danielstv-home.co.uk/catalog/controller/payment/realex_callback.php and I have had them double check they have it correct several times and have also checked to make sure the pathway is correct.

On the readme that comes with the module it says this:

How to set up your RealEx/Global Iris Account:
=====================================
1. You must contact RealEx Tech Support and have them set your response url in your realex account to:
http://www.yoursite.com/catalog/control ... llback.php
(be sure to change yoursite.com to your real site and add any subfolders if necessary)
2. Set the Response Method to "POST"

I haven't set my Response Method to "POST" and i'm not sure how to go about doing this so it could well be the problem? could anyone advise me on how to set the Response Method to "POST" or if there is another obvious problem that I have overlooked.

Any help would be greatly appreciated.

Newbie

Posts

Joined
Fri Mar 08, 2013 5:20 pm

Post by cjsystems » Mon Mar 11, 2013 10:57 pm

Hi,

Did you find an answer to your problem?

We are also having the same issue. In fact we are also having the same issue with a couple Oscommerce sites as of a few weeks ago.

Our new site is opencart, but gets the same problem. Like yourself I am 100% sure that the response URL is correct. Our server hosts say that nothing as changes, Realex say that nothing has changed, yet we seem to not be able to use Realex in any of our stores for the last 3 weeks!!

Thanks.

Newbie

Posts

Joined
Mon Mar 11, 2013 10:48 pm

Post by RealexSupport » Wed Mar 13, 2013 1:18 am

Hi danielstv and cjsystems,

My name is Alan, I look after Shopping Cart integrations for Realex Payments and Global Iris.
I'd like to assist you both on the issues you are having with getting the response page to display.
Could you contact me on ala***********************com or alternatively supply me with your contact details so I can get in touch and troubleshoot this with you.

Kind regards,

Alan
Last edited by RealexSupport on Wed Nov 13, 2013 6:08 pm, edited 1 time in total.

Channel Support
Realex Payments


User avatar
Newbie

Posts

Joined
Wed Mar 13, 2013 12:58 am

Post by jllwton » Wed May 29, 2013 7:15 pm

Did you manage to get this fixed? I'm having exactly the same issue.
???

Newbie

Posts

Joined
Fri Aug 19, 2011 8:04 pm

Post by RealexSupport » Thu May 30, 2013 4:16 pm

Hi jllwton,

One of the above cases got in touch and we have fixed this issue.
Could you email me your merchant id and I'll be happy to run some testing to troubleshoot this with you?

Kind regards,

Alan

Channel Support
Realex Payments


User avatar
Newbie

Posts

Joined
Wed Mar 13, 2013 12:58 am

Post by KW2912 » Tue Nov 12, 2013 8:56 pm

Same problem here. Did anyone ever find out where you are supposed to change the response to POST or indeed is it even myself or Realex that this concerns? I am trying to set up payments via Elavon and can't seem to get it working - I've a sneaky feeling it is linked to the POST thing as I haven't been able to set this up??

Can anyone help?

Newbie

Posts

Joined
Mon Mar 11, 2013 11:17 pm

Post by RealexSupport » Wed Nov 13, 2013 6:14 pm

Hi KW2912,

Could you want PM me your number/e-mail and I can troubleshoot this with you?
Or if more convenient please ask your account manager to escalate this to me I can get in touch that way.

Kind regards,

Alan

Channel Support
Realex Payments


User avatar
Newbie

Posts

Joined
Wed Mar 13, 2013 12:58 am

Post by topsuppz » Thu Sep 01, 2016 2:35 pm

Hi.

We are having the same problem but Realex support team is not being able to help. All they do is say check with your webdeveloper. I've checked and we couldn't find anything wrong with the server or opencart. I've triple checked and the return url pathway is correct.

What is weird is that the payments are being registered correctly. What I mean by that is that we've done a test and the client's account is being debited and our bank account is being credit, however we can't register any order on Opencart because of this error. Can anyone please help?

Newbie

Posts

Joined
Thu Sep 01, 2016 2:29 pm

Post by RealexSupport » Wed Sep 07, 2016 3:56 pm

Hi Topsuppz,

Could you please send me a PM with your Realex Merchant ID and your email so I can troubleshoot this with you?

Kind Regards
Borja

Channel Support
Realex Payments


User avatar
Newbie

Posts

Joined
Wed Mar 13, 2013 12:58 am

Post by Abstruse21 » Wed Oct 12, 2016 5:29 pm

Again.. same issue.

"Your transaction has been successful but there was a problem connecting back to the merchant's web site.
Please contact the merchant and advise them that you received this error message. Thank you."

Any help appreciated

Newbie

Posts

Joined
Mon Sep 26, 2016 8:15 pm

Post by stayhi128 » Fri Jan 13, 2017 12:52 am

I am having problems with Realex. It is this same '511' issue, reported here as far back as 2013. Since December 19th, our clients have received the following message:

"Your transaction has been successful but there was a problem connecting back to the merchant's web site.
Please contact the merchant and advise them that you received this error message. Thank you."

We did not receive our usual, 'You have an order', email and no entry appears in OpenCart admin. So we have to go into the Global Iris site, where we can see sums of money are pending. It does advise who this is from, so we then go back into OpenCart, find the client's contact details and somewhat sheepishly, 'phone them. When we tell them that we can see the sum of money, but not what they ordered, their immediate thought is that their security has been compromised. We assure them they their details are safe, but it does nothing to encourage them to purchase from us.

Now the Realex people in Dublin are very pleaseant to deal with, but they simply do not know what causes this. Today, they emailed us, saying:

'The issue has been raised to priority as there are a small handful of merchant who are experiencing this issue.'

One can only wonder how many is a 'small handful' . thousands probably.

But nobody seems able to advise when this is going to be fixed and we are beginning to wonder whether we should start talking to another payment provider. What we have heard about Worldpay is less than reassuring. I am told Sagepay have an extension pre-installed in Opencart. Is that so please? And could anyone recommend any other payment providers.

Being nearer to eighty than seventy, I have long passed the time when i get stressed out by problems like this. But it is making our small company look ridiculous. Has anyone any thoughts please?

Newbie

Posts

Joined
Sat Jan 07, 2017 6:59 am

Post by salmanjav » Fri Aug 24, 2018 10:17 am

RealexSupport wrote:
Wed Mar 13, 2013 1:18 am
Hi danielstv and cjsystems,

My name is Alan, I look after Shopping Cart integrations for Realex Payments and Global Iris.
I'd like to assist you both on the issues you are having with getting the response page to display.
Could you contact me on ala***********************com or alternatively supply me with your contact details so I can get in touch and troubleshoot this with you.

Kind regards,

Alan
Hi,
I am having same issue and need your help. Can you please support?.

Newbie

Posts

Joined
Tue Mar 27, 2018 9:02 am
Who is online

Users browsing this forum: No registered users and 5 guests