Post by Sweetpete » Fri Dec 01, 2017 3:43 pm

Hi, I am working on a new site and want to use Sagepay. On my old site (1.5.6.4) I installed a Sagepay V3 extension and it worked fine but I can not find the extension for 3.0.2.0.
The extensions that are included are Sagepay Direct and Sagepay Server but they seem very complicated and I'm not sure how to use them.
Sage Payment Solutions (US) extension looks right but I am in the UK.
Can anyone help? Many thanks.

Newbie

Posts

Joined
Wed Jun 05, 2013 12:10 am

Post by ADD Creative » Mon Dec 04, 2017 7:16 pm

Looks like Sage Pay Form was removed in version 2 onwards. Sage Pay Server would be the closest (may have different PCI Compliance requirements https://www.sagepay.co.uk/our-payment-s ... compliance). Sage Pay US would not work as it collects card details on your site and submits to a different URL.

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by CSR » Fri Dec 15, 2017 12:55 am

As stated above there is no longer SagePay Form integration in 3.0.2.0, just Sagepay Server or Direct.

This link may help:
https://www.sagepay.co.uk/support/12/36
Lots of sections for reference including Setting Up Your integration....

I am in the process of going through the same thing on a website. The current set up uses SagePay Form integration and it looks like I will have to switch over to Server and test it etc.

According to SagePay with effect from 31 March 2018 any website using Server or Direct will need to use TLS 1.2

CSR
Newbie

Posts

Joined
Sun Mar 19, 2017 3:12 am

Post by daveyoi » Fri Dec 15, 2017 8:05 pm

If you use sagepay server without the storage of credit cards - that is the equivalent of the old sagepay v3 form integration.

Storing cards and using Sagepay Direct - require tighter PCI compliance above just a https certificate.

Image
Tristar Web Solutions


New member

Posts

Joined
Sun Oct 05, 2014 2:38 am
Who is online

Users browsing this forum: No registered users and 6 guests