Post by johnp » Wed Jun 06, 2018 11:32 pm

Can anyone help please?

I've installed the official update currency patch on my 1.5.6.4 and 1.5.6.5rc1 sites and it doesn't work on either. If I login and log out the currencies other than the default currency get set to 0.000000. I'm using VQMOD 2.6.3.

https://www.opencart.com/index.php?rout ... n_id=32694

I get no errors in either the system error log or VQMOD error log.

Any idea as to why anyone?

Opencart 1.5.6.5/Default Theme/VQMOD 2.6.1 lover, user and geek.
Opencart Installs, Fixing, Development Upgrades, Ecommerce, Marketing and More
https://aawadmin.co.uk/ecommerce-and-website-services
https://aawadmin.co.uk


Active Member

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK

Post by IP_CAM » Thu Jun 07, 2018 1:30 am

Update Currency Patch:
https://www.opencart.com/index.php?rout ... n_id=32694
Well, that free OC 'House' Extension is already out of date again, as it looks,
get more info on this here:
https://api.fixer.io/latest?base=
https://github.com/fixerAPI/fixer#readme
---
But this one seems to work, you just have to get a free API Key,
it still produces a nasty error log entry, but it still does the Job,
as it looks. I posted the error on the Ext.Page, so, we'll see, if the
fellow Creator has a solution for this.
Currency Rates Fix
https://www.opencart.com/index.php?rout ... n_id=32352
---
Ernie
---
Image

Attachments

currency_update_oc_1565.jpg

currency_update_oc_1565.jpg (90.92 KiB) Viewed 723 times


For Sale: Top URL's, including an OpenCart V-Pro Shop!
A wide range of matching Designs can be seen here: http://www.opencart.li
For Information on URL's offered, please contact me at: jti@jacob.ch
Hundreds of Mods in 380+ Repositories for OC v.1.5.x - v.2.3.x
to be found on my Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by johnp » Thu Jun 07, 2018 3:37 am

Thanks Ernie but I can't get that to work either. It installs ok but when I click the update currencies now button I get a Warning: Currency update failed! message. I'm using alphavantage an have an API key. I also can't get debug to stay enabled. Any ideas?

One question. When using this extension do you need the Opencart built in auto currency update set to yes or no in the system settings menu?

I'm stumped.

Opencart 1.5.6.5/Default Theme/VQMOD 2.6.1 lover, user and geek.
Opencart Installs, Fixing, Development Upgrades, Ecommerce, Marketing and More
https://aawadmin.co.uk/ecommerce-and-website-services
https://aawadmin.co.uk


Active Member

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK

Post by IP_CAM » Thu Jun 07, 2018 4:23 am

Well, did you download the latest Version ?
With the former version, it did not work here either...
I had the Admin Setting on and off, but it did not make a difference.
Ernie

For Sale: Top URL's, including an OpenCart V-Pro Shop!
A wide range of matching Designs can be seen here: http://www.opencart.li
For Information on URL's offered, please contact me at: jti@jacob.ch
Hundreds of Mods in 380+ Repositories for OC v.1.5.x - v.2.3.x
to be found on my Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by johnp » Thu Jun 07, 2018 4:32 am

I did indeed download the latest version. I've just done it again to be sure. Still no luck. :-(

Opencart 1.5.6.5/Default Theme/VQMOD 2.6.1 lover, user and geek.
Opencart Installs, Fixing, Development Upgrades, Ecommerce, Marketing and More
https://aawadmin.co.uk/ecommerce-and-website-services
https://aawadmin.co.uk


Active Member

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK

Post by johnp » Thu Jun 07, 2018 4:38 am

Just a thought. The server I'm on is running PHP Version 5.3.28. Could that be causing the problem?

Opencart 1.5.6.5/Default Theme/VQMOD 2.6.1 lover, user and geek.
Opencart Installs, Fixing, Development Upgrades, Ecommerce, Marketing and More
https://aawadmin.co.uk/ecommerce-and-website-services
https://aawadmin.co.uk


Active Member

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK

Post by johnp » Thu Jun 07, 2018 4:45 am

I've just tried on an account using PHP Version 5.6.36 and that works using the alphavantage api. Looks like that may be the problem.

Opencart 1.5.6.5/Default Theme/VQMOD 2.6.1 lover, user and geek.
Opencart Installs, Fixing, Development Upgrades, Ecommerce, Marketing and More
https://aawadmin.co.uk/ecommerce-and-website-services
https://aawadmin.co.uk


Active Member

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK

Post by johnp » Thu Jun 07, 2018 8:14 pm

I've just had PHP updated on the original site hosting account and it works perfectly. Looks like it needs PHP Version 5.6 to run correctly.

Opencart 1.5.6.5/Default Theme/VQMOD 2.6.1 lover, user and geek.
Opencart Installs, Fixing, Development Upgrades, Ecommerce, Marketing and More
https://aawadmin.co.uk/ecommerce-and-website-services
https://aawadmin.co.uk


Active Member

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK

Post by johnp » Fri Jun 08, 2018 8:10 pm

Ok. Just when things were going great this new error message appeared:

2018-06-08 7:03:04 - PHP Notice: Undefined property: stdClass::$Error Message in /home/public_html/admin/model/module/currency_update.php on line 65

Line 65 and onwards:

if (@is_null($json->{"Error Message"})) {
$value = (float) $json->{"Realtime Currency Exchange Rate"}->{"5. Exchange Rate"};
$value = $comission ? $value + ($value * $comission) : $value;
$this->db->query("UPDATE " . DB_PREFIX . "currency SET value = '" . $this->db->escape($value) . "', date_modified = '" . $this->db->escape(date('Y-m-d H:i:s')) . "' WHERE code = '" . $this->db->escape($code) . "'");
} else {
$this->log('alphavantage error : '.$json->{"Error Message"});
return false;
}
} else {
return false;
}
}

Any ideas anyone. Ernie?

Opencart 1.5.6.5/Default Theme/VQMOD 2.6.1 lover, user and geek.
Opencart Installs, Fixing, Development Upgrades, Ecommerce, Marketing and More
https://aawadmin.co.uk/ecommerce-and-website-services
https://aawadmin.co.uk


Active Member

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK

Post by IP_CAM » Fri Jun 08, 2018 11:41 pm

Well, I still have the same PHP Warning, and I published a Message about it on the extension Page.
But since it still works, I don't really bother about it at the moment...
Ernie

For Sale: Top URL's, including an OpenCart V-Pro Shop!
A wide range of matching Designs can be seen here: http://www.opencart.li
For Information on URL's offered, please contact me at: jti@jacob.ch
Hundreds of Mods in 380+ Repositories for OC v.1.5.x - v.2.3.x
to be found on my Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by johnp » Sat Jun 09, 2018 7:28 am

Thanks Ernie. I've posted on there too.

Opencart 1.5.6.5/Default Theme/VQMOD 2.6.1 lover, user and geek.
Opencart Installs, Fixing, Development Upgrades, Ecommerce, Marketing and More
https://aawadmin.co.uk/ecommerce-and-website-services
https://aawadmin.co.uk


Active Member

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK

Post by IP_CAM » Sun Jun 10, 2018 5:31 am

Well, I hate warnings and errors in my Logs, so, I removed, what needed to be removed,
to at least keep my logs clear, until someone possibly presents a solution. Then, I set the
US$ exchange rate to an UNREAL Value, and then clicked on the Currency Upgrade Button.
It did NOT add a handling value, as set, but it at least presented the correct exchange rate.
But in my next Life, I really wanna be Coder... :-\
Ernie :D
---
Image
---

Attachments

remove_message_lines_to_remove_error_message.jpg

remove_message_lines_to_remove_error_message.jpg (164.07 KiB) Viewed 572 times


For Sale: Top URL's, including an OpenCart V-Pro Shop!
A wide range of matching Designs can be seen here: http://www.opencart.li
For Information on URL's offered, please contact me at: jti@jacob.ch
Hundreds of Mods in 380+ Repositories for OC v.1.5.x - v.2.3.x
to be found on my Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: No registered users and 4 guests