Post by Kristabyte » Fri Aug 04, 2017 1:12 am

Hi everyone

I'm attempting to adjust the color of my order status' on my admin dashboard.. I found a topic that does exactly this, and following the steps exactly it completely crashes my Admin Panel. I get a 500 time-out error only on my Admin panel. I then found a vqmod extension that does the same thing, editing the same files and again, times out my admin panel. I have had no issue installing VQmod extensions in the past, and i'm hoping someone can help me. I've attached the vqmod extension for some help :(

Newbie

Posts

Joined
Fri Aug 04, 2017 1:08 am

Post by IP_CAM » Fri Aug 04, 2017 2:13 am

Well, I made it work, but my unsuccessfull_orders-opencart.xml,
beeing one of my ~55 Admin VqMod Extensions, changed the
VqMod SEARCH-LINE Anchor Content, and so kept the VqMod from work:

Code: Select all

<search position="replace"><![CDATA[
<td class="left"><?php echo $order['status']; ?></td>
]]></search>
to the Search Line Replacement Content of the other VqMod,
so I had to QUICKFIX-change the SEARCH Link Line Content,
to make the color-status VqMod look like this, in all it's SEARCH
Sections:

Code: Select all

<search position="replace"><![CDATA[
<td class="left"><?php if($order['status']){ echo $order['status']; } else { echo '---'; } ?></td>
 ]]></search>
to avoid this VqMod-Manager Error Message:

Code: Select all

REQUEST URI : /shop/admin/index.php?route=sale/order&token=afa ......
MOD DETAILS:
modFile   : /home/jacobch/www/ocshop_li/shop/vqmod/xml/color_status.xml
id        : Color Code
File Name    : admin/view/template/sale/order_list.tpl(0)
VQModObject::applyMod - SEARCH NOT FOUND (ABORTING MOD): <td class="left"><?php echo $order['status']; ?></td>
I also renamed te color-status.xml to zz_color-status.xml, to be INDEXED/LISTED
after the other VqMod, just to make sure, that it will FIND the correct Anchor Link !
---
Meaning, that you have to check in your Extensions, if something ELSE already
uses this VqMod SEARCH ANCHOR TAG Line, and so prevents your VqMod
from doing it's Job:
<td class="left"><?php echo $order['status']; ?></td>
Just to give you some ideas...
Good Luck! ;)
Ernie
---
PS: I changed some colors and added STRONG Tags, to make it more 'visible' for the lower Image :D
---
Image

Attachments

order_listings_colored.jpg

order_listings_colored.jpg (178.07 KiB) Viewed 329 times


Ernie's OpenCart v.1.5.6.5 LIGHT + OpenShop Admin v.1.75 Test Sites
http://www.ebikes.li - http://www.evelo.li - http://www.openshop.li
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by Kristabyte » Fri Aug 04, 2017 2:38 am

Hey thank you for the response -- I added your searchline modification and it doesn't crash my Admin anymore, just.. nothing happens at all -- Here's my updated XML, any ideas??

Newbie

Posts

Joined
Fri Aug 04, 2017 1:08 am

Post by IP_CAM » Fri Aug 04, 2017 3:02 am

well, you should ONLY add/use my Modification line, if you also use this
VqMod, shown below, or it will NOT have any effect ! :laugh:
I just meant it as a sample ! ;)
Ernie

Attachments


Ernie's OpenCart v.1.5.6.5 LIGHT + OpenShop Admin v.1.75 Test Sites
http://www.ebikes.li - http://www.evelo.li - http://www.openshop.li
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: No registered users and 16 guests