Post by Rodesta » Fri Feb 10, 2017 12:08 am

Voor de site www.rodesta.nl is er een SSL certificaat geïnstalleerd.

De volgende acties zijn uitgevoerd:

- SSL aangezet in dashboard

- code toegevoegd .htaccess-bestand
RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^.*$ https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]

-de volgende codes aangepast

in de map ==> config.php (code aangepast onder //https)
// HTTPS
define('HTTPS_SERVER', 'https://www.rodesta.nl/');

in de map ==> /admin/config.php (code aangepast onder //https)
// HTTPS
define('HTTPS_SERVER', 'https://www.rodesta.nl/admin/');
define('HTTPS_CATALOG', 'https://www.rodesta.nl/');

- Zelf handmatig in de database de laatste links aangepast naar HTTPS

Toch worden de URL's van de afbeeldingen nog steeds geladen via HTTP, en niet via HTTPS.

Weet iemand hoe, wat en waar ik dit kan aanpassen zodat de volledige site via HTTPS loopt?

Newbie

Posts

Joined
Thu Feb 09, 2017 3:34 pm

Post by victorj » Fri Feb 10, 2017 6:53 am

neem maar even contact op via pm of via mijn website, verwacht dat er een fout in de config files zit, voor oc 1.5.6.4 is dat zo gefixed.

Koeltechnische deurrubbers eenvoudig online op maat bestellen.
Alle niet stekplichtige onderdelen zoals scharnieren, sloten, randverwarming en verlichting voor alle typen koelingen en vriezers.
https://koelcel-onderdelen.com

Koeltechnische deurrubbers eenvoudig online op maat bestellen.
Eigen productie en snelle levering.
https://123-deurrubbers.com


User avatar
Expert Member

Posts

Joined
Sat Jun 25, 2011 4:09 am
Location - Alkmaar Holland

Post by Fitnessprof » Wed Mar 07, 2018 8:05 pm

Hallo,

Is er nog een oplossing uit dit probleem gekomen? Ik heb nl een vergelijkbaar probleem gekregen nadat mijn hosting provider onze site heeft overgezet naar het nieuwe hosting platform waar we gebruik kunnen maken van een ssl certificaat. Alles lijkt nu te functioneren, de hele site draait onder https alleen worden er geen afbeeldingen geladen in de store front en in het admin panel zijn ook geen afbeeldingen te zien. In de image manager worden geen afbeeldingen getoond en uploaden lukt ook niet. Dan krijg ik de melding "warning: directory does not exist"

Alle acties uit dit topic heb ik ook al doorlopen. Binnen opencart ssl aangezet. config.php in de root en in admin aangepast naar https. .htaccess aangepast, cache geleegd.
Ik ben nu al een paar dagen bezig om met de hosting provider dit probleem op te lossen, maar deze komt nu ook op een punt dat ze het niet meer weten. Volgens de hosting provider staan alle paden in de config.php goed. rechten op de image map is ook goed. Wat kan er nu nog aan de hand zijn, iemand een idee? Oh ja ik gebruik versie 2.3.0.2 van opencart

Groeten, Jeroen

Newbie

Posts

Joined
Tue May 30, 2017 2:54 am


Post by victorj » Wed Mar 07, 2018 8:15 pm

De oplossing was dat het opgelost is.
Geef even aan met welke versie oc je werkt, sommige zijn erg koppig en die moet je met wat geweld in het gareel trappen.

Koeltechnische deurrubbers eenvoudig online op maat bestellen.
Alle niet stekplichtige onderdelen zoals scharnieren, sloten, randverwarming en verlichting voor alle typen koelingen en vriezers.
https://koelcel-onderdelen.com

Koeltechnische deurrubbers eenvoudig online op maat bestellen.
Eigen productie en snelle levering.
https://123-deurrubbers.com


User avatar
Expert Member

Posts

Joined
Sat Jun 25, 2011 4:09 am
Location - Alkmaar Holland

Post by Fitnessprof » Wed Mar 07, 2018 8:57 pm

Ik gebruik versie 2.3.0.2 van OC

Newbie

Posts

Joined
Tue May 30, 2017 2:54 am


Post by Fitnessprof » Thu Mar 08, 2018 3:49 pm

Het is opgelost! Ben er gelukkig nog uitgekomen met de hosting provider. Blijkt dat er op het nieuwe hosting platform een home folder bij gekomen is. Uiteindelijk was dus toch het pad in de config.php niet juist.

Newbie

Posts

Joined
Tue May 30, 2017 2:54 am

Who is online

Users browsing this forum: No registered users and 9 guests